12 Replies Latest reply: Feb 22, 2012 6:37 PM by alchemy9 RSS

    keyboard problems with workstation 8

    rcgill Lurker

      Hi,

       

      I'm running vm workstation 8 on a winXP pro x64 2003, sp2, fully updated, fresh, very-clean install, with zero other programs than vmware workstation. Hardware is Xeon E5520 with 12G, keyboard/mouse is logitech wireless via usb. I've experienced the problem described below both with and without the vm extended keyboard driver installed. vm tools have been installed and re-installed on all guests.

       

      My main guest is an Opensuse 11.4 machine. Everything works fine until I also boot up one or more win guests. When I switch back to the opensuse machine after being a win guest the keyboard seems to report double-hits to the os...at least everytime I hit a key, my editor (emacs) behaves as if I've hit the key two or more times.

       

      Sometimes I can fix the problem by restarting emacs; sometimes by restarting the opensuse vm; and sometimes by rebooting the host.

       

      Searched and can't find any solutions. Obviously, w/out a soln vm workstation 8 is unusable.

       

      Any hints before I switch to virtualbox?

       

      Regards,

      Rawld

        • 1. Re: keyboard problems with workstation 8
          timmattison Lurker

          I am experiencing the same issue so maybe we can experiment and figure it out before we both switch to different virtualization platforms.

           

          First, this issue seems to happen under all of my virtual machines when the disk load is high.  It's as if the keyboard "make" code gets to the guest OS and then it is several seconds before the "break" code makes it there which causes the guest to think I am holding a key down.  This can range from just a few repeats to a few dozen repeats and happens especially when I am background snapshotting a VM.  I do not expect to find a solution for this issue.

           

          Second, the issue happens for me very consistently under 32-bit Kubuntu running 2.6.22-14-generic but not under my 64-bit Debian running 2.6.32-5-amd64.  Both VMs have updated VMware tools and I have rebooted the host and the guest OS several times.  Both VMs also have their hardware configurations updated to VMware 8 format/specs.

           

          Do you have any of the same criteria here like the difference between your host running 64-bit and your guest running 32-bit?  Are you running similar kernels ("uname -a" will show that information)?

           

          I am running Windows 7 Ultimate x64 SP1 (6.1.7601) w/ 24 GB RAM on a Core i7 930 and VMware Workstation 8.0.0 build-471780.

           

          My possible solutions are the following (in increasing order of effort):

           

          1) Attempt to decrease the keyboard repeat rate to see if that makes a difference.  This will probably work for situation #1 but not situation #2.

          2) See if there are any accessibility options that can catch situation #2 in Kubuntu as accidental keypresses and filter them out.  This may make typing certain words a bit tricky if it even exists.

          3) Write a Linux (X?) application that catches keyboard "make" codes and immediately sends the "break" code for every keypress.  This will break all key repeating.

          4) Hook the WM_* events related to the keyboard in Windows to do essentially the same thing in solution #3.  However, I have tried this for an unrelated project and couldn't get keyboard hooks to trap the keys sent to VMware.

           

          Beyond solution #2 we are starting to get a bit crazy.  Hopefully we can figure something out without resorting to that.

          • 2. Re: keyboard problems with workstation 8
            timmattison Lurker

            In Kubuntu I have found "Bounce keys" in System Settings -> Accessibility -> Keyboard Filters.  It lets you set a delay before the system will accept another keystroke.  The lowest delay is 100 milliseconds though so depending on how fast you type this could become a real hinderance.  In the meantime it is making it a little easier to deal with my current setup but I will keep looking for a better solution and post here if I find anything.

            • 3. Re: keyboard problems with workstation 8
              timmattison Lurker

              Turns out "bounce keys" didn't work for me consistently.  Instead I went to System Settings -> Keyboard & Mouse and disabled keyboard repeat.  No more duplicate characters but it's still a workaround.  Let me know if that works for you.

               

              It's interesting to note that in the VMs that this issue affects the keyboard and mouse input lag significantly versus other guest OSes and the host OS.  Do you notice that as well?

              • 4. Re: keyboard problems with workstation 8
                rcgill Lurker

                Hi timmattison,

                 

                I did a fresh install of win7pro (x64) on my workstation. As mentioned the workstation is an 8-core xeon w/ 12G or ram. I've also switched to a ssd for the os, vmware software, and virtual machines (still have spinners for backup).

                 

                The os install was as clean as you can get...followed http://tweakhound.com/ advice and *nothing* is installed other than the os and vmware...no virus protection, no special kb drivers, no nothing! So vmware can't say there's a conflict.

                 

                Still had the problem.

                 

                Rev'd all the vm machines to the new format. Reinstalled all tools.

                 

                Still had the problem.

                 

                On a whim, looked through the opensuse software repos to see if there were any magical packages. I found

                 

                vmware-guest-kmp-default  (Open Virtual Machine Tools)

                 

                This had actually been automatically installed when I originally installed openSuse on vm workstation7. At that time, I removed it before intalling vmware tools (from vmware). In any event, I re-installed it (without first removing the currently-installed vmware tools) and things are much improved. Not perfect...sometimes it feels like the kb or mouse is missing events now, but at least I don't get a bounce.

                 

                I'm still irritated because the kb/mouse doesn't feel perfect...even with a super-powerful workstation and no load. Also, the utter lack of vmware support is bad. I called sales, and they basically said, though nicely, "good luck, nothing we will do unless you buy, and then, even if we can't fix it, no refund".

                 

                It's pretty clear to me that vmware doesn't care about it's workstation customers too much (which is fine if that's their business decision). But, at this point, I leaning towards losing a day and trying virtualbox.

                 

                Rest assured, I'll write a sidebar in my next book about this. A good vm environment is a requirement for a professional webdev.

                 

                Thanks for your help on this issue!

                 

                Regards,

                Rawld

                • 5. Re: keyboard problems with workstation 8
                  timmattison Lurker

                  Sorry to hear about your trouble.  I think that reinstalling that package and tuning your keyboard repeat may work.  It worked in my case and while it still doesn't feel perfectly responsive I'm no longer repeating keystrokes all the time and I also don't lose any of them either.

                   

                  I haven't tuned it yet but I think I will soon set my key repeat to a less aggressive value.  Rather than just turning it off completely it that should resolve the problem for me (but not the input lag) and still leave me with some form of keyboard repeat.

                   

                  If I find any tweaks to make my VM feel as snappy as the other 64-bit VMs I have I'll post them here.

                   

                  I thought about switching to Virtualbox for a bit but at this point in my development I didn't want to play with another variable.  This setup is adequate and hopefully soon I can get rid of my older VMs that exhibit this issue anyway.

                   

                  Good luck!  Feel free to message me if you decide to try VMware again and want some extra eyes on the issue you've come across.

                  • 6. Re: keyboard problems with workstation 8
                    rcgill Lurker

                    Here's more.

                     

                    Now when I...

                     

                    1. Fresh boot host.

                    2. start vmware workstation

                    3. boot the opensuse vm

                    4. go to full screen mode on the opensuse vm

                    5. go back to the host

                     

                    keyboard completely fails on host

                     

                    I can go back to vm and kb ok.

                     

                    shut down opensue vm

                     

                    kb still dead on host (mouse always ok)

                     

                    shut down vmware workstation

                     

                    kb still dead on host

                     

                    logoff-logon on host

                     

                    kb it back to life

                     

                     

                    This happened three times in a row. Yes just tried to dup and now I can't get a dup.

                     

                    But, clearly, something is wrong with kb!

                    • 7. Re: keyboard problems with workstation 8
                      timmattison Lurker

                      Interesting.  Is this a USB keyboard?  If so, check the icons in the lower right of the VMware window (when it's not full screen) and see if for some reason VMware is treating this as a generic USB device, disconnecting it from the host, and then connecting it only to your VM.

                       

                      I've never seen this happen before so I can only guess that that is what is going on.  In the event that that is what is happening could you post what kind of keyboard you are using?

                      • 8. Re: keyboard problems with workstation 8
                        rcgill Lurker

                        Yeah, I checked that when I first started having the problem (and just rechecked). The kb/mouse is not showing up as a usb device (which is expected/normal).

                         

                        Anyhow, I went ahead and paid to upgrade to ws8 which gives me a month of supposed real tech support. I filed a ticket immediately. We'll see what they say.

                         

                        I really don't want to go through the pain of setting up 10 vms in a new environment! The $ risk is small. I'll let you all know how it goes with the vmware folks.

                        • 9. Re: keyboard problems with workstation 8
                          SoftRite201110141 Novice

                          I just upgraded to VM 8 and find it acting much worse than VM 7 - the mouse and keybord delays and instabilities are just crazy. What could they have done to make a perfect product worse? I guess I wil uninstall 8 and go back to 7... I don't have time to screw around with it... like I have WORK to do!

                           

                          Host is Win 7 Ultimate - Quad core cpu w/ 4 gigs - wireless Microsoft keyboad and mouse. VM is Windows XP 64 Professional. All this worked flawlessly on VM 7... now half the time it misses mouse clicks and/or there is a LONG delay in responding... which makes you click again... which causes problems.

                           

                          YUK!

                          • 10. Re: keyboard problems with workstation 8
                            rcgill Lurker

                            I agree, clearly, something is wrong.

                             

                            I'm working with tech support to solve this problem. If you can give me a reproducible case, I'll try to repro on my machine and pass to tech support.

                             

                             

                             

                            Thanks,

                            Rawld

                            • 11. Re: keyboard problems with workstation 8
                              SoftRite201110141 Novice

                              I got better keyboard/mouse response by:

                               

                              1.)

                              The default settings are Preferences/"Allow some virtual memory to be swapped". Switch to "Fit all virtual memory into ...", this could be a reason why you use less RAM and you get some freezing.

                               

                              On win 7 you have to right click on the VMware IDesktop con and select "Run as Administrator" or the controls in the Edit dropdown that allow this are greyed out.

                               

                              2.)

                              Killing the floppy drive at the bottom right of the VMware screen

                               

                              I am now better friends with VMware 8...

                              • 12. Re: keyboard problems with workstation 8
                                alchemy9 Lurker

                                I had keyboard issues running a vmware image version 6.5-7. Ugrading the vmware image to 8 fixed the issue.

                                 

                                 

                                power down the image (do not pause)

                                 

                                right click image name, choose manage> change hardware compatability...

                                 

                                 

                                new window opens - change hardware compatability Wizard

                                 

                                click next button

                                 

                                choose workstation 8 in the hardware compatability option.

                                 

                                click next...

                                 

                                fixed