12 Replies Latest reply on Feb 5, 2013 10:43 PM by robgj821

    USB passthrough

    StarBuilder Lurker

      I am running ESXi 5.0 on an HP BL460c G1.

      Guest OS is Windows Server 2003 Standard Edition SP1.

      vSphere Client is running on Server 2003 Standard SP2.


      I'm trying to virtualize an old server that is critical to daily functions because the hardware it is currently on is 6 years old and management doesn't want to spend the cash to have it replaced.


      One of the requirements for the software is a security device that is currently parallel but we can get a USB version.


      Now the problem is I can't get any USB devices to connect to the virtual machine that I've created.


      • I tried to do a USB passthrough under the Host's configuration>Advanced Settings; but it tells me "Host does not support passthrough configuration"


      • I tried to connect a USB device from the vSphere Client machine; It warns me the device is about to be unplugged from the host and connected to the virtual machine. Then after clicking "ok" I get the message "The remote device on <virtual machine> connected to <usb device> is disconnected." 


        It actually shows the virtual machine name instead of <virtual machine> and <usb device> is "v2.0.33"


      Is there a way to fix this disconnecting usb device?

        • 1. Re: USB passthrough
          Dave.Mishchenko Guru
          User Moderators

          > Host's configuration>Advanced Settings

          This is for enabled VMdirectpath.  You don't need that for USB passthrough.


          It might be more ideal to connect the USB device directly to the host.  In that case

          1) Edit the VM and add a USB controller.  You'll do this on the Hardware tab.

          2) Add a USB device to the VM.  You'll also do that on the Hardware tab for the VM.



          VMware Communities User Moderator


          Free ESXi Essentials training / eBook offer

          Now available - VMware ESXi: Planning, Implementation, and Security

          Also available - vSphere Quick Start Guide

          • 2. Re: USB passthrough
            StarBuilder Lurker

            The VM already has a USB controller added.

            But your second point helped.


            I didn't realize you had to add the device in the hardware screen.

            I've mainly used VM Workstation before where it would automagically attach itself.


            Anyways it works now. Thanks.

            • 3. Re: USB passthrough
              brainslice Enthusiast

              One issue with attaching the USB dongle to the host is that you cannot vMotion the dongle.


              I have several VMs which require software dongles.  I've been using a Digi AnywhereUSB/14 box to to connect the USB over IP.


              Works perfectly with vMotion.  It's also useful for some of the lab workstations that use very expensive software USB dongles.  I can lock the dongles away in the datacenter preventing the sticky fingers from "borrowing" them.



              • 4. Re: USB passthrough
                Dave.Mishchenko Guru
                User Moderators

                Something like the Digi Anywhere USB solution is ideal if you have to move a VM around.  However, you can vMotion a VM with a host attached USB device and it will continue to work (until the VM is powered down / suspended).


                Configuring USB Devices for vMotion

                With USB passthrough from a host to a  virtual machine, you can migrate a virtual machine to another ESXi  host in the same datacenter and maintain the USB passthrough device connections  to the original host.

                If  a virtual machine has USB devices attached that pass  through to an ESXi  host, you can migrate that virtual machine with the devices attached.

                For  a successful migration, review the following conditions:

                You  must configure all USB passthrough devices  connected to a virtual machine for vMotion. If one or more devices is not  configured for vMotion, the migration cannot proceed. For  troubleshooting details, see the vSphere  Troubleshooting documentation.

                When  you migrate a virtual machine with attached USB devices away from the host to  which the devices are connected, the devices remain connected to the virtual  machine. However, if you suspend or power off the virtual machine, the USB devices are disconnected and  cannot reconnect when the virtual machine is resumed. The device connections can  be restored only if you move the virtual machine back to the host to which the  devices are attached.

                If  you resume a suspended virtual machine that has a Linux guest operating system,  the resume process might mount the USB devices at a different  location on the file system.

                If  a host with attached USB devices resides in a DRS  cluster with distributed power management (DPM) enabled, disable DPM for that  host. Otherwise DPM might turn off the host with the attached device. This  action disconnects the device from the virtual machine because the virtual  machine migrated to another host.

                • 5. Re: USB passthrough
                  brainslice Enthusiast

                  Host maintenance or a host outage would disable the USB if attached to the host.  Just something to consider for your application availability.

                  • 7. Re: USB passthrough
                    TopoGigio201110141 Lurker

                    Hi Dave,

                    my problem is slightly different: I need to connect an IOmega REV 120 to a virtualized Windows Server 2003 (or, in future, 2008) to perform certain fast backups.

                    I can't use Digi device due to USB 1.1 speed.

                    I'd like to connect the REV directely to USB on host (running ESXi 5.0, of course)


                    Any help will be appreciated :-)




                    • 8. Re: USB passthrough
                      TCNS Novice

                      Hi there,


                      I have a problem where I am unable to passthrough any USB device to a VM.  At the moment I want to passthrough a usb drive to a VM of a SBS2008 server.  I have installed the USB controller onto the VM however when you go to add another device the option for "USB device" is not present thus I am unable to passthrough the usb drive.  You could do this easily with ESXi 4.1 however it does not seem to work with 5.0 - is this a bug?


                      Have tried restarting the managements agents and it is a HP Proliant ML350 G6 if that has any bearing on it.


                      Any advice would be greatly appreciated.


                      Many thanks,



                      • 9. Re: USB passthrough
                        keatho Lurker

                        I am having the same issue as Jasper.

                        After upgrading to ESXi 5 the USB devive is unavailable and can't be added to the VM.


                        Has anyone seen this before?



                        • 10. Re: USB passthrough
                          BAnderson875 Lurker

                          Double check your VM hardware version, I had this issue just yesterday, couldn't figure out why USB Device would show up under some machines and not others. I had overlooked the fact that the last 2 machines I converted from physical to virtual got imported with VM hardware version 4 instead of 8, I ran my update manager and upgraded to VM hardware version 8 and now I am able to add USB devices to those machines.

                          • 11. Re: USB passthrough
                            JaySMX Hot Shot

                            I had a similar issue with ESXi 5, it turns out there's an issue with hostd loading before the usbartibrator.  Check out this KB


                            • 12. Re: USB passthrough
                              robgj821 Novice

                              Hi Brainslice


                              In regards to the  Digi AnywhereUSB/14 box have you come across any license dongles or software that this USB over IP method does not work for?