1 2 3 Previous Next 33 Replies Latest reply on Sep 22, 2018 11:22 PM by TTyz

    ESXi 5 esxcli installation of VIBs fails

    yozh Novice

      Well to tell you the thruth it doesnt even start.....

       

      I`m trying to install 1000v VIB via CLI directly on the host via SSH.

       

      Here is what I get

       

      [CODE]

      esxcli software vib install /tmp/VEM500-201108271.zip

      Error: Unknown command or namespace software vib install /tmp/VEM500-201108271.zip

      [/CODE]

       

      Even to list installed VIBs.

      [CODE]

      esxcli software vib list
      Error: Unknown command or namespace software vib list

      [/CODE]

       

      What am I doing wrong ? This is a new ESXi 5 install (upgrade from 4.1)

        • 1. Re: ESXi 5 esxcli installation of VIBs fails
          Cr0n_J0b Novice

          Same issue here.  I'm just trying to patch the server.  I don't have update manager and I'm using the same CLI tools that I had from the 4.1 days.

          • 2. Re: ESXi 5 esxcli installation of VIBs fails
            Dave.Mishchenko Guru

            If you're doing this at the console you'll want to use one of the options to specify a VIB file -  -n/--vibname or -v/--viburl.

             

            Remotely, you'll want to update the version of the vCLI that you're using.  esxcli has been significantly enhanced in the 5.0 release.

            • 4. Re: ESXi 5 esxcli installation of VIBs fails
              yozh Novice

              I`m really not sure what I did last time, but I`m trying to upgrade to a VIB on my ESXi and its still not working, from vCLI or shell

               

              Error: Unknown command or namespace software vib list

               

              PLease help, as I need to update ASAP.

              • 5. Re: ESXi 5 esxcli installation of VIBs fails
                Novice

                Can you try running

                 

                esxcli software vib list

                 

                and if it fails look through /var/log especially esxcli.log and hostd.log and post any related messages?

                • 6. Re: ESXi 5 esxcli installation of VIBs fails
                  yozh Novice
                  /bin # esxcli software vib list
                  Error: Unknown command or namespace software vib list
                  /bin # more /var/log/esxcli.log
                  [root ERROR] Unknown command or namespace software vib list
                  /bin #
                  • 7. Re: ESXi 5 esxcli installation of VIBs fails
                    Novice

                    What does

                     

                    grep -r ERROR /var/log

                     

                    give you?

                    • 8. Re: ESXi 5 esxcli installation of VIBs fails
                      Novice

                      Also can you post the output of

                       

                      esxcli --help

                       

                      it should list the available namespaces

                      • 9. Re: ESXi 5 esxcli installation of VIBs fails
                        yozh Novice

                        See below, I remmber it was something where I had to specify something like, esxcli IMAGE_or_something software that was for vem-cmd, never mind

                         

                         

                        /bin # grep -r ERROR /var/log
                        /var/log/vmware/vua-1.log:-->       <result>ERROR</result>
                        /var/log/vmware/vua-1.log:-->       <result>ERROR</result>
                        /var/log/vmware/vua-1.log:--> ERROR:root:Mount failed: (256) mount: applet not found
                        /var/log/vmware/vua-1.log:-->       &lt;result&gt;ERROR&lt;/result&gt;
                        /var/log/vmware/vua-1.log:-->       &lt;result&gt;ERROR&lt;/result&gt;
                        /var/log/vmware/vua-1.log:--> ERROR:root:Mount failed: (256) mount: applet not found
                        /var/log/vmware/vua.log:-->       <result>ERROR</result>
                        /var/log/vmware/vua.log:-->       <result>ERROR</result>
                        /var/log/vmware/vua.log:--> ERROR:root:Mount failed: (256) mount: applet not found
                        /var/log/vmware/vua.log:-->       &lt;result&gt;ERROR&lt;/result&gt;
                        /var/log/vmware/vua.log:-->       &lt;result&gt;ERROR&lt;/result&gt;
                        /var/log/vmware/vua.log:--> ERROR:root:Mount failed: (256) mount: applet not found
                        /var/log/.vmsyslogd.err:2012-01-17T02:46:11.592Z vmsyslog.main            : ERROR   ] reloading (2642)
                        /var/log/esxcli.py.log:[root ERROR] Unknown command or namespace software vib list
                        /var/log/syslog.log:2012-01-28T11:14:35Z sfcb-vmware_base[113384]: ERROR READING FROM SOCKET
                        /var/log/shell.log:2012-02-29T18:47:10Z shell[1877788]: vmgrep -r ERROR /var/log
                        /var/log/shell.log:2012-02-29T18:47:10Z shell[1877788]: grep -r ERROR /var/log
                        /var/log/esxcli.log:[root ERROR] Unknown command or namespace vm
                        /bin #
                        • 10. Re: ESXi 5 esxcli installation of VIBs fails
                          yozh Novice
                          /bin # esxcli --help
                          Usage: esxcli [options] {namespace}+ {cmd} [cmd options]
                          Options:
                            --formatter=FORMATTER
                                                  Override the formatter to use for a given command. Available
                                                  formatter: xml, csv, keyvalue
                            --debug               Enable debug or internal use options
                            --version             Display version information for the script
                            -?, --help            Display usage information for the script
                          /bin #
                          • 11. Re: ESXi 5 esxcli installation of VIBs fails
                            Novice

                            Ok, somehow the esxcli infrastructure doesn't find the namespace plugins. Can you run this command

                             

                            find /usr/lib/vmware/ | grep -i esxcli

                             

                            and post the result?

                            • 12. Re: ESXi 5 esxcli installation of VIBs fails
                              yozh Novice

                              REALLY THANK YOU for helping me...

                               

                               

                               

                              /bin # find /usr/lib/vmware/ | grep -i esxcli
                              /usr/lib/vmware/esxcli
                              /usr/lib/vmware/esxcli/ext
                              /usr/lib/vmware/esxcli/ext/cisco.xml
                              /usr/lib/vmware/esxcli/ext/esxcli-syslog.xml
                              /usr/lib/vmware/esxcli/ext/esxcli-software.xml
                              /usr/lib/vmware/esxcli/libfcoe.so
                              /usr/lib/vmware/esxcli/libvms.so
                              /usr/lib/vmware/esxcli/libhardware.so
                              /usr/lib/vmware/esxcli/libsystem.so
                              /usr/lib/vmware/esxcli/libnetwork.so
                              /usr/lib/vmware/esxcli/libcore-storage.so
                              /usr/lib/vmware/esxcli/int
                              /usr/lib/vmware/esxcli/int/ext
                              /usr/lib/vmware/esxcli/int/ext/hostprofile.xml
                              /usr/lib/vmware/esxcli/int/libdebug.so
                              /usr/lib/vmware/esxcli/int/libboot.so
                              /usr/lib/vmware/esxcli/int/libsched.so
                              /usr/lib/vmware/esxcli/int/libnetworkinternal.so
                              /usr/lib/vmware/esxcli/int/libcore-storage-internal.so
                              /usr/lib/vmware/esxcli/libiscsi.so
                              /usr/lib/vmware/hostd/docroot/esxcli.css
                              /usr/lib/vmware/hostd/cgi-bin/esxcli.cgi
                              /usr/lib/vmware/esxcli-software
                              /bin #
                              • 13. Re: ESXi 5 esxcli installation of VIBs fails
                                Novice

                                Hmm that looks all correct. Just to verify my assumption you are running in a root shell right? Can you type

                                 

                                who

                                 

                                and post the output?

                                • 14. Re: ESXi 5 esxcli installation of VIBs fails
                                  yozh Novice

                                  I`m on the root shell, I also tried from vCLI and get exactly same results

                                   

                                   

                                  /bin # who
                                  USER       TTY              IDLE      TIME            HOST
                                  root       char/pty/t1      00:00     Feb 17 21:07:08 win7quad.lan
                                  root       char/pty/t2      00:00     Feb 29 18:18:52 win7quad.lan
                                  /bin #
                                  1 2 3 Previous Next