3 Replies Latest reply on May 19, 2011 11:49 AM by mittim12

    Remote VDI Access Issues

    caryers Enthusiast

      I took my work (Win7) laptop home last night, and placed it side by side with my ThinClient (HP t5740e) device(Windows 7 Embedded) and my personal(WinXP SP2) PC. Both the laptop and my personal PC sporadically have connectivity issues upon connection. The connections timed-out 2 or 3 times before I got a successful connection to my desktop. Each failed connection initially connects fine maining I get my authentication prompt each and every time, the username & password is accepted. I see the two media pools I have access to. I select one and my desktop starts to size. However, a black window will only appear. After ~20 seconds I get the infamous error message: “ The remote computer has ended the connection”. However, the Thinclient was stable upon first connection as usual. My work laptop works fine internally at work. This is only a remote connection issue. I do not have any devices internally at work that has these same sporadic connectivity issues.

       

      To add to this issue, another colleague of mine has the same sporadic connectivity issue on his personal (Win 7 Home Edition x64 bit) Laptop. He has a dual-boot laptop. He then boots into Ubuntu 11.x(Linux distribution) and downloaded the Open View client from Linux (http://code.google.com/p/vmware-view-open-client/) and stays connected all the time and experiences NO time out connections.

       

      Another colleague is using his personal iPAD iOS Verizon G3 using the View client from the Apple store (v.1.0.1  Updated 3/09/2011). He has very good connectivity. However, he does indicate he gets the infamous time-out message. I am willing to bet it is due to the wireless G3 connection. My guess.

       

      Yet another colleague has a personal MAC and uses the View client remotely with no connectivity issues.

       

      So in summary, I believe our remote connectivity issues are NOT ISP or work Firewall related. The common thread with the connectivity issues I talked about above is the Windows(Win XP or Win7) client.

       

      Can you tell me if there is any VDI log file(s) with paths either on the client side or the Security Server or even the connection server that I could review to help troubleshoot these remote connectivity issues?

       

      Any insight or experiences would be greate. We are a pure 4.6 shop. 4.6 Agents, Connection server, security server, client, etc.

       

      Let me know if anymore information is needed to help troubleshoot this issue. Thanks in advance…

      Scott

        • 1. Re: Remote VDI Access Issues
          mittim12 Guru
          User Moderators

          The black screen and then the disconnect is a common issue when PCOIP isn't setup correctly from outside the company network.   Previous to View 4.6 you could not access PCOIP from outside the network unless you were connected via VPN.   With the release of 4.6 PCOIP is available but there are certain rules that must be followed.

           

           

          1:   From your home connections can you verify which protocol you are using?

           

          2:  If you are connecting via PCOIP make sure you are on View 4.6.  If not you will have to use RDP or utilize VPN until upgraded to View 4.6

           

          3:    If you are already on View 4.6 you will need to make sure the instructions on this document have been followed, http://communities.vmware.com/docs/DOC-14974.

           

           

           

          Also here is a link to View log locations.   http://kb.vmware.com/kb/1027744

          • 2. Re: Remote VDI Access Issues
            caryers Enthusiast

            1:   From your home connections can you verify which protocol you are using? PCoIP

             

            2:  If you are connecting via PCOIP make sure you are on View 4.6.  If not you will have to use RDP or utilize VPN until upgraded to View 4.6

                 We are a complete 4.6 VDI shop.

            3:    If you are already on View 4.6 you will need to make sure the instructions on this document have been followed, http://communities.vmware.com/docs/DOC-14974.

                  I have seen this link bfore. All ports are opened on the FW as indicated.

             

            I agree the the black screen and then the disconnect is a common issue when PCOIP. At this when this occurs remotely, I can hit the ESC key and the desktop appears, but not all the time.

             

            Not sure what you mean when you say " ....when PCOIP isn't setup correctly from outside the company network"

             

            How would you setup PCoIP correctly from outside the company network???

             

            Any feedback would be great!

            • 3. Re: Remote VDI Access Issues
              mittim12 Guru
              User Moderators

              I was actually just referring to the document.  In my experience if you have setup everything as the document states then PCOIP should work right out of the box with no problems.

               

              Have you  tested this from multiple images?   Maybe XP works and Windows 7 does not work.