8 Replies Latest reply on Feb 10, 2011 6:46 PM by lamw

    backup of specific vmdk file vanishes?

    monostereo Lurker

      Hi there, first of all i must say this script is excellent and thanks for all the hard work!


      I have about 12 VM's all backing up nicely via your script, however one of OUR VM's which has two vmdk files is only backing up the first disk, ANNOYINGLY the second vmdk disk which isn't backing up is a data disk that the most important out of all of our disks! 


      i'm getting no errors, and have tried to backup ONLY the disk which is failing via a specific config file for the vm, all seems to go well according to the log but the backup is finished very fast and no vmdk file is present (the virtual machine file is being backed up OK, just no data_01.vmdk)


      The problematic vmdk file  is much bigger then any of the others - around 800GB - could this be why it is failing?  i'm backing up to an iscsi vol which is 2TB in size and is empty (in testing all other vmdk's back up to this volume without a problem so i dont think the issue is with the destination volume)


      The output log shows the backup finishing in 1-min, which is of course far to fast for an 800GB file.  The snapshot IS getting created as i have checked, so i'm baffled as to what the problem could be??  one thing i have noticed is this error when i run the .pl script


      "Use of uninitiated value in numeric le (<=) at ./ghettoVCBg2.pl line 1047."


      Any help very much appreciated!!!


      Link to output Log:


      my setup:

      Current version of ghettoVCBg2

      esxi 4.1

      3 hosts

      Enterprise licence