6 Replies Latest reply on Feb 14, 2011 8:42 AM by nord

    problems

    nord Novice

      Hello,


      I started to have problems with  ghettoVCBg2.


      I am using VMware vSphere 4 Essentials. ESXi 4.1.

       

      I want backup 3 VMs. Backups are put on NFS server. It worked few days, but after week I noticed, that only 1 VM is backed up. When I run backup script I am getting this message:

       

      Can't call method "rootFolder" on an undefined value at /usr/lib/perl5/5.8.8/VMware/VICommon.pm line 1218.

      A thread exited while 2 threads were running.

       

      Here is ghettoVCBg2 log when I run backup script : http://pastebin.com/EWCFuYjr

       

      This way I run backup script:

       

      /home/vi-admin/ghettoVCBg2/ghettoVCBg2.pl --config_dir /home/vi-admin/ghettoVCBg2/backup_config --vmlist /home/vi-admin/ghettoVCBg2/virtual_machine_backup_list --dryrun 0

       


        • 1. Re: problems
          lamw Guru
          Community WarriorsVMware Employees

          Hello,

           

          Not sure if you read the announcement on this forum, please don't post output on the forums, it's very difficult to read. Please post it on http://pastebin.com and provide a link.

           

          Dryrun does not actually perform the actual execution, if you're still hitting the problem, I need to see debug logs during execution. Unfortunately the error is pretty generic, it possibly could be due to some type of failed lookup. I would need to see the logs when this occurs to get a better understanding. Also is this part of a VMware cluster? Is DRS enabled automatically? Anything else that may have gone around the time of the backup? Is this consistently happening or just happened once? I need as much detail as you can provide to help troubleshoot the problem.

          • 2. Re: problems
            nord Novice

            what logs do you mean? using 

            --verbose (variable VI_VERBOSE)
                  Display additional debugging information

            option ?

            • 3. Re: problems
              lamw Guru
              VMware EmployeesCommunity Warriors

              The logs will be generated if you actually perform the run, if you do a dryrun, nothing is happening, does that make sense? Please refer to the documentation if you have more questions.

               

              I would still like to understand the issue and I had a few questions in my last reply that haven't been answered.

               

              Thanks

              • 4. Re: problems
                nord Novice

                I will try to answer your questions.

                 

                VMware cluster? Is DRS enabled automatically? No, this is only 2xESX hosts, which are managed by vCenter, there are not in cluster mode, there is not DRS function  enabled.

                 

                It happen when all 3 or 4 VMs are backed up. When I am using one or two VMs in  virtual_machine_backup_list it works without problems. Here is VMs backup configuration files: http://pastebin.com/CtUbaXRF

                 

                Here is how I run ghetto script and the output:

                 

                /home/vi-admin/ghettoVCBg2/ghettoVCBg2.pl --config_dir /home/vi-admin/ghettoVCBg2/backup_config --vmlist /home/vi-admin/ghettoVCBg2/virtual_machine_backup_list --dryrun 0
                Can't call method "rootFolder" on an undefined value at /usr/lib/perl5/5.8.8/VMware/VICommon.pm line 1218.
                A thread exited while 2 threads were running.

                 

                Here is ghettoVCBg2 log (LOG_LEVEL=debug): http://pastebin.com/gZNfWeiR

                • 5. Re: problems
                  nord Novice

                  I still cant solve this problem. I did "--verbose" mode. Here is verbose log: http://www.bgm.lt/vmware/verbose.rar

                   

                  Again I get this message:

                   

                   

                  Can't call method "rootFolder" on an undefined value at /usr/lib/perl5/5.8.8/VMware/VICommon.pm line 1218.

                  A thread exited while 2 threads were running.

                  • 6. Re: problems
                    nord Novice

                    Could you help me to solve this problem, I am still confused

                    do you need more logs?

                     

                    Does this problem belongs to:

                     

                    17Q: I'm running into an issue when I backup my VMs  using NFS on  Linux, I'm able to either get 1 successful backup and all  subsequent  backups fail OR I'm having issues where snapshots are not  being removed  upon completition and future backups fail.

                    17A: This problem/issue has been reported by quite a few users in  the  community and only affects a very small percentage of users overall   under a specific configuration. The problem as I understand it today   which is still an on-going investigation by myself and the community is   as follows: