9 Replies Latest reply: Oct 14, 2011 2:39 PM by WoodyZ RSS

    How do I disable time synchronization with host?

    Niedhart003 Novice

      I know this topic has come up before, and I've read at least some of the discussions regarding it, and I hope I've read them all, but I STILL cannot disable the time synchronization between guest and host.  I've also read the Timekeeping in Virtual Machines Guide.


      Here's what I've got:

       

      VMware Workstation Version 7.1.3 running on a Windows 7 host, with Windows XP Professional running in Workstation.

       

      In VMware Tools, the Time synchronization box is unchecked.

       

      In my .vmx file, at the end of the file:

       

      tools.synchTIME.period = 600
      tools.synchTIME = "FALSE"
      tools.synchronize.continue = "FALSE"
      tools.synchronize.restore = "FALSE"
      tools.synchronize.resume.disk = "FALSE"
      tools.synchronize.resume.memory = "FALSE"
      tools.synchronize.shrink = "FALSE"
      tools.synchronize.tools.startup = "FALSE"
      rtc.startTime = 1074859200

       

      I've also tried the same commands when running Windows XP in VMware Player, and in that case I've also tried replacing "FALSE" with "0".  No luck.

       

      You'll notice that in trying to debug this I used the command "tools.synchTIME.period= 600" as a attempt to delay the daemon from checking for the time/date on the host.  I can think of at least one reason why this wouldn't/didn't work, but I thought it was worth a try.

       

      I've also used the command "rtc.startTime = 1074859200" to start the virtual machine at a test date - it works perfectly.

       

      Here's what happens:

       

      After I start the virtual machine, with the above commands in the .vmx file, I quickly open the "Date and Time Properties" application in Windows XP by clicking on the time in the lower right of the task bar, and see that the date is set to January 23, 2004 and time to 7:00 pm, just as it should be as a result of the "rtc.startTime = 1074859200" command.  After a few seconds, I can watch the date and time change on the guest in the "Date and Time Properties" application to the same date and time as on the host, which is the problem, of course.

       

      What in heck am I doing wrong?  Perhaps something in .vmx is over riding the above commands?

       

      Thanks and Best Regards.

        • 1. Re: How do I disable time synchronization with host?
          WoodyZ Guru

          The only way I've found to stop date/time synchronization with the Host in the latest releases of the VMware Desktop Products is to have the preferences you've shown and not have VMware Tools installed.  From my tests, once VMware Tools are installed it appears to ignore the preferences.

          • 2. Re: How do I disable time synchronization with host?
            Niedhart003 Novice

            Thanks WoodyZ.

             

            Your experience agrees with what was mentioned is some of the discussions I read before I posted the initial question.  In cases where removing the VMWare Tools was mentioned, if I remember correctly, there was always a response identifying a command that was missing and advising against removing VMWare Tools (I can understand that - VMWare Tools are quite valuable), and then a subsequent response that all was ok after the missing command was implemented, with VMWare Tools still installed.  I think I am using the full set of commands, but I was and still am hoping that something somewhere is missing.

             

            The thing I don't understand is why VMWare tools has the Time Synchronization check box that doesn't seem to work, at least if it's supposed to do what I think.  The other thing is the "rtc.startTime =    " command; it's useless if the time that is set is quickly reset after a few seconds.  I'm a new user, and a bug or badly implemented command seems a little incongruous with what I've seen so far with this nice application - I still think I'm the problem.

            • 3. Re: How do I disable time synchronization with host?
              continuum Guru User Moderators vExpert

              you maybe able to keep the vmware-tools if you use

               

              monitor_control.restrict_backdoor = "true"

               

              but I don't know for sure.

               

              Other then that your vmx looks it has the relevant entries like I described them
              http://sanbarrow.com/vmx/vmx-always-start-tonight.html

               

              I have never tested VMs that have the tools installed when setting a fixed start-time.

              • 4. Re: How do I disable time synchronization with host?
                WoodyZ Guru

                you maybe able to keep the vmware-tools if you use

                 

                monitor_control.restrict_backdoor = "true"

                 

                but I don't know for sure.

                 

                I think I've tried that and it didn't stop it from syncing however I'll test it a bit later and report back.

                • 5. Re: How do I disable time synchronization with host?
                  Niedhart003 Novice

                  Thanks Continuum,

                   

                  I tried adding the "monitor_control.restrict_backdoor = "true" " to my .vmx file.  Here's what I  found:

                  When I powered on the  virtual machine, which is running an activated version of Windows XP, I got a  message that Windows XP activation was required, and was returned to the Windows  logon screen.

                  I shut down VMWare Workstation, removed the "monitor_control.restrict_backdoor = "true" " command from the .vmx file, restarted Workstation, and started the virtual machine; it started normally  - no Windows XP activation message.

                  I shut down VMWare Workstation, and again added the  command to the .vmx file; same activation problem, but this time I activated  Windows XP.  The activation was successful, but I noticed that the VMWare  Tools icon is missing from the taskbar.  BUT, it appears that the time Time  Synchronization was disabled successfully.  It appears that there is SOME  VMWare Tools functionality.  I can move the cursor from the host to the  guest with the mouse, but I can't fit the the guest to the virtual  machine window, even though I can resize the virtual machine window (if I remember correctly, I don't think it's possible to resize the virtual machine window without VMWare Tools installed).  I  tried to reinstall VMWare Tools, but the installation  failed.

                  So it appears there  is partial success, but still some annoying glitches.

                  By the way, before adding "monitor_control.restrict_backdoor = "true" " to my .vmx file, I had tried setting the time in the VMWare BIOS.  This  was not a success.  Although the virtual machine starts with the modified BIOS time, it is quickly reset in the virtual machine to the host time, and when  I subsequently check the BIOS, the time there is reset to the host time too.

                  Thanks again and Best Regards
                  • 6. Re: How do I disable time synchronization with host?
                    Niedhart003 Novice

                    Aha.

                     

                    It appears that VMware Tools may be working as it's supposed to.

                     

                    When I start the virtual machine, which is running Windows XP, during the startup process, the time is intially set as specified on the

                     

                    rtc.startTime = 1074859200

                     

                    command in my .vmx file.

                     

                    During the startup process, the VMware Tools is initially disabled (it's over layed by a circle with a slash).  As the startup process continues, VMware Tools starts, and the virtual machine time is reset to the host system time.  This is in accordance with:

                     

                    "These options do not  disable one-time synchronizations done by VMware Tools for events such  as tools startup, taking a snapshot, resuming from a snapshot, resuming  from suspend, or VMotion. These events synchronize time in the guest  operating system with time in the host operating system even if VMware  Tools periodic time sync is disabled, so it is important to make sure  that the host operating system's time is correct."

                     

                    (http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1318)

                     

                    This does seem like a glitch in VMware Tools - it seems like it might be appropriate to not perform the initial synchronization if "rtc.startTime" is set.  It DOES seem like the time synchronization is disabled apart from this initial synchronization.  If I reset the time in Windows XP, the time does seem to remain set to the new value.

                     

                    Evidently, there may be other ways to modify the synchronization (see the link); I haven't yet figured this out.

                    • 7. Re: How do I disable time synchronization with host?
                      WoodyZ Guru

                      Just curious why do you need or want a Virtual Machine to always start at, Fri, 23 Jan 2004 12:00:00 GMT?

                       

                      Anyway...

                       

                      I did some testing on a Windows 7 Guest with VMware Tools installed and in conjunction with the following settings in the .vmx configuration file and disabling Guest OS Level Time Synchronization I found it to maintain the correct time as referenced by the value of rtc.startTime and not sync with the Host.  Of course as usual YMMV.

                       

                      rtc.startTime = "VALID_VALUE"
                      
                      tools.syncTime = "FALSE"
                      time.synchronize.continue ="FALSE"
                      time.synchronize.restore = "FALSE"
                      time.synchronize.resume.disk = "FALSE"
                      time.synchronize.resume.memory = "FALSE"
                      time.synchronize.shrink = "FALSE"
                      
                      monitor_control.restrict_backdoor = "TRUE"
                      
                      • 8. Re: How do I disable time synchronization with host?
                        VM0Sean Enthusiast

                        I know that this is an old thread, and this may be a really stupid question, but did you disable XP's native "Internet Time Sync" option?

                        • 9. Re: How do I disable time synchronization with host?
                          WoodyZ Guru

                          It's not a stupid question and yes it's an old thread and I already mention "disabling Guest OS Level Time Synchronization" to Niedhart003.