1 18 19 20 21 22 Previous Next 814 Replies Latest reply on Sep 26, 2018 12:22 PM by edward_walton Go to original post
      • 285. Re: VMDirectPath and ATI Radeon
        aaronvm Novice

        Thanks for the correction GBowman.  I now see your earlier post about that hardware.  This thread has gotten very long, I have to admit I've been a bit lazy to review it all.  Somehow I missed MrPippy's earlier post about the ACPI tables, that's very interesting.  And it jives with your earlier theory about this being purely a mainboard BIOS issue (and much less to do with chipset, specific GPU card used, etc).

         

        So I was motivated to look into this.  Here are MrPippy's ACPI DMAR lines (before and after, respectively, of his BIOS update that got it working):

         

        [    0.000000] ACPI: DMAR 00000000bf575fd8 000B0 (v01 ALASKA    A M I 00000001 INTL 00000001)  <- before

        [    0.000000] ACPI: DMAR 00000000bf3ae798 00078 (v01 INTEL      SNB  00000001 INTL 00000001)   <- after

         

        Now here is my ACPI DMAR line from dmesg of Ubuntu 11.10 (booted off CD on the SH67H3):

         

        [    0.000000] ACPI: DMAR bf3b58f0 000B0 (v01 ALASKA    A M I 00000001 INTL 00000001)

         

        My output is suspiciously similar to his before it wasn't working.  Interestingly, 000B0 and 00078 are the length fields of the structure, so it actually shrunk after his update.

         

        Now here is some more info from my dmesg during DMAR parsing:

         

        [    0.000000] ACPI: DMAR bf3b58f0 000B0 (v01 ALASKA    A M I 00000001 INTL 00000001)
        [    2.284440] DMAR: Host address width 36
        [    2.284441] DMAR: DRHD base: 0x000000fed91000 flags: 0x1

        [    2.284445] IOMMU 0: reg_base_addr fed91000 ver 1:0 cap c9008020660262 ecap f0105a

        [    2.284447] DMAR: RMRR base: 0x000000bf5ed000 end: 0x000000bf5fbfff
        [    2.284448] DMAR: No ATSR found

         

        Hmm, "No ATSR found".  Anyone have any idea if this is critical for GPU passthrough?  It appears that ATSR stands for "Address Translation Services Remapping", which is described in the following Intel document:

         

        http://download.intel.com/technology/computing/vptech/Intel(r)_VT_for_Direct_IO.pdf

         

        Finally, here is the acpidump output for my DMAR entry:

         

        DMAR @ 0xbf3b58f0
          0000: 44 4d 41 52 b0 00 00 00 01 01 41 4c 41 53 4b 41  DMAR......ALASKA
          0010: 41 20 4d 20 49 00 00 00 01 00 00 00 49 4e 54 4c  A M I.......INTL
          0020: 01 00 00 00 23 01 00 00 00 00 00 00 00 00 00 00  ....#...........
          0030: 00 00 58 00 01 00 00 00 00 10 d9 fe 00 00 00 00  ..X.............
          0040: 03 08 00 00 00 f0 1f 00 04 08 00 00 00 f0 0f 00  ................
          0050: 04 08 00 00 00 f0 0f 01 04 08 00 00 00 f0 0f 02  ................
          0060: 04 08 00 00 00 f0 0f 03 04 08 00 00 00 f0 0f 04  ................
          0070: 04 08 00 00 00 f0 0f 05 04 08 00 00 00 f0 0f 06  ................
          0080: 04 08 00 00 00 f0 0f 07 01 00 28 00 00 00 00 00  ..........(.....
          0090: 00 d0 5e bf 00 00 00 00 ff bf 5f bf 00 00 00 00  ..^......._.....
          00a0: 01 08 00 00 00 00 1d 00 01 08 00 00 00 00 1a 00  ................

         

        I'll need to take a closer look at the aforementioned spec and match up the data here to the documented struct formats, to see if it's sensical or garbage.  I'm really not familiar enough about how these BIOS's are manufacturerd to say anything intelligent about these findings yet, other than observe the identical B0 lengths, and "ALASKA A M I" string.  If I didn't know any better I'd guess that AMI provides a default ACPI table template to the vendors that Shuttle didn't populate with proper data.

         

        Meanwhile, if folks agree this is progress, perhaps MrPippy and others could provide full acpidump's (or at least the DMAR portion) from their working and/or non-working machines?  On Ubuntu, just use "sudo apt-get install acpidump" to install it.

        • 286. Re: VMDirectPath and ATI Radeon
          GBowman Novice

          Which player software are you using?  How have you got the drive connected?

          • 287. Re: VMDirectPath and ATI Radeon
            mindless728 Novice

            I am using AnyDVD HD which is commercial software that allows me to play blu-rays in VLC and the drive is connected to the motherboard SATA connector, this works just fine when it is just windows 7 installed natively

            • 288. Re: VMDirectPath and ATI Radeon
              madsheep Lurker

              I've been using vmware for a long time now, and I have a lot of vm´s too, soo switch to xen will be difficult. 

               

              But does not sound that some have successful in passthrough a gfx card on my motherboard (dq67sw).

              • 289. Re: VMDirectPath and ATI Radeon
                technobro1 Novice

                Hi gentlement ,

                 

                still no luck here , its either i got bsod when i install it or when i enable it from safe mode

                 

                When i disable the svga VMware diver i can install it whiout bsod but windows  doesnt allow me to choose it in resolution settings,


                I read erlier in this post the vmware svga should be WDDM 1.1, how do i install that, should i investigate more this way...

                any help

                 

                Thanks you

                 

                i3770

                Asrock Z77 pro3

                WIn64b

                • 290. Re: VMDirectPath and ATI Radeon
                  aaronvm Novice

                  So a follow-up from the other day.  I used the "iasl" utility from Intel to verify that my ACPI DMAR table is in fact well-formed.  I can't confirm that all of the data in there is actually 100% correct, although PCI passthrough works for an Intel NIC (just not Radeon GPU), so I guess I should assume that DMA remapping is working.

                   

                  Back to a prior theory.  Is anyone doing VGA passthrough successfully w/ ESXi on a machine with Intel graphics present?  That is, not passing through the Intel graphics per-se, but any PCI-E GPU alongside a graphics-equipped Intel CPU (i.e., my CPU is an i5-2500 w/ HD Graphics 2000).  For the next step I was thinking about picking up a Xeon E3-1230 CPU to try in my Shuttle.  It's an LGA1155 CPU that lacks graphics but does include VT-d.  This is not on the officially supported CPU list for the SH67H3, but I found reports of it working.

                   

                  According to ARK, GBowman's i7-870 doesn't have integrated graphics, for example.  Nor do any of the other working configurations that I've looked up on this thread so far (I admit I lack the patience to exhaustively check every single one).  Anyway, the theory is that the Intel graphics are somehow conflicting with the PCI-E GPU.

                   

                  Finally, does anyone know if there's a reliable way to disable onboard graphics entirely (like at chip level)?  In my BIOS, the only selections for graphics are "Onboard" or "PCI-E/Onboard".

                   

                  Thanks all.

                  • 291. Re: VMDirectPath and ATI Radeon
                    GBowman Novice

                    My i7 820 has no integrated graphics as said and my Q6700 has only the motherboard graphics of the intel Q45 chipset.  These are not disabled but do not appear in the list of devices that could be passed through.

                     

                    I will try to run the linux diagnostic on my Q45/Q6700 machine in the next few days.  I cant shut down the i7 as it is the TV for the whole family and also now has a digium card passed through for the telephones.  Got to wait until I'm home alone!

                    • 292. Re: VMDirectPath and ATI Radeon
                      kthree Novice

                      I went through the past 10 pages or so as well and it looks like you're onto something.

                       

                      Another thing is that we could try is passing through both the intel graphics as well as the radeon. I know there has been issues with passing through the integrated graphics, but perhaps just passing it through is enough to get the radeon working.

                       

                      Also believed that there was a user who got it working under OS X despite it BSODing under Win7. So might be OS dependent and worth trying on Win8.

                       

                      When ESXi 5.1 comes, I'll take the opportunity to try it out as well as test the above.

                      • 293. Re: VMDirectPath and ATI Radeon
                        bwiklander Novice

                        Hey, This is my first post in this forum so i would yust like to say hi first, and thanks to all the people who have been posting in this thread it have really helped me alot when trying to get VGA passtrough working i ESXI

                        1 .
                        Ok so first i would like to give out a tip to everyone who is trying to get pci passtrough working for a graphic adapter.

                        It can be a real struggle to get this working and testing diffrent setups and PCI-E ports, OS’s and so on...

                        I came across testing the XBMCUbuntu iso image.
                        http://mirrors.xbmc.org/releases/XBMCbuntu/xbmcbuntu-11.0.iso

                        this came in real handy as it by default disables the “onboard” in this case ESXI’s virtual graphics adapter, and puts the output directly in my case trough my radeon HD5450 HDMI port.
                        (ohh, and remember to only give the guest a maximum of 2GB for starters and Reserve all the mememory to the guest)

                        hope this can help anyone.


                        2.
                        Im also having some trouble with either my Radeon card or my Motherboard and i would like som help with solving this problem.

                        Simply put, Everything works great, i got the XBMCubuntu OS running for 2weeks straight, until it hanged. and the whole ESXI server freeze.

                        The problem is when something goes wrong, or if i just reset the virtual machine. then the whole ESXI system freezes up and i cant do anything at all, i have to do a Hard reset.

                        And as im planning on using a windows7 installation for my HTPC and do some casual gaming this is gona be a problem.

                        So have anyone else experienced something similar or do have some idea what can be wrong?’

                        i have seen some people having trouble with the 5450 cards, and some seem to have no problems at all, but i would like to hear if someone else can confirm it’s a problem with either my GFX or my motherboard so i can get a new one.

                        Posting my setup below

                        ESXI 5.0.0, 469512


                        Gigabyte GA-990FXA-UD3 (latest bios(alltough it didn’t seem to do much diffrens when i uppgraded))

                        AMD Phenom II X6 1055T Processor @ 2.8 ghz (stock)

                        PCI-E nvidia cheap graphic card running the console
                        MSI Radeon HD5450 1024MB
                        (PCI-passtrough, to Guest)

                        20GB ddr3 Ram

                        2x 30gb OCZ Vertex SSD
                        1x 60gb OCZ Vertex 2 SSD


                        Thanx in advance.
                        Björn

                        • 294. Re: VMDirectPath and ATI Radeon
                          derickso Enthusiast

                          I would suggest you try a newer card, I've had nearly no problems with my 7 series Radeon, and you have to expect that newer cards will have better hardware and software compatibility with what we are doing.

                          • 295. Re: VMDirectPath and ATI Radeon
                            mindless728 Novice

                            I don't know if it is because the card being old, before I bought my 7970 I was using passthrough just fine with my 4870.

                             

                            It might have to do with the fact that it is a low end card and it works slightly different from higher end cards

                            • 296. Re: VMDirectPath and ATI Radeon
                              MarBen Novice

                              Dear all,

                               

                              since I just made my first experiences with ESXi on my new Shuttle and someone in this thread also asked about the Z77 chipset, here is my config and a question from my side:

                               

                              Hardware

                              • Shuttle SZ77R5
                              • Intel Core i7-3770
                              • 32 GB RAM (Corsair Vengeance LP)
                              • 2x 3 TB Seagate Barracuda
                              • nVidia 8800 GTX (from my old desktop in order to test the passthrough feature)

                               

                              Everything seems to work flawlessly, though most of the hardware is listed as "unknown" within vSphere, since the Shuttle is not in the HCL.

                               

                              I'm currently struggling with the passthrough of my video card: I got it through to my Windows 7 x64 system and successfully installed the certified Windows drivers for the 8800 (had to disable the VMware SVGA). When I reboot the guest OS, the output from the nVidia card still shows the host's "cnic_register loaded successfully" screen, which I guess one of you suggested correctly is the stage where the "passing through" actually happened.

                               

                              But I don't get a Windows login screen.

                               

                              That's the problem. Tried many things but no luck. The system boots up correctly, I can access it via the vSphere console and login to the system; but how can I get the actual output to the nVidia card?

                               

                              Any help is highly appreciated ...!

                               

                              Cheers

                              • 297. Re: VMDirectPath and ATI Radeon
                                derickso Enthusiast

                                nVidia cards are known to be problematic, try a Radeon.  Also disabling the VMware SVGA will almost certainly prevent your setup from working.

                                • 298. Re: VMDirectPath and ATI Radeon
                                  mindless728 Novice

                                  I can definitelty confirm that disabling the VMware adapter will cause any GPU's that are passed to the VM to not function at all

                                   

                                  I tried this myself with both my 4870 and 7970 to see if it would work or not

                                  • 299. Re: VMDirectPath and ATI Radeon
                                    MarBen Novice

                                    Thanks for the quick answers!

                                     

                                    I read in several other forums that other people got their setup to work only if they disabled the VMware SVGA. Maybe I can find these posts again ...

                                     

                                    Anyway, if I enable it, the device manager indicates a problem with the nVidia card, which prevents me from using it. Besides that: could somebody please post a screenshot of the display settings (such as output to monitor X and stuff) and the device manager? I know, not much magic there, but I'd like to see a working config, somewhere.

                                     

                                    Many thanks and cheers

                                    1 18 19 20 21 22 Previous Next