1 15 16 17 18 19 Previous Next 814 Replies Latest reply on Sep 26, 2018 12:22 PM by edward_walton Go to original post
      • 240. Re: VMDirectPath and ATI Radeon
        twisterStorm Novice

        oka this is the log file when i try to install the catalyst 12.4 driver. this time with no monitor connected to the graphic card

         

        cat vmware.log:

         

        2012-06-12T16:07:29.717Z| vcpu-1| MONITOR PANIC: vcpu-0:NOT_IMPLEMENTED devices/pci/pci_monitor.c:244
        2012-06-12T16:07:29.717Z| vcpu-2| Exiting vcpu-2
        2012-06-12T16:07:29.717Z| vcpu-0| Exiting vcpu-0
        2012-06-12T16:07:29.717Z| vcpu-1| Core dump with build build-702118

        [-------Dump Cores---------]

        2012-06-12T16:07:32.882Z| vcpu-1| Dumping extended monitor data
        2012-06-12T16:07:48.159Z| vcpu-1| Msg_Post: Error
        2012-06-12T16:07:48.159Z| vcpu-1| [msg.log.monpanic] *** VMware ESX internal monitor error ***
        2012-06-12T16:07:48.159Z| vcpu-1| --> vcpu-0:NOT_IMPLEMENTED devices/pci/pci_monitor.c:244
        2012-06-12T16:07:48.159Z| vcpu-1| [msg.log.monpanic.report] You can report this problem by selecting menu item Help > VMware on the Web > Request Support, or by going to "http://vmware.$
        2012-06-12T16:07:48.159Z| vcpu-1| [msg.log.monpanic.serverdebug] If the problem is repeatable, set 'Use Debug Monitor' to 'Yes' in the 'Misc' section of the Configure Virtual Machine We$
        2012-06-12T16:07:48.159Z| vcpu-1| [msg.log.monpanic.vmSupport.vmx86] To collect data to submit to VMware support, run "vm-support".
        2012-06-12T16:07:48.159Z| vcpu-1| [msg.log.monpanic.entitlement] We will respond on the basis of your support entitlement.
        2012-06-12T16:07:48.159Z| vcpu-1| [msg.log.monpanic.finish] We appreciate your feedback,
        2012-06-12T16:07:48.159Z| vcpu-1| -->   -- the VMware ESX team.
        2012-06-12T16:07:48.159Z| vcpu-1| ----------------------------------------

         

        via google i found nothing like this

        • 241. Re: VMDirectPath and ATI Radeon
          twisterStorm Novice

          I MADE IT!!!

           

          My computer, see my last post on side 16, only changed the firmware back to BIOS.

          my passthrough devices http://s7.directupload.net/file/d/2921/fx7amgyz_png.htm

           

          My (painfull) way:

          * i createt the new VM with custom settings,

          * added the 2 PCI Devices, VGA Controller (ID 06:00:0) and the Unknown device with ID 06:00:1. It is the HDMI output of the video card.

          * set the ram size to 768MB RAM - why? i read somewhere (sorry, didnt find anymore) on a blog, this is a good number for installing and not have a BSOD after 1. boot...

          * and mounted the dvd device to a Win7 incl. SP1 Image.

           

          * installed Windows on the virtual Disk

          * after the setup was completed, i installed all windows updates

          * vm reboot

           

          * after this, i installed the vmware tools and installed the catalyst 12.4 driver

           

          with ONE exception, the last point, AMD Vision Center (or something like this), i did not installed.

           

          *vm reboot

           

          vm starts, after login, windows was looking for all the driver for new installed hardware.

          it founds the ati driver and in the windows ballon bubble stand "AMD 6950 is know installed":D

           

          Right click on the desktop -> change resolution, and here i can now activate my 2 24" Benq Monitors and disabled the "vmware Monitor".

           

          The Windows Performance Index  says 7,9 for both graphics parts.

           

           

          now i have to increase the ram of the vm.

           

          * 1GB -> VM start, Windows performance index 5,5

          * 2GB -> VM start, Windows performance index 5,9

          * 4GB -> crash, error message in vSphere:

           

          PCIPassthru 004:00.0: Guest tried to map 8 device pages (with base address of 0xb2800)

          to a range occupied by main memory. This is outside of the PCI Hole. 

          Add pciHole.start = "2856" to the configuration file and then power on the VM.

           

          >> added the parameter

           

          start (still 4gb) ==> crash, error message in vSphere:

           

          PCIPassthru 006:00.0: Guest tried to map 32 device pages (with base address of 0xb2520) 

          to a range occupied by main memory. This is outside of the PCI Hole. 

          Add pciHole.start = "2853" to the configuration file and then power on the VM.

           

          changed the parameter to the new number...

           

          BSOD http://s7.directupload.net/file/d/2921/c7bwh9zi_png.htm

           

          found this article via google to pciHole.Start http://tinkertry.com/gpu-pass-future-test/ and here is the commentar from Rob Perry important.

           

          changed the start to 1200 and added pciHole.end as parameter

           

          vm start => works, no BSOD ==>  4GB RAM ==> Windows performance index 7,9

           

          moved to 8GB, vm start => Windows works...

           

          my complete performance index now ==> http://s7.directupload.net/file/d/2921/px4lc8as_png.htm

          (sorry for the german windows i think it is the same order but from top to bottom  CPU # RAM # graphics # graphics (games) # primary harddisk)

           

          the VM has 6 cores * 3,6GHz (AMD FX - 8150, 8*3,6 with boost 8*3,9GHz or 4*4,2GHz ), so i dont know, why it is "only" 7.3.

           

          And the 5.9 is (maybe) a configuration issue. The vmdk file is saved on a mdadm software RAID 5 Array (3 * 60GB OCZ Vertex 3 SSDs).

          Each SSD writes/reads with around 550MB/seconds, so it must be better than 5.9.

           

          the esix host passthrough the 3 devices to a debian VM =>

          the debian VM creates the mdadm array and is hosting a NAS share =>

          the esix host used this share for a new Datastorage =>

          and on this storage is the windows vmdk....

           

           

          now i can create all my other VMs

          1x Windows Server 2008 for TFS / MS-SQL

          1x Ubuntu 12.04 LTS

          1x X / Ubuntu or debian for a FTP

          1x X / Ubuntu or debian for SAMBA

          • 242. Re: VMDirectPath and ATI Radeon
            DMG210 Novice

            Great news guys! Well i've got a bit of good news myself...   I have successfully managed to passthrough a radeon hd6450 + blackgold bgt3600 (dvb-t2/dvb-s2) tv tuner to a windows 7 vm! I'm using mediaportals backend + Xbmc pvr front which really works a treat :-) I able to watch / record live hd channels and even record 10+ channels simultaneously :-)

            • 243. Re: VMDirectPath and ATI Radeon
              sevet Novice

              After finally succeding in passing the ATI 3450

              I got a new card Sapphire ATI 7770 (OC) with 1gb mem and it works as well,

              I used the memory hole setting and gave the VM 6gb of memory (upgraded the ESXI to 32gb),

              Got ~3450 on 3D mark 2011 which is as much as a physical machine should get with this GPU!!

              At last I have a gaming machine, plays skyrim pretty well while other VMs work fluidly

               

              Next I put the 3450 ATI on a x1 PCIe slot - I actually chopped its legs to fit, once I couldn't chop the ending of the slot on the mother board....

              Got it working ok on Win7 x64

              Now I tried to get it to work on Mac OS X 10.7, no success - could be driver and not esxi related

              Next I will try to put an ATI 4600 I have and try it on the Mac - once I get a proper x1 to x16 PCIe raiser... (don't want to chop my 4600 card without knowing if its working, already regret chopping the 3450....)

              Also got a Matrox G200 PCI card and set bios to boot GPU from PCI first so I will have a Console display to the ESXI.

               

              The OS X is working with a USB GPU from displaylink but the mouse moves horribly on it, It also moves bad with Win7 with this USB GPU.

              I have a KVM connected to the Computer on 3 ports - ESXI Console, Win7, and MAC

               

               

              All with i7 2600 (not K) with Intel DP67BG Motherboard (bios 2185 and disabled on board audio)

              • 244. Re: VMDirectPath and ATI Radeon
                nslim Novice

                Hello Sevet

                 

                Did you further your tests with a virtual card on OSX? Can it run on a non accelerated way? or does it just crash?

                 

                I am really interested in this since I have hardware that can almost do VT-d (except the CPU it is a 2600K)

                • 245. Re: VMDirectPath and ATI Radeon
                  x1nick Novice

                  Well after seeing the post about the ASUS P8B-E/4L I got a little excited and I thought I would give my Asus P8B WS a go seeing as its a similar chipset and a BIOS was released around the same time too.

                   

                  Differences are I am using ESXi 5 U1 and a HD5450

                   

                  No success here, this is my windows 7 client device manager/error from CCC

                   

                   

                  http://i36.photobucket.com/albums/e36/x1nick/ScreenShot2012-07-21at212314.png

                  Im half tempted to see if I can pick the same card up as you and see what happenes.

                   

                  Or any suggestions on what else I could try, have ready though this and think the 6 series is a little more successful

                  • 246. Re: VMDirectPath and ATI Radeon
                    derickso Enthusiast

                    I picked up a 7750 (http://www.newegg.com/Product/Product.aspx?Item=N82E16814150612) and it worked without issue paired with an Ivy Bridge Xeon and a C204 based board (http://www.newegg.com/Product/Product.aspx?Item=N82E16813151246).  I literally passed it through, installed the latest catalysts, rebooted, no issues at all.  Another thing to try is making a static 'pinned' memory reservation for the guest, I'm out of town right now else I'd get the exact name, but it may help.

                    • 247. Re: VMDirectPath and ATI Radeon
                      goudkamp74 Novice

                      I've been going crazy, getting my Sapphire 6450 2GB running on my ESXi 5 box (Asrock Pro 3, i7 3770, Vt-d enabled, 32GB mem) using Windows XP 32bit. Did everything I found in this thread; driver installs fine, can even see the 2 extra screens but as soon as I enable / extend a monitor, Windows reboots.

                       

                      However, I also got 2x OSX Lion 10.7.4 VM's running (one client, one server). Assigning the 6450 to either of those, I immediately got the desktop running on the 6450! And OSX sees it as a proper card. Now that's interesting! Assigning USB ports now so I can even control it; see how that goes.

                      • 248. Re: VMDirectPath and ATI Radeon
                        Kamerat Novice

                        Try installing VMware Tools x1nick.

                        • 249. Re: VMDirectPath and ATI Radeon
                          technobro1 Novice

                          hi guys

                           

                          after trying to make that work for a few days. its still not working

                          heres my setup

                           

                          3770

                          asrock z77 pro3

                          5.01 esxi

                          Gigabyte HD6850

                          win7 64bits

                          pciholes edited

                           

                          I got the driver install correctly, whithout BSOD, but for some reason it shows as a 6800 series

                          I can never select the ati 6850 as the second display its never there

                          When i boot windows it gives me a message that the '' ati catalyst control is not supported by the driver version  , please update your driver ....''

                           

                          i have been stuggling to completely disable the SVGA Vmware card but it always show up as only and primary card...

                           

                          Any suggestion , help

                           

                          Thanks

                          • 250. Re: VMDirectPath and ATI Radeon
                            derickso Enthusiast

                            Don't try and disable the VMware video card, if you do - and reboot - you will get that error.  You have to leave both, but you can turn off the display attached to the VMware video card.  Also try reducing the RAM assigned to your VM to like 2G, and *not* editing the PCI holes.

                            • 251. Re: VMDirectPath and ATI Radeon
                              x1nick Novice

                              @Kamerat Now to decide if its worth tearing my rack apart to remove the server and trying it all over again!

                               

                              Would certianly save me a load of money if it works and DXVA works too!

                              • 252. Re: VMDirectPath and ATI Radeon
                                Zakcar1 Novice

                                asus rampage II extreme chipset X58

                                also using an IBM M5015 controler for the disks.

                                • 253. Re: VMDirectPath and ATI Radeon
                                  ilya_ca Lurker

                                  Hi,

                                  I have an Nvidia videocard, will it be possible to passthrough it to my Windows 7 VM?

                                   

                                  I was able to install the driver for the videocard on the VM, but I cannot have the built-in video card along with my NVidia video card. I have to disable either of them. And even if I do so, applications on VM say that hardware acceleration is disabled. What am I doing wrong?

                                   

                                  Should I disable hardware acceleration in VM settings (it's currently enabled)?

                                   

                                  Thanks!

                                  • 254. Re: VMDirectPath and ATI Radeon
                                    x1nick Novice

                                    Well update on the Asus P8B WS with latest bios and latest ESXI 5.0.0 U1 and my HD5450

                                     

                                    Got the catalyst drivers installed ok (with VMware tools installed, seemed to fix that issue I had before!), then rebooted and got the standard atikmpag.sys BSOD if a monitor is connected.

                                     

                                    No monitor connected results in the host crashing, and I am assuming running at 100% CPU as the CPU fan begins spinning up 10x faster

                                     

                                     

                                    1 15 16 17 18 19 Previous Next