9 Replies Latest reply on Feb 2, 2011 8:53 AM by npeter

    Sysprep Issues vSphere

    justinsmith Enthusiast

      So I'm using VMWare view to roll out some virtual XP Pro desktops. I've created a template and using Windows Guest Customization. When the template is deployed, I see the VM run a sysprep, (Yes the sysprep files are there in the proper location) The issue I'm running into is that it doesnt use the customization file, even though I tell it to. I've tried to manually deploy a VM from a template and have it use the Windows customization, and that doesnt seem to work.

       

      Is there a log file that is generated somewhere? Im getting no errors, other then the customization isnt running on the box. This is going to be a pain when we use VMWare View and roll out 100+ VM's and have to manually add them to the domain.

       

      Specs:

       

      vSphere 4.1

      Virtual Center server is Windows 2008 R2

      VM Templates are XP Pro with SP3

        • 1. Re: Sysprep Issues vSphere
          MKguy Virtuoso

          You should find the customization log at C:\Windows\TEMP\vmware-imc\guestcust.log in the guest OS.

           

          Check the events of the VM, the exact location is stated in an event there, for example:

           

          Customization of VM MYVM succeeded. Customization log located at
          C:\Windows\TEMP\vmware-imc\guestcust.log in the guest OS.
          info
          14.12.2010 15:26:56
          MYVM
          User
          • 2. Re: Sysprep Issues vSphere
            justinsmith Enthusiast

            Is there a way to figure out why this error is happening? Or why it cant contact the domain? I have the NICS enabled with DHCP, and it gets an IP after it powers on....

             

            In the customization wizard, I've tried using domain\username and just username with the password...

             

            Joining domain DOMAINNAME using account jsmith and password '*****'
            The specified domain either does not exist or could not be contacted.

            • 3. Re: Sysprep Issues vSphere
              khughes Virtuoso

              While at times I have used the sysprep customization feature within VMware to deploy VM's I tend to just join them to a workgroup and manually join them to the domain after they're up and running (if that is an option for you).  There is a split second that it hits the network before joining to the domain or using any NIC settings you configured.

               

              I use static IP addresses and when I deploy I need to go and clean up DNS for when it pulled a dhcp address for a split second.    

              • 4. Re: Sysprep Issues vSphere
                justinsmith Enthusiast

                This is actually going to be used with VMWare View, so joining them to the domain manually after the fact will be a pain... and kind of defeat the whole automated process.

                 

                I might just have to call VMWare and find out if theres a way to figure this out.

                 

                On a side note, how do you create your images from a template? Do you sysprep after you finish your "image"? 

                 

                The way we do it, is create the standard image, convert it to template then deploy using a customization script. I know some people would sysprep it BEFORE converting it to template? Maybe this is the issue?

                • 5. Re: Sysprep Issues vSphere
                  khughes Virtuoso

                  If its for view then yes that would be a giant pain, so that is out of the question.  The way you do it is how we do it, which is take a prestine working server, clone it, convert it to template then deploy it and use the customization to make the changes to it.  Sometimes people run sysprep before that depending on what it will be used for.

                   

                  Contacting support would probably be a good idea because they can remote in and take a look at it and see if there is any network issues.  I haven't run into an issue where it had a problem finding the domain, but then again my network is all on the same subnet so if yours isn't I would look at the paths to the domain and make sure they are all clear.

                  • 6. Re: Sysprep Issues vSphere
                    mattjackson503 Lurker

                    Hello,

                     

                         Have you by chance found a solution?  I am too having the same symptoms with using customization and View 4.5, the customization fails to complete.  Sysprep actually runs but its as though thier is no answer file for it to refer to.

                     

                    Thanks

                    Matt Jackson

                    • 7. Re: Sysprep Issues vSphere
                      idle-jam Champion

                      i would suggest using the inbuilt quickprep for view 4.5

                      • 8. Re: Sysprep Issues vSphere
                        justinsmith Enthusiast

                        I've tried a couple different things working with VM support, none seem to be consistent. The only time I got an image to join the domain was when I removed the way users logon and the fast switching option in XP. But like I said, still very inconsistent on if it will join to the domain. I've tried a basic XP image with JUST XP installed and nothing seems to work. Frustrating.     

                        • 9. Re: Sysprep Issues vSphere
                          npeter Expert

                          Please try deploying a vm in vcenter from the same master image using same custom-spec. If this doesn't work your network settings has some misconfiguration. One more option to verity this is to login to the vm which failed to join domain during provisioning and manually try adding it to domain.

                          This could be simple issue of DNS provided by dhcp is not able to resolve your domain.