1 Reply Latest reply on Sep 14, 2010 6:54 AM by DaIceMan

    Vcenter 4.0 to 4.1 upgrade error

    DaIceMan Enthusiast

       

      When trying to upgrade our vcenter 4.0 to 4.1, near the end (apparently at 100%), the installer reports:

       

       

      Error 25012: Setup failed to configure Windows firewall

       

       

          and the only button left to press is "ok" at which point the installation fails.

       

       

           The firewall is of course enabled and disabling it doesn't change the result (of course to relaunch the upgrade we had to roll back the snapshot). After reading of a similar error on another upgrade it seems the problem is tied to the localisation of our Windows 2008 R2 server, which is in Italian with English as additional language pack, from which it was launched. It wouldn't be the first time I encur in such problems with a localised 2008 OS(see import/export of DHCP scopes). Is there any way to possibly bypass this firewall setting with a flag when launching the setup or know of any workaround?

       

       

          Thanks

       

       

        • 1. Re: Vcenter 4.0 to 4.1 upgrade error
          DaIceMan Enthusiast

           

            Just FYI, I found a solution/workaround to the problem: if you are using a localised version of Windows server 2008 with any additional language installed, revert to the original language before installing vcenter server 4.1 from the Administrative profile you are using (I actually uninstalled the additional language for safety). This resolved the firewall error and completed the upgrade successfully.