3 Replies Latest reply on Sep 15, 2010 10:19 PM by skilik

    OVF tool fails to convert compressed OVF file to vmx

    skilik Novice

      I have a compressed OVF file generated by OVF tool using "compress" option. However, I cannot convert the generated ovf file back to vmx. When I run OVF tool to perform conversion, it says "Disk Transfer Failed" and "Error: Failed to open source disk: disk1.vmdk.gz" .Any ideas how I should proceed with this?

        • 1. Re: OVF tool fails to convert compressed OVF file to vmx
          skilik Novice

          when i turned on the option "--X:logToConsole"

           

          the following message was shown:

          -


          E:\Lightweight>ovftool --X:logToConsole    JBoss_PostGRESQL.ovf JBoss_PostGRESQL

          .vmx

          Using home directory C:\Docume

          nts and Settings\rcf\Application Data\VMware\ovftool.cfg

          OvfTool Environment:

          /X:logToConsole = "true"

          /X:maxNumberOfTermSignals = "5"

          /X:maxRedirects = "256"

          /X:maximalDeltaConfSize = "8"

          /X:maximalDeltaTreeSize = "6"

          /prgPath = "D:\Program Files\VMware\VMware OVF Tool"

          /source = "JBoss_PostGRESQL.ovf"

          /target = "JBoss_PostGRESQL.vmx"

           

          Opening OVF source: JBoss_PostGRESQL.ovf

          Manifest file present. Parsing file.

          Manifest file entry: SHA(JBoss_PostGRESQL.ovf) = c07fa478ba6dc461ff16d04d2bbd65d418007d49

          Manifest file entry: SHA(disk1.vmdk.gz) = 46da5a29ddc64bdd4731755e8c5fe9a4b1be6b01

          Verifying that the files references in manifest are valid

          OVF Descriptor: <?xml version="1.0" encoding="UTF-8"?>

          <!Generated by VMware ovftool 1.0.0 (build-166674), User: chenshuz, UTC time:2010-06-04T04:27:31.018854Z>

           

          Opening VMX target: JBoss_PostGRESQL.vmx

          Creating disk .\JBoss_PostGRESQL-disk1.vmdk, 52428800 sectors, lsilogicTarget: JBoss_PostGRESQL.vmx

          Using file size as progress measure

          Ovf::GetDiskSource as StreamVmdk failed. Exception: Cannot open disk sourceDisk progress: 98%[2010-09-08 13:32:12.643 02956 verbose 'ovftool'] Ovf::GetDisk

          Source failed to open disk disk1.vmdk.gz. Exception: The file specified is not a virtual disk

          Disk Transfer Failed

          Error: Failed to open source disk: disk1.vmdk.gz

          Backtrace:

          backtrace[00] eip 0x009442a5 ?AbortProcess@System@Vmacore@@YAXXZ

          backtrace[01] eip 0x0089979a ?CreateBacktrace@SystemFactoryImpl@System@Vmacore@@UAEXAAV?$Ref@VBacktrace@System@Vmacore@@@3@@Z

          backtrace[02] eip 0x008644a0 ??0Throwable@Vmacore@@QAE@ABV?$basic_string@DU?$char_traits@D@std@@V?$allocator@D@2@@std@@@Z

          backtrace[03] eip 0x00401ad9 (no symbol)

          backtrace[04] eip 0x004582c5 (no symbol)

          backtrace[05] eip 0x00417eec (no symbol)

          backtrace[06] eip 0x00418572 (no symbol)

          backtrace[07] eip 0x00404658 (no symbol)

          backtrace[08] eip 0x0040115a (no symbol)

          backtrace[09] eip 0x77e6f23b ProcessIdToSessionId

           

          Deleting file: .\JBoss_PostGRESQL-disk1.vmdk

          -


           

          Does anyone have any ideas?

          • 2. Re: OVF tool fails to convert compressed OVF file to vmx
            Hot Shot

            you are missing a

            ovf:compression="gzip" in the &lt;File&gt; section. Inset this into the ovf (you will have to remove the .mf file as the manifest dont match) and everything should be fine. I can see that this was made with ovftool 1.0.0 you are more than wellcome to upgrade to ovftool 2.0.1 and try the export once more. If we still lack to set the ovf:compression="gzip" attribute I will make sure it gets included in the next release.

             eske 
            

             

            • 3. Re: OVF tool fails to convert compressed OVF file to vmx
              skilik Novice

              Eske,

               

              You are really accurate in hitting the problem.

               

              We made the following changes to our virtual machine:

              1. added ovf:compression="gzip" to the ovf file in the tag "";

              2. removed the mf file.

               

              Our problem was solved with ease under your guidance.

               

              Many thanks.