12 Replies Latest reply on Mar 2, 2013 7:06 AM by Linjo

    Bug Report - vmxnet3 and ms RAS NAT

    yizhar Lurker

      HI.

       

      I would like to report a bug in ESXI (and probably other products) and VMXNET-3 adapter.

       

       

      Problem description:

       

      I was using two vmxnet3 adapters on Windows server 2008 32bit (hardware version 7),

      and installed the Network Policy and Routing role.

      One adapter is connected to the Internet, and the other to an internal only lan.

      I have configured it as NAT router.

      I have also installed DHCP on that server.

      Both adapters with static IPv4 addresses.

      I didn't use IPv6.

      vmware tools are installed of course.

       

      I have installed another VM connected to the internal lan.

      When trying to access the Internet from that VM, the Win2008 machine hangs and network connections were stalled,

      I don't know how to exactly describe the problem but the botton line – I lost network connectivity on the Win2008 virtual host.

      When trying to change network settings or "disable routing and remote access" on the Win2008 server,

      it hanged and I needed to force a reset.

       

      I have created a similar machine, now with Windows Server 2008 R2 64bit (Hardware version 7),

      also with two vmxnet3 adapters.

      Bottom line – exactly the same problems.

       

      I then replaced the virtual adapters with E1000 , and it seems to work fine now.

       

      I suspect that the problems are related to the vmxnet3 driver – both 32 and 64 bit,

      and a compatibility problem with the NAT engine of both Win2008 (r1) 32 bit, and Win2008 R2 64bit.

       

       

      Platform:

      ESXi ver 4 update 1 server,

      version 4.0.0, 208167

      Installed from iso named: VMware-VMvisor-Installer-4.0.0.Update01-208167.x86_64.iso.

      I didn't apply any future updates.

      This is a single server.

      Hardware is HP DL360G6 , dual cpu, 12gb ram, 4 local SAS drives.

      The system has no load, and has planty of extra resources (ram cpu disks).

       

       

      How to reproduce:

      Install EXSI v4 update 1 server.

      Install Win2008 32 or 64 bit, r1 or r2.

      Configure 2 virtual nic vmxnet3 adapters – one connected to the Internet and the other to an internal only lan.

      Install DHCP + RAS.

      Configure as NAT server.

      Install another VM with single nic, connected to internal lan.

      Try to access the internet via the NAT server on the first VM .

       

       

      Yizhar Hurwitz

      VCP 3.5.

      Kibutz Gaaton, Israel.

      http://yizhar.mvps.org