1 2 Previous Next 23 Replies Latest reply on Jun 30, 2011 5:36 PM by spb2011

    Fusion 3.0.2 (232708) freezes entire system

    pumpichank Novice

      I have Fusion 3.0.2 on Snow Leopard 10.6.3.  When I run one VM everything works fine.  As soon as I try to create a second VM and run it, Fusion locks my entire system.  The cursor freezes and the entire system hangs.  I cannot even ssh into the host.  I have to hard reboot the machine (hold down the power button until the machine powers down).  Obviously this is seriously not good as it has corrupted other applications in the past (e.g. Mail.app).  This seems like a very serious bug in Fusion - it should never be able to freeze the host OS.

        • 1. Re: Fusion 3.0.2 (232708) freezes entire system
          Guru

          Have you run hardware diagnostics (e.g. memtest86+)? Is there anything in the system logs? Does it matter what order you run virtual machines in (e.g. A then B vs. B then A), their specifics (e.g. two empty virtual machines), etc.? For what it's worth, we run multiple virtual machines simultaneously all the time internally and have never seen this.

          • 2. Re: Fusion 3.0.2 (232708) freezes entire system
            pumpichank Novice

            Hi etung: I don't know how to run memtest86+ on my Mac.  I've looked through the system logs and cannot find anything relevant.

             

            To reproduce, I have a single guest running (Ubuntu 10.04) and then I create a new VM pointing to an ISO.  It's at the point at which I start the new VM and then move the mouse out of the VM window that everything locks up (or at least, that's what happened the most recently time it locked on my).  The existing VM uses 2 cores, 2048 RAM, bridged networking, 50 GB disk, running Ubuntu 10.04 x86_64 desktop.  The new VM was a i686 single proc with probably 512 MB ram and and a 20GB disk.  It was also bridged networking.

             

            The freeze definitely happened as soon as I transitioned the cursor from the VM window to the Mac desktop.

            • 3. Re: Fusion 3.0.2 (232708) freezes entire system
              pumpichank Novice

              This just happened again with Fusion 3.1.  Any ideas?

              • 4. Re: Fusion 3.0.2 (232708) freezes entire system
                pumpichank Novice

                In fact, this is horribly catastrophic.  Every time this happens it forces me to hard reboot the Mac, and I always lose data and settings.  I cannot let this continue.

                • 5. Re: Fusion 3.0.2 (232708) freezes entire system
                  pumpichank Novice

                  And now both my VMs disks are corrupted.  Thank you so much for crashing everything.

                   

                  "Cannot open the disk ... or one of the snapshot disks it depends on"

                   

                  Reason: The specified virtual disk needs repair.

                  • 6. Re: Fusion 3.1 cannot open disk, virtual disk needs repair.
                    jpbn Novice

                    error : Cannot open the disk '/Users/jjb/Documents/Virtual Machines.localized/Windows XP Professional.vmwarevm/Windows XP Professional.vmdk' or one of the snapshot disks it depends on.

                    Reason: The specified virtual disk needs repair.

                     

                    It is a new virtual machine Just Installed VMware fusion 3.1 and imported this win XP from a PC.

                    OS X 10.6.3

                     

                    Don't know how to repair a virtual disk.

                    • 7. Re: Fusion 3.0.2 (232708) freezes entire system
                      automaticit Lurker

                      I confirm the same freezing behavior on a MacBookPro5,2 (2.93 GHz Intel Core 2 Duo), 8 GB RAM, OS X 10.6.3, under both Fusion 3.0.2 and 3.1.0. This did not happen under OS X 10.5.8 with Fusion 3.0.2, but did happen with OS X 10.5.8 and Fusion 3.1.0. I thought that upgrading to Snow Leopard would resolve the issue but unfortunately it did not. We upgraded to Snow Leopard 10.6.0 by booting from the 10.6 DVD and installing (i.e., we did not use Apple Migration Assistant, and instead applied a clean install of our System Folder), then ran the Combo Update to upgrade to 10.6.3, then applied all the latest patches through Apple Software Update. We have held off on 10.6.4 as that is too new for us to use in production.

                       

                      We then thought that applying the inline Fusion upgrade from 3.0.2 to 3.1.0 from within Fusion itself was the problem. So we uninstalled the upgraded 3.1.0, then downloaded and installed from scratch 3.1.0, but that also did not prevent the issue. We thought perhaps the problem was with 3.1.0, so we uninstalled again and reinstalled 3.0.2, but the freezes continue.

                       

                      It seems the freezes are more likely to occur when either shutting down or rebooting a VM, on the order of about 7 out of 10 freezes. But the freeze doesn't happen on every VM shutdown or reboot. No system log entries are generated that we could see in Console.app that seem useful; the freeze is very abrupt every time so far. A few times, about 2-5 minutes after a DHCP lease is renewed through a captive portal at a hotel room's network, the network connection on the host OS X system will die (first way we notice is any web browser we have open can no longer open pages, though active SSH sessions still respond), then anywhere from 5-10 minutes later the system will freeze.

                       

                      For other users who are starting to run into this issue (there are other threads where users are starting to note similar problems), I recommend staying on OS X 10.5.8 and Fusion 3.0.2; that has been a stable configuration for us. I don't have the option of downgrading to 10.5.8 from 10.6.3, so I need to work out a resolution on an OS X 10.6.3 / Fusion 3.x configuration. This could also be due to a general OS X 10.6.3 freezing issue, but I believe I see a correlation on my system at least between leaving VMware turned on and the system freezing.

                       

                      We are going to try configuring the VM to only use a NAT network configuration, turning off Spotlight (that seems to be the new fix to try to mitigate the 10.6.3 freezing), and see if the freezes continue, and report back to this thread.

                      • 8. Re: Fusion 3.1 cannot open disk, virtual disk needs repair.
                        pumpichank Novice

                        In my case I could not repair the virtual disk, but I was lucky that it was just a snapshot.  I had to hand-edit the .vmdk (?) file to remove that snapshot and then was able to boot the original disk.  VMware really should be much more resilient.

                        • 9. Re: Fusion 3.1 cannot open disk, virtual disk needs repair.
                          dlhotka Virtuoso

                           

                          If you're on a laptop, you should only have 1 virtual CPU per VM configured - you may very well be starving the host (1 virtual CPU per physical chip, not per core).  Likewise on the RAM, make sure you have sufficient free RAM on the host to launch two VM's.

                           

                           

                          It sounds like the issue occurs when you're trying to create a new VM - does it also happen when you're just running two?

                           

                           

                          I've been running multiple VM's on 10.6.3 and 10.6.4 with 3.1 since the beta program, and never have had this issue.

                           

                           

                          Last, are you sure it's not just the UI hung (in other words can you ssh/telnet/vnc) into the machine while it's hung?  If so, you should be able to identify the process that's causing the problem.

                           

                           

                          • 10. Re: Fusion 3.1 cannot open disk, virtual disk needs repair.
                            automaticit Lurker

                            dlhotka, can you report what model Macintosh and hard disk you are using? There might be an issue with various combinations of EFI firmware and hard disks with 10.6.x, and it might be likely that you are on hardware that is not experiencing this problem.

                             

                            My system froze again today, so I think turning off Spotlight isn't the fix. I notice that while I am not running VMware and not sleeping the system today, the system is stable through all my other applications.

                            • 11. Re: Fusion 3.1 cannot open disk, virtual disk needs repair.
                              PixelWizard Lurker

                              this is happening to me, too...first time today. I actually had to repair my Mac hardrive, too, but after doing that, it didn't solve the virtual disk needing repair issue.

                              • 12. Re: Fusion 3.1 cannot open disk, virtual disk needs repair.
                                pumpichank Novice

                                Hi dlhotka,

                                 

                                I'm not sure I fully understand your recommendation.  You're saying that if we have a dual-core MBP (e.g. an MBP5,1) that we should generally not give 2 cpus to our VMs?  Or do you mean that if we want to run multiple VMs at the same time, each should only be assigned a single CPU?  I suppose that makes sense, although I'd still claim that any time VMware freezes the host, it should be considered a serious bug.

                                 

                                In general, I'm pretty conservative on the assigned RAM per CPU, so I don't think that's the problem.  Also the freeze, for me, only ever happens when switching focus to the other VM.  Specifically: I'm in VM1 and I switch out of full-screen mode.  Then I cmd-` (backtick) to bring up the other VM window on the host, and it is at that point that everything freezes.  This is not just a UI hang; I cannot ssh or ping the host OS at this point and only a hard reboot will bring it back (which of course is pretty destructive and has lost host data for me every time).

                                 

                                Note that this used to work just fine for me and in fact was one of the features I touted about VMware.  Somewhere along the line it broke, but for me it was definitely in the VMware 3.0.x series.  Earlier 3.0.x and OSX 10.6.x worked fine for me, but then either a VMware 3.0.x update or 10.6.x update (perhaps even 10.6.3) broke it.  I'm now on VMware 3.1 and OSX 10.6.4 so I may get brave, back up my entire disk and try again.

                                 

                                Note that I'm using a 256GB SSD on my MBP5,1.

                                • 13. Re: Fusion 3.1 cannot open disk, virtual disk needs repair.
                                  dlhotka Virtuoso

                                   

                                  On a dual-core CPU, you only have 1 chip, so yes, each VM should have only 1 virtual CPU configured (even if you're only running 1 VM).  You can run multiple VM's with 1 cpu each at the same time.  The former causes host resource contention, the latter just causes host load.  Attempting to run multiple 2 CPU guests on a host with only 1 CPU (cores don't count - CPU's do), will likely cause very bad things to happen.

                                   

                                   

                                  Couple of other thoughts (some of these are reaches - I'd try the 1CPU limit on each VM (including the first one) first:

                                   

                                   

                                  1) SSD's aren't fully baked yet.  Have you tried it on a physical drive?

                                   

                                   

                                  2) Have you repaired the OS drive and repaired permissions?

                                   

                                   

                                  3) Try using snow leopard cache cleaner and rebuild prebindings and clear your caches.

                                   

                                   

                                   

                                   

                                   

                                   

                                   

                                   

                                   

                                   

                                   

                                  • 14. Re: Fusion 3.0.2 (232708) freezes entire system
                                    automaticit Lurker

                                    I have likely isolated the crash to Apple's Rosetta, and am fairly certain that it is not VMware Fusion. Yesterday, I quit Fusion in the morning, stuck to running only Terminal.app, Preview.app, and Mail.app, and by the afternoon I had another crash. I turned off Rosetta, turned back ON Spotlight (as it was turned off when the crash happened), combed through all my Preference Panel add-ons, Safari plug-ins, and Mail.app plug-ins, and updated any I had to the latest versions. I then upgraded to VMware 3.1.0, and have been running all day today without a crash. If I make it through the end of the week without another crash, I will consider Rosetta the root cause.

                                    1 2 Previous Next