3 Replies Latest reply on Mar 2, 2010 9:45 AM by ppowell

    VMware Server 2.0 CIFS datastore bug?

    zamorano Novice

      I posted this problem a few weeks ago, but I still can not solve it, so I'm posting it again with new information about the problem. I think this could be a VMware Serever bug, but I'm not totally sure about this.

       

      I'm using VMware server 2.0.2 (b203138) with a Windows 7 Ultimate x86 as vmware server host, and a NAS datastore configuration. The datastore is hosting all the VMs files, including the configuration ones, and it is a shared folder located in a Windows Server 2008 Enterprise x86 SP2. The network is in workgroup mode, not in active directory mode.

       

      Symptoms of the problem:

       

      • If you shut down or restart the host server, when it is up again the CFS data store is unusable, and the the virtual machines are unaccessible, even if all of them were stopped in time of rebooting.

      • The option to refresh data store does not solve anything.

      • If the NAS data store is deleted and re-created from scratch, the machines are still not accessible; it is necessary also to delete and re-add the VMs.

      • If you only restart the VMware services then you do not lose either the NAS data store nor the virtual machines.

      • If you only restart the NAS then also you do not lose either the data store nor the VMs, although these were in operation when you restarted the NAS; the same happens if you shut down network communication between the host server and the NAS.

      • A delay in VMware services startup does not solve nothing.

      • I have tried to the start the VMware services in manual mode, to be sure that there is total access to the NAS before starting the services, but VMware is still losing the NAS datastore and the VMs, so it is not a problem with network connectivity or with network access permissions.

       

      Any help would be very appreciated. Thanks.

        • 1. Re: VMware Server 2.0 CIFS datastore bug?
          ppowell Novice

          VMWare server does not appear to retain the security information you put in when you created the datastore once it is restarted.

           

          I ahve seen this issue since day one and I don't know that there is any solution. A HUGE pain.

          • 2. Re: VMware Server 2.0 CIFS datastore bug?
            zamorano Novice

            Thank you for the answer; do you know if this VMware Serever bug is restricted to this combination of OSs (Windows 7 as Host and Windows Server 2008 as NAS) or it is applicable to all SOs?

            • 3. Re: VMware Server 2.0 CIFS datastore bug?
              ppowell Novice

              This applies to all OS as far as I know. The VMWare server 2.x just does not retain the security attributes for authenticated access to CIFS shares underlying any network based data stores you define.

               

              I have see some information that this actually worked in version 1.x server, but I can't confirm that.

               

              I am not sure if this is a bug or by design since this behaviour has persisted through several 2.x releases, it may be by design to drive users to the commercial versions.

               

              Good luck

               

              Peter