1 2 Previous Next 18 Replies Latest reply on Jun 15, 2011 4:23 AM by mepsus Go to original post
      • 15. Re: Virtual IP feature of Windows 2008 R2 does not work on ESX 4
        VMguru201110141 Lurker

        Anyone found a resolution to this issue besides uninstalling VM Tools or using the E100 adapter?

        • 16. Re: Virtual IP feature of Windows 2008 R2 does not work on ESX 4
          Marcj1 Enthusiast

          I resolved this by disabling the "VMware VMCI Bus Device" in Device Manager (under System devices) and uninstalling the VMCI driver by modifying the VMware Tools installation, disabling IPv6 by unchecking the box in the Local Area Connection properties and setting the DisabledComponents DWORD value to 0xFFFFFFFF under HKLM\CurrentControlSet\services\TCPIP6\Parameters in the registry, and adding the server's IPv4 info to its hosts file, i.e.:

           

          127.0.0.1       localhost

          127.0.0.1       server1
          127.0.0.1       server1.domain.com
          10.0.0.10       server1
          10.0.0.10       server1.domain.com

           

          I also made sure any IPv6 references in the hosts file, such as ::1, were commented out.

           

          I am using the VMXNET3 driver and did not make any config changes to the vSwitches and my RDS servers are successfully assigning virtual IPs from DHCP to each session.

          • 17. Re: Virtual IP feature of Windows 2008 R2 does not work on ESX 4
            al-arenal Lurker

            tried everything, but it doesnt work for my environment.

             

            I have an ESX4.0 Host:

            ->DHCP-Server@Win2008R2Enterprise

            ->RemoteDesktopHost@Win2008R2Standard

            Ip-Virt. activated on E1000 connected to the same VSwitch as the DHCP Server, VMware Tools are deinstalled, IPv6 disabled

            • 18. Re: Virtual IP feature of Windows 2008 R2 does not work on ESX 4
              mepsus Lurker

              Thanks, Marcj1

              I was helped by the following:

              1. add VMXNET3 adapter and remove E1000

              2. uninstalling the VMCI driver by modifying the VMware Tools installation

              3. disabling IPv6 by unchecking the box in the Local Area Connection properties

              4. setting the DisabledComponents DWORD value to 0xFFFFFFFF under HKLM\CurrentControlSet\services\TCPIP6\Parameters in the registry

              1 2 Previous Next