6 Replies Latest reply on Oct 17, 2018 2:42 AM by BJBW

    USB Redirection - can't get my card readers to work

    VDIWannabe007 Novice

      Hi All,

       

      I am running ESX 3.5 + WVMWare View 3.1.1 and for this example I am using VMWare View Client (3.1) to connect to the virtual desktop.

       

      I have enabled USB redirection and have tested the USB redirection with a USB drive which works perfectly. I have two card readers that I need to use on my virtual desktop but neither of the card readers will appear so that they can be mapped from my physical desktop to the virtual desktop. The card reader appears in device manager on my physical desktop and installs perfectly but I do not have the option to map it to my virtual desktop. I have tried 2 different USB card readers and have the same issue with both.

       

      The two crad readers I have tried is a datakey card reader, and a no name brand.

       

      I have also tried to map the card readers through a wyse V10L. I have the USB virtualizer software (2.1.5) installed on the virtual machine and the correct TCX license installed. I have also setup the specific card reader in the USB virtualizer software with the correct product and vendor ID but still no luck. After checking the WYSE device logs when plugging the USB card reader in i see the WYSE device picks up the USB card reader however it is still not mapped to the virtual desktop. If I plug in a USB storage device the virtual desktop picks this up and it maps through fine.

       

      Any help would be greatly appreciated..

        • 1. Re: USB Redirection - can't get my card readers to work
          AdamBil Enthusiast

           

          Hi there,

           

           

          I had the same issue on my View 4 installation.  I modified this reg key:

           

           

          HKEY_LOCAL_MACHINE\SOFTWARE\VMware, Inc.\VMware VDM\USB  AllowSmartcards=true

           

           

          This allowed me to redirect smart card readers into the sessions.  Caveats go along with using the card in the session in that if you're local machine is in a domain and using the smart card with removal policies, the redirected reader would effectively result in locking your local machine. 

           

           

          If you're using View 3.1, then this isn't using PCoIP like I am so I am assuming RDP should open the virtual channel and allow smart cards to work but it seems like it's not creating the VC.  It might be as simple as initially testing using mstsc.exe and connecting to the VM and making sure it works in that case.  Once confirmed that it's working there, check if there's an ADM template you can use from View 3.1's connection server (usually in an "Extras" directory) and confirm the GPO is set properly.

           

           

          Lastly, I would recommend confirming that smart card is set for the broker for single-sign-on using the connection servers settings and seeing if it works for that portion.

           

           

          Regards,

           

           

          --Adam

           

           

          • 2. Re: USB Redirection - can't get my card readers to work
            VDIWannabe007 Novice

            My Smart card readers are not used to login to the operating system. They need to be used to authenticate particular applications that  we use, therefore they need to be mapped through as USB smart card readers so I can see them in the client XP operating system, and so that the smart card reader software installed on the operating system can see the smart card reader device too.

             

            I have tried to connect to the XP desktop (and a windows 2003 server for testing purposes too) via RDP directly with the options to map Plug and play devices, USB devices and smart cards all enabled however the smart cards do not get mapped. If i plug in a usb storage device that gets mapped just fine.

             

            I have read on some forums that additional software is trequired to get some usb devices working through rdp sessions e.g :

             

            USB for Remote Desktop

             

            http://www.fabulatech.com/usb-for-remote-desktop.html

             

            USB Redirector - RDP Edition

             

            http://www.incentivespro.com/rdp-usb-redirector.html

             

            However because I am using VMware View, i dont suppose i need to use additional software.

             

            I just cant seem to get this working on my version of VMware view 3.1.1 for the way i need it to work.

             

            I have checked all the policies and reg settings which might prevent the smart card reader from being mapped but these are all default setting which should allow it.

             

            PLEASE HELP

            • 3. Re: USB Redirection - can't get my card readers to work
              bradykev Lurker

               

              To get our smartcards to work in View 3.1, we had to install the software on both the client and agent side. We were able to get away with just the drives on the client side.

               

               

               

               

               

              It would not work if we selected it from the USB dropdown list. Since RDP has a built in channel for smartcards it would pass it without selecting from the dropdown. If we did select it from the USB dropdown it would not work.

               

               

               

               

               

              Not sure if this will help you.

               

               

              • 4. Re: USB Redirection - can't get my card readers to work
                Rexroat_J Lurker

                If there are no drivers required to be installed for your readers, or other USB/HID device for that matter, VDI/View will not "see" them on the client to allow for passsthrough.  The only way I have discovered to pass this through is via the Registry Key HKLM\Software\VMware, Inc\VMware VDM\USB\.  Create a Multi-String Value named AllowHardwareIDs and set the value to the Vendor and Product ID string of the device(s) you are attempting to passthrough, in the format VID_####&PID_#### that you can find from the Control Panel under Human Interface Devices.

                 

                To get the VID and PID string, right-click the device in Device Manager and select the Details tab.  Select the Device Instance ID which will look something like HID\VID_06A8&PID_0043\6&89971BE&..........  All you need is the VID_####&PID_##### portion of the string to paste into the registry key value.

                 

                One word of warning, make certain you do not grab the values for the Keyboard or Mouse, or you will lose input ability to your client   If in doubt, unplug and replug your device and refresh Device Manager to verify you are grabbing the values from the correct device(s).

                • 5. Re: USB Redirection - can't get my card readers to work
                  Scald Lurker

                  Thank You for pointing to this direction, I could find KB Article 1011600, but all this settings are not working (AllowHardwareIDs & AllowSmartcards).

                  I use VMware View 4.5, Linked Clones installation. I use several smartcards from different vendors with no luck.

                  It does not matter, if physical computer has or has not appropriate drivers for smartcards.

                  Can You post some screenshots of Your USB redirection installation (Registry settings, physical computer USB device, virtual computer USB device)?

                  • 6. Re: USB Redirection - can't get my card readers to work
                    BJBW Lurker

                    Hello all people!

                    Already found a similar problem here on the forum. The question is not so fresh, but my answer may help. I also encountered a problem in working with a virtual desk, I had a problem, either one or the second device was working.

                    I found the USB Network Gate, I managed to solve the problem. It's good that in the trial version you can understand whether the software is suitable or not.