9 Replies Latest reply on Jan 7, 2010 1:14 PM by newbie93

    Laptop + LPT (on Docking station) == work???

    newbie93 Hot Shot

      Setup:

       

      Host: 6.5.3 on Windows XP SP3 (laptop + docking station)

      Guest: Debian 5.03 (doesn't really matter)...

       

      After I add the parallel port(with the laptop docked, obviously), and start the VM, I get the error:

       

      Jan 04 09:58:53.723: vmx| parallel0: Using auto detect backend LPT1.

      Jan 04 09:58:53.723: vmx| parallel0: FAIL to open the parallel port driver
      .\Global\VMparport1 error 0x2 in ParallelHost_DeviceConnect()

      Jan 04 09:58:53.723: vmx| Msg_Post: Error

      Jan 04 09:58:53.723: vmx| http://msg.parallel.badDriver Cannot open VMparport driver for LPT1: The operation completed successfully

      Jan 04 09:58:53.723: vmx| http://msg.device.badconnect Failed to connect virtual device parallel0.

       

      I did a search on LPT, parallel port, found very little.

       

      Questions:

       

      1). When I installed VMWare, I did not have the docking station attached. Does this cause a problem? I will reinstall with it docked, if somebody thinks that will help

       

      2). I understand about the limitations of peripherals being on the "motherboard". Does a docking station constitute a motherboard or an external peripheral?

       

      The properties (on the host), lists it as:

       

      "on Intel(R) ICH9M-E LPC Interface Controller - 2917" so, I think it is considered part of the motherboard.

       

      Also, the driver installed is the standard XP OS driver:

       

      "C:\WINDOWS\system32\DRIVERS\parport.sys"

       

      I tried both autodetect and specifying the existing port (LPT1).

       

       

      3) vmware tools are NOT installed in any of the guests. - Is this required?

       

       

      4) Also tried logging into host with admin privileges (Normally I run as a user on the host). Didn't seem to make any difference.

       

       

      Any suggestions?

       

      Workstation 7.x isn't an option right now (way too many bugs for me right now)

       

      Thanks.