8 Replies Latest reply on Apr 14, 2011 2:22 AM by IrmaIsfot

    How can I fix USB Arbitration won't start Error 31: A device is not functioning

    PatrickSteranka Novice

      Any ideas how to fix or troubleshoot this error.

      I read following thread but wasn't able to post to the thread (because it was LOCKED).

      VMWare Communities Thread 1383098

       

      I purchased a new Win7 box, and installed VMWare Workstation 7 on it.  It works great EXCEPT that I can't access USB devices.  When the VM starts I get an error saying: 

       

      Host USB device connections disabled.

      The connection to the VMware USB Arbitration Service was unsuccessful.  Please check the status of this service in the Microsoft Management Console.

       

      I've looked at the log in C:\Windows\Temp\vmware-SYSTEM\vmware-usbarb-SYSTEM-####.log, and it doesn't have much more than the above error.  It's shown below:

       

      -


      Nov 10 05:10:24.039: usbArb| Log for VMware USB Arbitration Service pid=3520 version=3.0.0 build=build-203739 option=Release

      Nov 10 05:10:24.039: usbArb| The process is 32-bit.

      Nov 10 05:10:24.039: usbArb| Host codepage=windows-1252 encoding=windows-1252

      Nov 10 05:10:24.039: usbArb| DICT --- USER PREFERENCES C:\Windows\system32\config\systemprofile\AppData\Roaming\VMware\preferences.ini

      Nov 10 05:10:24.040: usbArb| DICT --- USER DEFAULTS C:\Windows\system32\config\systemprofile\AppData\Roaming\VMware\config.ini

      Nov 10 05:10:24.040: usbArb| DICT --- HOST DEFAULTS C:\ProgramData\VMware\VMware USB Arbitration Service\config.ini

      Nov 10 05:10:24.040: usbArb| DICT --- SITE DEFAULTS C:\ProgramData\VMware\VMware USB Arbitration Service\config.ini

      Nov 10 05:10:24.042: usbArb-3536| USBArb: Starting VMUSBArbService args:'VMUSBArbService'

      Nov 10 05:10:24.043: usbArb-3536| USBArb: USBArbInit failed with error:31

      Nov 10 05:10:24.044: usbArb-3536| USBArb: Stopping service, status:31

      -


      I've looked at some of the logs (but there were too many to go through) at c:\users\ current user\AppData\Local\Temp.  The logs were named:  vminst.log, vmsetup.log, vmmsi.log.  I can post them if this will help but there are several of them and different copies under different users (admin1, user1, user2, etc)

       

      I've tried manually starting the USB Arbitration Service and it doesn't start (same simple error, Error 31 stated above).

       

      I've looked for a "AMD USB Filter Driver" to disable it (this worked for another person) but didn't find one installed.

       

      My configuration is:

      Hardware: HP Pavilion Elite - AMD X4 2.6GHz 8Gig DDR3

      Host OS: Windows 7 Home Premium, 64-bit  (Build 7600) 6.1.7600

      Guest OS: Win XP Pro SP3 (but I think the problem is unrelated to the Guest)

      VMWare Worksation: 7.0.0 build-203739

       

      I love the speed of the system but I've also run into problems disk cloaning (for some reason the SATA drives are not detected by some disk imaging software).   I was able to get Ghost to work but not Acronis, or Paragon.  I think this is a separate issue but share it in case it matters.  In these cases, posts reported that the X58 chipset (I think this is right but I'm not positive).  This is too low level for me to follow.