1 Reply Latest reply on Nov 6, 2009 6:44 AM by poentaEosei

    Windows 95C & the SBPCI128 driver & Creative ENSONIQ AudioPCI driver….

    celebi23 Novice

      This is an odd question, I admit.  So, I've got Windows 95C running in VMware Fusion (2.0.6) on my Mac.  I downloaded the "Sound Blaster PCI128 (Drivers Only - Windows 9x) " driver (from the "Sound Blaster PCI 128" product page http://support.creative.com/Products/ProductDetails.aspx?catID=1&subCatID=207&prodID=1864&prodName=Sound%20Blaster%20PCI%20128&subCatName=Others&CatName=Sound+Blaster ) & installed it.  Right before the registration window pops up, I got a BSOD:

       

      "A fatal exception 0E has occurred at 0028:C55118F7 in VXD ctpci9x(05)

      + 00001853.  The current application will be terminated."

       

      Right after the VM reboots, I get a "Windows protection error" message. 

       

      So, I had to boot into Safe Mode & disable/remove the SBPCI128 driver so that I could reboot into the normal mode. 

       

      I then tried the Creative ENSONIQ AudioPCI driver

      http://communities.vmware.com/message/78617

      http://support.creative.com/downloads/download.aspx?nDownloadId=259

       

      I also got a BSOD with that driver as well (right before the installation finishes:

       

      "A fatal exception 0E has occurred at 0028:C54C4FC7 in VXD ctpci9x(05)

      + 00001853.  The current application will be terminated."

       

      My question is this: is there a workaround to make either of these drivers work with Windows 95C or, is there another audio driver out there for it?  Any help would be greatly appreciated

        • 1. Re: Windows 95C & the SBPCI128 driver & Creative ENSONIQ AudioPCI driver….
          poentaEosei Lurker

           

          Hi,

           

           

          I'm not an expert but I have had the same problem with Windows 98SE with Vmware Player for Windows Vista; I hope that this solution is useful!

           

           

          I've tried to use the SB128 drivers (SBPCI128Setupus_w9x.exe), getting the same BSOD; so I've downloaded the file from the same link that you have posted (the first one), and before installing the new drivers (SBPCI_WebDrvsV5_12_01.exe) I've modified with a text editor the .vmx file related to the virtual machine, introducing at the end of the file the line:

           

           

          sound.virtualDev = "es1371"

           

           

          (power off the VM before doing it!); I've booted up the virtual machine and I've deleted the file C:\windows\inf\ctpci9x.inf, generated from the previous, unlucky setup.I've launched SBPCI_WebDrvsV5_12_01.exe, followed all the steps and rebooted.

           

           

          I hope that my instructions are understandable - as you can see, my english it's not very good!