1 2 Previous Next 22 Replies Latest reply on Apr 25, 2019 6:49 AM by Klyborg Go to original post
      • 15. Re: Can't Remove Host from dvSwitch
        swiftyb Lurker

        I joined the forums just to say thanks to XavierE - you have solved hours of heartache! Thank you very much!!

         

         

         

         

         

        I had a vSphere host which i disconnected from the vds (host was connected, i removed one port but forgot the other, deleted the .vds data folder from the machine - stupid move) removed the hosts from vcentre then bingo! removed the vds!

        • 16. Re: Can't Remove Host from dvSwitch
          Kahlid74 Lurker

          I also had this issue however, I was getting an error about  "Shadow/Zombie port" in existence.  I disconnected the Host and was then able to successfully remove the host from the dvSwitch.  When I reconneted the host it gave me two warnings about the host and it not being in the dvSwitch.  I removed the host from the vCenter instance and then logged directly into the host.

           

           

           

           

          What was odd then was that the host still thought it was part of the dvSwitch even without being in vCenter.  I've rebooted the host but if it's still part of the dvSwitch I'm going to try to forcefully remove it from the CLI.

           

           

           

           

           

          Update - Once I rebooted the Host, the dvSwitch still showed up but had no ports and was just a grey box.  I clicked the remove button and voilla, gone as gone can be.  I wonder ifit has something to do with the service console being on a dvSwitch and it's use/integration with vCenter.

          • 17. Re: Can't Remove Host from dvSwitch
            PeterVG Enthusiast

             

            Yeah, disconnecting the host did the trick for me as well. Tnx for the tip !!

             

             

             

             

             

            Does anybody know if it is possible to remove a host from a dvSwitch via the CLI ?? I've been looking around, but can't seem to find anything on this subject...

             

             

            Tnx in advance for any help !!

             

             

            Grtz, Peter

             

             

            • 18. Re: Can't Remove Host from dvSwitch
              theemax Novice

              Same here, i had same issue  and what ever i did, would remove "ghost port", even reboot.

              Disconnect and reconnect to vCenter did it.

               

              thx Guys!

              eMax

              • 19. Re: Can't Remove Host from dvSwitch
                sg222 Novice

                Hi there,

                 

                pretty old thread, but still the one which exactly deals with the problem we have today.

                 

                Situation:

                4 node esx cluster, running on vsphere 4.1i update 3, build 800380, using vmware HA and vmware drs - fully automated.

                 

                vCenter running on version 5.0

                 

                Distributed vSwitch with 4 uplinks on each host, running as a 4.1.0 dvSwitch.

                 

                Today we tried to evacuate on of our hosts to maintain it tomorrow.

                 

                The vCenter scheduled all migrations and suddenly stopped doing anything. We found out, that it tried to migrate 4 vms to the same host (normally no problem), but this host had issues with the distributed switch.

                Checking the hosts network settings seems to show normal values, but checking directly connected to the host with vsphere client, the host reported "This host has no physical adapters connected to distributed switch".

                This message was weird, as the already running vms were all online.

                 

                With vmware support we had to stop vcenter service as it had a lot of issues configuring the dvswitch on the "problem" host. After restart of service at least vcenter was available again and showed, that all tasks concerning vm-migrations were cancelled.

                After that we evacuated the problem host and removed all uplinks from the dvswitch. Reboot and connected the vmnics to the dvswitch again.

                 

                Still the host could not determine which of his vmnics are connected to the dvswitch. Therefore i removed all uplinks again, disconnected the host from vcenter, removed the host from dvswitch and rebooted it again.

                After boot i connected the host again to vcenter. Now the host can determine which uplinks are connected, but it can't determine which portgroups should be availabe on this dvswitch!

                 

                I migrated a test-vm to this host and it remained online and reachable, but on the host i see in the vm-settings, checking the portgroup "Invalid Backing" - and i'm connected as root. In advanced settings i can see the correct dvswitch-port, but not the portgroup.

                 

                After 1 h the host got the right port-group showing up in network settings, dvswitch section. So i migrated some other vms to it, vms of other portgroups. But now, after finally 2 more hours the host still can't determine the new (and used) portgroups, but the vms are online.

                 

                Does someone has an idea on that?

                 

                Our vCenter does not see any problems, but i think all hosts should see their right network-settings. All other hosts in that cluster see correct data.

                 

                Attachements:

                invalid_backing_host.jpg

                a look on vm-settings directly connected to the problem esxi host

                 

                vcenter_information.jpg

                a look on vm-settings on vcenter

                • 20. Re: Can't Remove Host from dvSwitch
                  sg222 Novice

                  Update:

                   

                  Dumb "trick":

                  I migrated vms to the problem host. The host did not get the right port groups of these vms and showed "invalid backing" and no portgroup available in drop down (vm-settings) on host.

                   

                  To update the host i had to use the vcenter:

                  - open settings of a vm already running on problem host

                  - select the network card

                  - open the drop down to select the portgroup and select the correct portgroup (again, as it was already active) !

                  - vcenter marks this as a change in configuration and "deploys" the new config to the underlying host

                   

                  result:

                  - the problem host was now aware of all portgroups which i reactivated in vm-settings and showed up the right dvswitch-settings. I had to repeat the process for one vm in each portgroup (not all vms) and after that - all vms were shown up right!

                   

                  dumb, but worked fine for me... damn dvswitch.

                   

                  new update: the problem host knew that he has a distributed vswitch, and it worked all fine, all vms were online. But it did not get the whole list of portgroups of the dvswitch from vcenter. The vcenter did not push the whole configuration onto the esx host.

                  I had to migrate one vm out of each portgroup onto the problem host and repeat the procedure in vcenter - confirming its portgroup by reselecting it and confirm config clicking ok. After that the vcenter pushed the portgroup to the problem host. That dvswitch still has a lot of issues concerning vcenter connectivity.

                  • 21. Re: Can't Remove Host from dvSwitch
                    spennell Lurker

                    After spending the last two hours trying to gracefully remove a host from a vDS this is what did the trick.

                    • 22. Re: Can't Remove Host from dvSwitch
                      Klyborg Lurker

                      Very helpful. Thanks for this.

                      One note, we actually had to delete the vmkernel adapter on that dvswitch, disconnect host, reconnect host, and then hit remove on the dvswitch again (still receiving error), and then it just fell off.

                      After that we were able to add the dvswitch back to the host.

                      1 2 Previous Next