0 Replies Latest reply on Oct 18, 2009 11:44 AM by mierdatuti

    Problem installing vmware tools in gust mythubuntu 9.10

    mierdatuti Novice

       

      Hi,

       

       

       

       

       

      I'm trying to install vmware tools in my guest mythubuntu 9.10. Everithing seems ok but when I reboot I can't boot with startx. When I install the wmare tools it says me:

       

       

       

       

       

      make: Leaving directory `/tmp/vmware-config1/vsock-only'

      The vsock module loads perfectly into the running kernel.

       

       

       

      Detected X.org version 7.5.4.

       

       

       

      The configuration file /etc/X11/xorg.conf can not be found. Do you want to

      create a new one? (yes/no)

       

      /bin/grep: /etc/fedora-release: No such file or directory

      /bin/grep: /etc/SuSE-release: No such file or directory

      Rather than invoking init scripts through /etc/init.d, use the service(8)

      utility, e.g. service hal restart

       

      Since the script you are attempting to invoke has been converted to an

      Upstart job, you may also use the restart(8) utility, e.g. restart hal

      hal start/running, process 12832

       

      X.Org X Server 1.6.4

      Release Date: 2009-9-27

      X Protocol Version 11, Revision 0

      Build Operating System: Linux 2.6.24-24-server i686 Ubuntu

      Current Operating System: Linux david-desktop 2.6.31-14-generic #48-Ubuntu SMP Fri Oct 16 14:04:26 UTC 2009 i686

      Kernel command line: BOOT_IMAGE=/boot/vmlinuz-2.6.31-14-generic root=UUID=a2630835-db83-4dc1-a66d-0684a1b41564 ro quiet splash

      Build Date: 14 October 2009  11:18:16PM

      xorg-server 2:1.6.4-2ubuntu3 (buildd@)

          Before reporting problems, check http://wiki.x.org

          to make sure that you have the latest version.

      Markers: (--) probed, (**) from config file, (==) default setting,

          (++) from command line, (!!) notice, (II) informational,

          (WW) warning, (EE) error, (NI) not implemented, (??) unknown.

      (++) Log file: "/tmp/vmware-config0/XF86ConfigLog.2930", Time: Sun Oct 18 20:33:43 2009

      (EE) Unable to locate/open config file: "/tmp/vmware-config0/XF86Config.2930"

      (==) Using default built-in configuration (30 lines)

      (EE) open /dev/fb0: No such file or directory

       

      X is running fine with the new config file.

       

      ddxSigGiveUp: Closing log

         Checking acpi hot plug                                              done

      Starting VMware Tools services in the virtual machine:

         Switching to guest configuration:                                   done

         Guest filesystem driver:                                            done

         Mounting HGFS shares:                                              failed

         Guest memory manager:                                               done

         Guest vmxnet fast network device:                                   done

         VM communication interface:                                         done

         VM communication interface socket family:                           done

         Blocking file system:                                               done

         Guest operating system daemon:                                      done

         Virtual Printing daemon:                                            done

       

      The configuration of VMware Tools 7.8.6 build-185404 for Linux for this running

      kernel completed successfully.

       

      You must restart your X session before any mouse or graphics changes take

      effect.

       

      You can now run VMware Tools by invoking the following command:

      "/usr/bin/vmware-toolbox" during an X server session.

       

      To enable advanced X features (e.g., guest resolution fit, drag and drop, and

      file and text copy/paste), you will need to do one (or more) of the following:

      1. Manually start /usr/bin/vmware-user

      2. Log out and log back into your desktop session; and,

      3. Restart your X session.

       

      To use the vmxnet driver, restart networking using the following commands:

      /etc/init.d/networking stop

      rmmod pcnet32

      rmmod vmxnet

      modprobe vmxnet

      /etc/init.d/networking start

       

      Enjoy,

       

       

      Any help?

       

       

      Many thanks and sorry for my english!