0 Replies Latest reply on Oct 7, 2009 9:08 AM by paksun

    Cannot browse VM's directories with Netbackup 6.5.4 and file level backup problem in  SAN mode

    paksun Lurker

      I'm a user of Netbackup 6.5.4, the main reason I'm using it because I want to make file level backups (through VCB snapshots) for guest virtual machines (windows server 2003 guest, not in IDE mode and got VM tool installed) in a VMware ESX Server 4 (VSphere).  I have VCB 1.5.0 installed; I have both master server and media server set on a machine (another physical machine) that runs Windows Server 2003; I also set the machine the backup proxy server for backup jobs.  I'm able to select virtual machines on the ESX server (for "Windows-NT" polices) to be backed up also. But I end up with two problems.

       

      First, it is concern with "directory browse button" of guest virtual machines. To my knowledge, there are two possible modes / connection architectures for VCB, the LAN mode and SAN mode; I have no problem with backup jobs under LAN mode as long as I enter Directories to be backed up in the "Backup Selections" of a "Windows-NT" policy. But the "browse directory" button for virtual machines (clients of a policy) is not working (at a place where "Windows 2000, Windows 2003" and "System state"...etc can be selected), so as the "client machine properties", "cannot connect on socket 25" errors occur.

       

       

      Second, I cannot make file level backups under SAN mode. I have all setting the same as above except the "Snapshot Options" set as "san=0" rather than "nbd=1" of the policy type. I ‘m sure the proxy server and the ESX server share the same iSCSI storage under this scenario (and properly set), but backups end up with "bpfis: WRN - Cannot create snapshot after waiting for SNAP_LOCK_TIMEOUT: 15 minutes,  bpfis: INF - EXIT STATUS 156: snapshot error encountered".

       

       

      Have I missed some configuration? Currently, I have no VMware vCenter Server installed, any relation to this? Any help would be appreciated. Thank you.