1 2 3 Previous Next 33 Replies Latest reply on May 15, 2018 6:14 AM by EFD7887

    OVF export fails with timeout error

    dendicott Lurker

       

      When I try to export a VM to OVF, it fails with error "Failed to Export Virtual Machine: The Operation has Timed Out."  The event long shows that the task was cancelled by a user.  I have tried this from 2 different workstations and the vcenter console with no change in symptoms.  I have also tried different VMs with no change.  Any help would be greatly appreciated.

       

       

      Thanks,

      DLE 

       

       

        • 1. Re: OVF export fails with timeout error
          TobiasKracht Expert

          And what is your goal? Maybe for you is simplier to copy VM`s files or convert it to other format.

           

          StarWind Software R&D

          • 2. Re: OVF export fails with timeout error
            dendicott Lurker

            I could just copy the files, but this feature should work. I need to 

            determine why it is failing and repair it.

             

            Thanks,

            DLE

             

            Sent from my iPhone

             

            On Sep 22, 2009, at 7:38 AM, "TobiasKracht" <communities-emailer@vmware.com

            • 3. Re: OVF export fails with timeout error
              techierick Lurker

              Curious that this has never been answered. I have the exact same problem, but it only effects Suse Linux 11. I'm using ver 4.0 now, and still have the problem.

              • 4. Re: OVF export fails with timeout error
                mike.tummy Novice

                 

                I am seeing the same issue exporting a system to OVF, also as an OVA.  Watching the temporary file get written to the host running vsphere, data transfer slows down to a crawl and eventually stops when the timeout occurs.  Because of these timeouts exporting the templates I'm now unable to use templating at all at this point.

                 

                 

                Has anyone else seen this or been able to diagnose or trouble-shoot it?

                 

                 

                • 5. Re: OVF export fails with timeout error
                  obriensl Novice

                  I am also having this same issue on vSphere - mine is a SLES10 x64 vm. Has anyone found a reason/fix?

                  • 6. Re: OVF export fails with timeout error
                    mike.tummy Novice

                     

                    I've not found a reason or an actual fix but I was able to effect a workaround of sorts.  I had previously exported these systems to my windows management host running the vsphere client.  I created new VMs on a different ESXi server using these templates, updated them and re-exported (to OVF template) which worked. So basically, exporting from one host workd but not from another.  It used to work just fine from the host that it now fails on.

                     

                     

                     

                     

                     

                    This wouldn't work for a production system but worked for me for these systems I only use as templates.  All servers involved are running 4.0.0.  It's certainly a frustrating issue.

                     

                     

                    • 7. Re: OVF export fails with timeout error
                      MartinMPP Lurker

                      This happens for me as well, the system is running 4.0, timeout is at random completion levels.  Guest OS is Ubuntu 10.04 server, 2 hard drives in the guest that are sat on 2 physical drives (12GB/50GB), on thin Provisioning, the 50GB is barely used at all.

                       

                      I'm going to try copying the file off using the datastore browser, but it's not really the best way to do this... should this not be working?

                      • 8. Re: OVF export fails with timeout error
                        JuBa22 Novice

                        I'm also experiencing this issue.

                        I use vcenter 4.1 and esx 4.0 U1.

                         

                        Regards,

                        JB

                        • 9. Re: OVF export fails with timeout error
                          srujal Lurker

                          I have same issue..

                          • 10. Re: OVF export fails with timeout error
                            mikelane Expert

                            I am currently experiencing this issue (so far on a single VM (Ubuntu 10.4 - thing provisioned). Below is my log (FWIW) for the evening trying to look at this problem ...

                             

                            I did successfully export a different VM so that was cool.

                             

                            I had been using a thinstalled version of the vSphere client so I installed the full application and found that this made no difference at all.

                             

                            So I tried to copy all of the files from the affected VM folder to a new folder and got tons of windows with the following error:

                             

                            Connection timeout while waiting in the queue.

                            Error stack

                            Call "PropertyCollector.CreateFilter" for object "ha-property-collector"

                             

                            This took a little while and resulted in a Purple Screen Of Death as I ran out of disk space. I rebooted (deleted the new folder I had tried to copy the VM to) and deleted all of the snapshots for the affected VM.

                             

                            After this I managed to export it successfully (using the thinapped vSphere client).

                             

                            So for me either removing snapshots or rebooting (or both) *appears* to have fixed the issue ... YMMV ...

                            • 11. Re: OVF export fails with timeout error
                              JuBa22 Novice

                              Problem solved in esxi 4.1.

                               

                              Best regards,

                              JB

                              • 12. Re: OVF export fails with timeout error
                                derekAndree Lurker

                                This is *not* fixed in 4.1.  I am having this exact issue with 4.1.

                                 

                                - all my disks are thin provisioned

                                - i can export smaller VMs

                                - brand new VM with 200G disk thin provisioned will not export to OVA (total size is probably 1G)

                                 

                                Every time I try to export I get a timeout error, usually around "37 minutes remaining"

                                 

                                I've exported VMs with a larger utilization although thin provisioned with no issues.  It appears to only happen on these larger thin provisioned disks.

                                • 13. Re: OVF export fails with timeout error
                                  Zydox Lurker

                                  I have the same issue with ESXi 5.0.0.

                                   

                                  Works great for guests with a thin disk of 100GB or less, but if the disk is above 200GB it fails every time.

                                   

                                  I also find it quite intressting that once I've deleted the guest from vSphere, the guest directory is still left on the datastore with just the 200GB disk files... and these are possible to delete though the vSpere's browse datastorage, so I'm assuming its not an issue on the NFS server side (QNAP 459)

                                  • 14. Re: OVF export fails with timeout error
                                    sandybruce Novice

                                    I also am having this issue on 5.0.0, with the most up to date build. I have a 1TB volume assigned to this RHEL6 64bit VM. I've taken backups before of this system. However, I may not have used snapshots when I did that backup. After reading this thread, maybe I'll try to delete all the snapshots and then re-do the image export. Maybe it does have to do with volumes larger than 200GB as another poster suggested.

                                    1 2 3 Previous Next