6 Replies Latest reply on Aug 21, 2010 5:38 AM by Axky

    Windows 7 Host bridging - A Temporary Solution till VMWare fixes.

    Joffenb Lurker

      After grumbling and cussing and researching on the problem with Windows 7 RTM as a host for VMWare Workstation (ver 6.5.2) and internet access, I finally have the system working (after a few gotchas).

       

      The following is a step by step procedure that should let the normal user utilize Windows 7 as a host for VMWare Workstation (works on 6.5.2 - untested with other versions) who is connected to the internet via a normal router (computer uses a private IP e.g. 192.168.1.100).

       

       

      On the host computer, reconfigure your network as a Work network rather than a Home group. Home group requires IPV6 to communicate and the virtual portion of VMWare does not support IPv6. (found this out after getting all else to work and then not being able to connect to internet from host - virtuals worked fine.) To do this, click start --> Network and Select Network and Sharing Center. In the middle of the screen under your active network, you probably see Home Group. Double click it and change the location to Work network.

       

       

      1. Set your internet connecting network with a static IPv4 address outside the range of your router's DHCP and manually set up your provider's DNS. With the Linksys, DHCP uses 192.168.1.100-149, so I set IP to 192.168.1.99 with a gateway of 192.168.1.1 and netmask of 255.255.255.0. You can check gateway, netmask and DNS servers with an "ipconfig /all" from a cmd prompt.

      2. Open VMWare and click "edit" then Virtual network editor. Click the Host Virtual Adapters tab and remove all that are present. Click Apply. When all are empty, click "Add..." and use VMnet2. You should see a "Local Area Connection X" appear. Click the Host Virtual Network Mapping tab and click the right arrow to the Right of the VMNet2 line and select Subnet. Set the subnet equal to the subnet of your router. (in my case it's 192.168.1.0 and 255.255.255.0). Click Apply. Click the same right arrow again and select DHCP. Set the Start IP address and End IP address to a range outside that of your router and not including the static IP you set your internet access NIC to. I used 192.168.1.150 and 192.168.1.200. You can change the lease times, but I left them at the default. Click OK and Apply. Click the DHCP tab and insure that DHCP is started. If not, start it and click Apply. Click the NAT tab and select disable and stop the service. Click Apply.

      3. On the host computer, do a start --> Network and Select Network and Sharing Center. Click the "Change adapter settings" in the left pane. You should see at least two items. The NIC you normally use to connect to the internet with, and the VMWare Virtual Adapter. Highlight one, then hold the control key while highlighting the other. Right click and select "Bridge" Your host machine is now set up to just use IPv4 and should bridge the VMWare adapter and your internet NIC correctly. (Well, maybe not correctly, but with a static IP, it will work.) Now on to the virtual machines.

      4. On each virtual machine, devices tab, double click the "Network Adapter" line. Highlight the radio button on the "Custom" line and select VMnet2. Click OK and the virtual machine should start, get it's IP from VMWare's DHCP, and bridge through the host machine to the internet. (At least it's working for me.)

       

       

       

       

       

      The above should work, however, if you're running additional 3rd Party firewall software, you may need additional changes. If so, recommend you disable them till you get VM working, then re-enable and adjust configurations till you get all working.

       

       

      Let me know if anyone has problems with this. Just got it working and think the above should be complete enough to follow...