9 Replies Latest reply on Sep 7, 2011 9:29 AM by pglick201110141

    VLANs and Dell Blades

    VinceButler Novice

       

      I know this is more a Dell question than a Vmware question, but I figure some of you are using the same BladeSystem as me and may be able to provide a quicker answer than Dell. We have a new M1000E BladeSystem which contains four M600 servers (each with 6 NICs) and six M6220 interconnect switches. The plan is to dedicate two of the switches to iSCSI and connect the other four switches back to our core switch, aggregating all four external links on each switch. We plan to use those four switches for the VM data network, service console and VMotion (using VLANs).

       

       

      We have configured the link aggregation on the switches back to the ProCurve 5412 core switch and the link is up. We have configured all the internal switch ports as well as the LAG group to operate in trunk mode and we have created VLANs for use for service console (20) and VMotion (10). These VLANs are tagged on the internal ports as well as the LAG group uplink. On the HP, the ports that connect to the M6220 ports are configured as untagged for the default VLAN (1) and tagged for our other VLANs (10, 20). This is the same port configuration we use for some other VMware host servers which connect directly to the HP switch.

       

       

      Unless I have it configured incorrectly, this scenario should let me specify the VLAN in VMware and the traffic should pass through the M6220 switches to our core switch, which then routes traffic between the VLANs.

       

       

      When I install VMware on one of the blades I specify the first NIC to use for the service console. I specify VLAN ID 20 and provide static IP addressing for that subnet. When I try to ping that host from a workstation I can't reach it - keeps timing out.

       

       

      Is there anyone out there with a similar configuration (Dell Blades with M6220 using VLANs) who can tell me what I'm doing wrong? I'm pretty sure the VLAN configuration on the M6220s is incorrect but I can't figure out what we are doing wrong...

       

       

        • 1. Re: VLANs and Dell Blades
          azn2kew Champion

          Have you look at this guide yet, if not read page #9 regarding design VLAN for Dell Blades with VMware!  [http://www.bladesystems.org/elearning_center/WP/vmware_bladeservers_Dell.pdf]

           

          If you found this information useful, please consider awarding points for "Correct" or "Helpful". Thanks!!!

           

          Regards,

           

          Stefan Nguyen

          VMware vExpert 2009

          iGeek Systems Inc.

          VMware, Citrix, Microsoft Consultant

          • 2. Re: VLANs and Dell Blades
            VinceButler Novice

            Yes I did but it doesn't go into specifics about VLAN configurations on the M6220 switches. I'm sure that's where my problem is.

            • 3. Re: VLANs and Dell Blades
              azn2kew Champion

              For best practice configuring VLAN for Dell Blades, read the attached guide its pretty good. 

               

              If you found this information useful, please consider awarding points for "Correct" or "Helpful". Thanks!!!

               

              Regards,

               

              Stefan Nguyen

              VMware vExpert 2009

              iGeek Systems Inc.

              VMware, Citrix, Microsoft Consultant

              • 4. Re: VLANs and Dell Blades
                VinceButler Novice

                Yeah, I've looked at that too and it also doesn't have specifics about VLAN config.

                • 5. Re: VLANs and Dell Blades
                  ferjero989 Lurker

                   

                  funny enough i got the same issue, altho i decided to use the first 2 cards (switch a1 and a2) as console and vmotion only..

                   

                   

                  and.. well. i got the same problem.. in this case its a 5424 external switch...

                   

                   

                  got the same setup, m1000e chassis with 4 blades, 6 cards each, all 6 switches are m6220...

                   

                   

                  cant figure it out... without vlan everything works tho

                   

                   

                  • 6. Re: VLANs and Dell Blades
                    rmarul Novice

                    I also have the same problem. The attached documentation a few posts up is great if you want an overview at 10,000 feet.

                     

                    No thanks.

                     

                     

                     

                    I've tried to put the M6220 ports into all 3 port types with no luck.

                     

                     

                     

                    Anyone have any ideas?

                     

                     

                     

                     

                     

                    EDIT: These VMware communitys are obviously broke if someone can reply back with a non sense answer and be awarded points for answering it correct.

                    • 7. Re: VLANs and Dell Blades
                      awliste Hot Shot

                      Has anyone gotten anywhere with this?

                       

                      I'm facing this exact problem right now. I'm a Cisco guy and inherited this thing, and I can understand why folks don't use these switches. If anyone has a moment and can offer me some advice on this problem, I'd be much obliged.

                       

                      My problem is specifically this: from a VM, I can 'see' traffic from the host that is on the access port (eg, broadcast traffic, NBNS stuff), but I cannot talk to that host directly - it won't respond to pings or HTTP. I can see it trying to reply (I'll see it ARP for my VM's IP) but it's like it cannot resolve layer 3 traffic. I've walked through all kinds of configs on these ports and I still cannot get this thing to cooperate. It's been incredibly frustrating.

                       

                      If anyone has any thoughts, I'm all ears. All I want is for a ping to succeed from my VM, through it's portgroup, through the trunk, through the switch, to a host plugged in on an access port assigned to the same VLAN as the VM. It's driving me nuts. It's worth a six-pack from me.

                       

                      Here's the relevant parts of my switch config:

                       

                      console#show run
                      !Current Configuration:
                      !System Description "Powerconnect 8024, 3.1.4.5, VxWorks 6.5"
                      !System Software Version 3.1.4.5
                      !
                      configure
                      vlan database
                      vlan  2-1024
                      exit
                      interface vlan 40
                      name "iSCSI"
                      routing
                      ip address  10.0.127.215  255.255.255.0
                      exit
                      !

                      !

                      !

                      !
                      interface ethernet 1/xg3
                      gvrp enable
                      switchport mode trunk
                      switchport trunk allowed vlan add 40
                      exit

                      !

                      interface ethernet 1/xg17
                      gvrp enable
                      spanning-tree portfast
                      switchport access vlan 40
                      exit
                      !
                      interface ethernet 1/xg20
                      gvrp enable
                      spanning-tree portfast
                      switchport access vlan 40
                      exit
                      !

                       

                      Thanks for your time and help.

                      - Abe

                      • 8. Re: VLANs and Dell Blades
                        VinceButler Novice

                        I did resolve this problem although I don't recall exactly how - it's been too long :-/

                         

                        I do know we aren't using that HP switch anymore, we went back to our Cisco 6509 core switch. The main reason for switching back was due to a recurring multicast issue with the HP which they were unable to resolve. Unfortunately I can't recal if that also fixed *this* problem, or if I figured it out before that switch happened.

                         

                        In any case I have attached a copy of the config from one of my blade switches. Hopefully there is something useful in there; if not, the problem must have been on the HP side (in which case I can't help since that switch is long gone).

                        • 9. Re: VLANs and Dell Blades
                          pglick201110141 Lurker

                          VinceButler,

                           

                          Do you realize that you have multiple VLANs untagged on the same port?  This may work, but it seems undesirable.

                          For example, in your attached config:

                          switchport trunk allowed vlan add 10,20,30,40,50,60,80,90,100

                           

                          The Dell documentation states that the default for "switchport trunk allowed vlan add 10" is tagged, but I don't believe this is true, because if you enter "switchport trunk allowed vlan add 10 untagged", printing the configuration gives you "switchport trunk allowed vlan add 10" and if you enter "switchport trunk allowed vlan add 10 tagged" it prints "switchport trunk allowed vlan add 10 tagged".