1 2 3 4 Previous Next 47 Replies Latest reply on Mar 22, 2012 2:15 PM by Matthew Stewart

    Trouble with IBM x3650 M2 and ESX 4.0.0 Build 164009

    kp238 Novice

      I have 8 new IBM x3650 M2 (P/N: 794792G) servers installed with ESX 4.0.0 Build 164009. The servers come from IBM with UEFI Firmware 1.01 (with fixed problem "Interrupt routing was not valid for VMWARE 4.0" - http://www-947.ibm.com/systems/support/supportsite.wss/docdisplay?lndocid=MIGR-5079767&brandind=5000008).

       

       

       

       

       

      The Service Console show this error:

       

       

       

      0:00:00:02.582 cpu0:4096)CosCommon: 2103: Couldn't setup IRQ 11 with vector 193

       

       

       

      0:00:00:02.582 cpu0:4096)CosCommon: 2103: Couldn't setup IRQ 11 with vector 193 

       

       

       

       

       

       

       

       

       

       

      Who has an idea for solution?

       

       

       

       

       

       

       

       

       

       

      IBM say the problem is ESX 4.0 software and not the IBM hardware.

        • 1. Re: Trouble with IBM x3650 M2 and ESX 4.0.0 Build 164009
          JRArseneau Novice

           

          Just so you know, I have two new x3650 M2's with the same issue (different vector # however).

           

           

          This KB -> http://kb.vmware.com/selfservice/microsites/microsite.do?cmd=displayKC&docType=kc&externalId=1003812&sliceId=1&docTypeID=DT_KB_1_1

           

           

          There are simply too many devices using IRQ11. The KB indicates that you have to tell the BIOS to have these devices use different IRQs, but the x3650 M2 bios doesn't provide any option to do so.. I haven't had any issues so I don't think it's a big deal, but it is frustrating seeing that red message appear when you boot ESX

           

           

          • 2. Re: Trouble with IBM x3650 M2 and ESX 4.0.0 Build 164009
            vmroyale Guru
            User ModeratorsvExpert

            Hello.  Did either of you ever get this resolved?  I'm running into the same issue.  Thanks.

            • 3. Re: Trouble with IBM x3650 M2 and ESX 4.0.0 Build 164009
              JRArseneau Novice

              I didn't get it resolved, no...

               

              I've been running these ESX servers for just under a month on vSphere (essentially since May 21) and I haven't had any issues. I'm thinking it may be more of a warning than anything else.

              • 4. Re: Trouble with IBM x3650 M2 and ESX 4.0.0 Build 164009
                MCJJJJ Lurker

                 

                I've got the same issue. It would be nice if someone could post whether or not we should worry about this message.

                 

                 

                -J

                 

                 

                • 5. Re: Trouble with IBM x3650 M2 and ESX 4.0.0 Build 164009
                  jidhin Enthusiast
                  VMware Employees

                  please upgrade the BIOS to latest version.

                  • 6. Re: Trouble with IBM x3650 M2 and ESX 4.0.0 Build 164009
                    MCJJJJ Lurker

                     

                    Sorry if I was unclear, but by saying I have the same problem I meant that I have updated to the latest uEFI/BIOS that IBM has on their website, just like the original post mentions. It is version D6E124AUS or, as referred to above 1.01 and can be found here:

                     

                     

                    http://www-947.ibm.com/systems/support/supportsite.wss/docdisplay?lndocid=MIGR-5079767&brandind=5000008

                     

                     

                    Unless there is an update that is only available by calling IBM support I'm not sure what you are referring to. Is there a newer uEFI/BIOS that I should be running?

                     

                     

                    • 7. Re: Trouble with IBM x3650 M2 and ESX 4.0.0 Build 164009
                      MCJJJJ Lurker

                      I spoke to VMware and they are aware of this issue and are working with IBM on a solution.

                      • 8. Re: Trouble with IBM x3650 M2 and ESX 4.0.0 Build 164009
                        vmroyale Guru
                        vExpertUser Moderators

                        Thanks for the replies.

                        • 9. Re: Trouble with IBM x3650 M2 and ESX 4.0.0 Build 164009
                          kp238 Novice

                           

                          With UEFI Firmware 1.00 boot ESX 4.0.0 Build 164009 without IRQ 11 failure messages.

                           

                           

                           

                           

                           

                          This UEFI Firmware 1.00 is in UpdateXpress System Pack for Microsoft Windows v1.01 included.

                           

                           

                           

                           

                           

                          Attention: 2 of my 8 servers with downgraded UEFI Firmware 1.00 an IMM Firmware 1.03 irreparably and IBM has replaced the motherboards.

                           

                           

                          • 10. Re: Trouble with IBM x3650 M2 and ESX 4.0.0 Build 164009
                            renpen Novice

                             

                            I had the same issue with my 3650M2. Downgraged UEFI one version to ver 1.00 and issue went away.

                             

                             

                             

                             

                             

                            KP238, which Raid controller do you have in your system - BR10i or MR10i?

                             

                             

                            Have you been able to install ESX 3.5 on your system. I cannot - just hangs on initializing scheduler screen

                             

                             

                             

                             

                             

                            • 11. Re: Trouble with IBM x3650 M2 and ESX 4.0.0 Build 164009
                              NM777 Lurker

                               

                              I have the same error but with different vector 209. The server is IBM blade HS22 and when i updated the bios  to the latest uEFI/BIOS, the error appears in the ESX 4 console.

                               

                               

                               

                               

                               

                              0:00:00:02.582 cpu0:4096)CosCommon: 2103: Couldn't setup IRQ 11 with vector 209

                               

                               

                              0:00:00:02.582 cpu0:4096)CosCommon: 2103: Couldn't setup IRQ 11 with vector 209

                               

                               

                               

                               

                               

                              output of interrupts:

                               

                               

                               

                               

                               

                              # cat /proc/vmware/interrupts | grep 'irq *11'

                              0x79:           0          0          0          0          0          0          0          0          0          0          0          0          0          0          0          0 <COS irq 11 (PCI level)>

                              0x81:           0          0          0          0          0          0          0          0          0          0          0          0          0          0          0          0 <COS irq 11 (PCI level)>

                              0x89:           0          0          0          0          0          0          0          0          0          0          0          0          0          0          0          0 <COS irq 11 (PCI level)>

                              0x91:           0          0          0          0          0          0          0          0          0          0          0          0          0          0          0          0 <COS irq 11 (PCI level)>

                              0x99:           0          0          0          0          0          0          0          0          0          0          0          0          0          0          0          0 <COS irq 11 (PCI level)>

                              0xa1:          97          0          0          0          0          0          0          0          0          0          0          0          0          0          0          0 <COS irq 11 (PCI level)>, VMK qla2xxx

                              0xa9:         327          0        651          0          0       1673          0          0          0          0          0          0          0          0          0       1777 <COS irq 11 (PCI level)>, VMK uhci_hcd:usb5, VMK ehci_hcd:usb1

                               

                               

                               

                              thanks

                               

                               

                              • 12. Re: Trouble with IBM x3650 M2 and ESX 4.0.0 Build 164009
                                MCJJJJ Lurker

                                Just thought I'd share that I decided to go to ESXi rather than use ESX and I haven't had these problems. Why switch? Well, VMware recommends ESXi over the older ESX platform. Check out their blog article for more info. I know some might not agree (no console and I'm sure many other reasons), but we decided we'd rather align ourselves with VMware's future goals. Not sure if this will really help anyone, but I figured it might be good info to post here.

                                • 13. Re: Trouble with IBM x3650 M2 and ESX 4.0.0 Build 164009
                                  trurodh Enthusiast

                                   

                                  Has anyone ever heard anything more on this issue?  I have the same issue and I have disabled a few things and the errors still show up.  The server seems to work fine but can't imagine that being a good thing anyway.  It is definetly something to do with the 1.01 UEFI compared to the 1.0.  I will have to open a ticket with both IBM and VMware I suppose.  If anyone in this thread has heard back from either let me know.  I will do the same.

                                   

                                   

                                   

                                   

                                   

                                  Thanks.

                                   

                                   

                                   

                                   

                                   

                                  Rod

                                   

                                   

                                  • 14. Re: Trouble with IBM x3650 M2 and ESX 4.0.0 Build 164009
                                    JRArseneau Novice

                                     

                                    I know this isn't a real solution, but seeing as ESX will be phased out within the next year or so (and based on my conversations with a few VMware engineers), I've migrated my servers to ESXi from ESX. No irq errors are appearing after having moved to ESXi and (in my environment anyway) I haven't lost any functionality going to ESXi.

                                     

                                     

                                     

                                     

                                     

                                     

                                     

                                     

                                    1 2 3 4 Previous Next