13 Replies Latest reply on Jun 11, 2009 2:03 AM by GarethWilson

    VDR: Correct time configuration

    a.p. Guru
    vExpertUser ModeratorsCommunity Warriors

       

      Located in Germany, I installed a vSphere environment (all GA versions) with the appropriate time config.

      Hosts, Virtual Center and the Data Recovery VM are set to Europe/Berlin (GMT +2:00).

       

       

      After connecting to the appliance in vCenter, it shows a 4 hour difference in the time configuration tab. E.g. at Noon it says 4PM and displays a warning about more than 5 minutes difference between the vShpere-Client and the Recovery appliance!?

      Backup runs ok, however the logs have the wrong time stamp.

       

       

      Is there anything I missed in the configuration or is this just a bug?

       

       

      Thanks

      André

       

       

        • 1. Re: VDR: Correct time configuration
          Krede Enthusiast
          vExpert

          I have the same problem. Im located in Denmark.

          • 2. Re: VDR: Correct time configuration
            pharmer Enthusiast

            We have the exact same problem with the New Zealand timezone.

             

            Our VC4 server, ESX hosts, SQL database, Active directory controllers and vSphere client as well as the VDR appliance all have correct time and regional settings

             

             

             

            The VDR plugin however continues to report a major discrepancy (5 hours 47 minutes out) even though the VDR plugin says it is in the right timezone

             

             

             

            I have tried different client platforms, re-import of the VDR appliance, new VC server etc - all with same result

             

             

             

            Add this to the already reported logon problems to the VDR appliance and strange snapshot failures (even though manual snapshots work) - means VDR cannot be considered even for small production backup

             

             

             

            Just my 2c

            • 3. Re: VDR: Correct time configuration
              Roelofz Novice

               

              Same here, just started the appliance, real time is 9:19 AM, Appliance time is 1:19 PM, 4 hours difference.

               

               

              Located in the netherlands, GMT02:00

               

               

              Regards,

               

              Roelof

               

               

              • 4. Re: VDR: Correct time configuration
                5ynack Novice

                 

                Shutdown vm, then change settings to enable "Synchronize guest time with host" under VMware Tools options.

                 

                 

                No more time warning for me  

                 

                 

                 

                 

                 

                 

                 

                 

                • 5. Re: VDR: Correct time configuration
                  Krede Enthusiast
                  vExpert

                   

                  On which machine - the VDR appliance? - I tried that, that didnt help me.

                   

                   

                  • 6. Re: VDR: Correct time configuration
                    GarethWilson Enthusiast

                    i have the same problem (GMT) if i look on the vdr console and type "date" it reports the correct time yet the VDR secrtion of VC says a completely different time

                    • 7. Re: VDR: Correct time configuration
                      pharmer Enthusiast

                       

                      Setting "Synchronize guest time with host" on the VDR appliance does not help in my case

                       

                       

                      From the commandline, the VDR appliance already reports correct timezone and clock

                       

                       

                      The plugin still reports 5 hours+ discrepancy

                       

                       

                      • 8. Re: VDR: Correct time configuration
                        Mirko Huth Enthusiast

                         

                        Had the same issue. I resolved it on my mschine by doing the following on the vdr macine:

                         

                         

                        1. Check "System clock uses UTC"

                         

                         

                        2. Choose one of the etc/GMT (e.g. gmt+1 for germany) entrys instead of the country/city entrys.

                         

                         

                        3. Reboot the vm

                         

                         

                         

                         

                         

                        1 person found this helpful
                        • 9. Re: VDR: Correct time configuration
                          a.p. Guru
                          Community WarriorsUser ModeratorsvExpert

                          Mirko,

                           

                          thanks for the hint. I am at least able to reproduce the issue.

                           

                          To get a correct time in the plug-in I need to do the following:

                          1. Set timezone to etc/GMT+1 and check "System clock uses UTC"

                          2. Reboot the appliance

                          3. Set timezone back to "Europe/Berlin" and uncheck "System clock uses UTC"

                          4. Set the correct date and time in the appliance using the date command.

                           

                          Well, this is a workaround only. It seems there is a little bug somewhere which has to be fixed.

                           

                           

                          André

                          • 10. Re: VDR: Correct time configuration
                            mcwill Expert

                            We had a similar problem and solved it by enabling ntp within the VDR app, it's stopped by default.

                             

                            If you check you will find that /etc/ntp.conf is already setup to use the centos.pool.ntp.org hosts, you can leave this as is but I changed ours to 0-2.uk.pool.ntp.org

                             

                            Start ntpd...

                             

                            /etc/init.d/ntpd start

                             

                            Set ntpd to run automatically at boot...

                             

                            chkconfig --level 345 ntpd

                             

                             

                            You can check that ntp is running correctly by...

                             

                            ntpq -p

                             

                            Hope this helps,

                            Iain

                            • 11. Re: VDR: Correct time configuration
                              kot99 Novice

                              This is strange, but none of solutions above helped me

                               

                              Plugin reports 5 hours+ discrepancy...any other solutions ???

                              • 12. Re: VDR: Correct time configuration
                                GarethWilson Enthusiast

                                a.p. posted the solution below and this worked fine for me

                                 

                                To get a correct time in the plug-in I need to do the following:

                                1. Set timezone to etc/GMT+1 and check "System clock uses UTC"

                                2. Reboot the appliance

                                3. Set timezone back to "Europe/Berlin" and uncheck "System clock uses UTC"

                                4. Set the correct date and time in the appliance using the date command

                                 

                                 

                                e.g. login to the VDR appliciance command line - set the current time and date to June 10th 2009, 11:16pm, type date 100623162009 where 10 is the 10th june, 06 is the month june, 2316 is 11:16pm and 2009 is the year

                                • 13. Re: VDR: Correct time configuration
                                  kot99 Novice

                                   

                                  everything is fine now !!!

                                   

                                   

                                  ntp just need some time to sync...

                                   

                                   

                                  thanks.