2 Replies Latest reply: Jun 2, 2009 4:27 AM by Erik Bussink RSS

    Upgrade Data Recovery Appliance ?

    briandatamatters Novice


      For fun I did a yum upgrade of my test Data Recovery Appliance. Given that this is a Centos 5.2 I thought I'd see what happened when it was upgraded.






      Turns out not so good....






      sfcb cannot start as it looks like it needs the centos 5.2  openssl libs 0.9.8






      Are we meant to update this appliance ? We will need this thing to be kept patched etc to maintain our PCI DSS compliant network.












        • 1. Re: Upgrade Data Recovery Appliance ?
          depping Champion VMware Employees User Moderators

          I haven't seen an upgrade/update policy yet but normally VMware will provide the necessary updates to make sure they are compliant with our software and will not break it.




          VMware Communities User Moderator | VCP | VCDX


          Blogging: http://www.yellow-bricks.com

          Twitter: http://www.twitter.com/depping


          If you find this information useful, please award points for "correct" or "helpful".

          • 2. Re: Upgrade Data Recovery Appliance ?
            Erik Bussink Expert vExpert

            I've taken the liberty to patch the Operating System of the Data Recovery appliance from CentOS 5.2 to the latest 5.3 with Kernel 2.6.18-128.1.10 using simply the yum update command. I uninstalled the vmware-tools rpm, added the new one.


            I then had to create two links for libssl and libcrypto as thelibraries have been updated, and the vmware-config-tools.pl could not run, without those libraries.


            cd /lib




            ln -s libssl.so.0.9.8e libssl.so.0.9.8




            ln -s libcrypto.so.0.9.8e libcrypto.so.0.9.8




            My VMware-tools are now up-to-date.











            But, this now means I have a DataRecovery appliance that is not the same as what VMware supplies, and I know that I would not be able toopen a SR ticket if I had any issues. It's something I'm willing toaccept for making sure my appliance is secure and has up-to-date VMwaretools.