1 2 Previous Next 23 Replies Latest reply on May 31, 2020 11:47 AM by UserOfVirtualMachines

    keyboard problem - key gets stuck (autorepeat) in guest

    pj1001 Novice

      Here is my config:

      vmware workstation 6.5.2

      host ubuntu 9.04 (Jaunty Jackalope)

      guest XP (from physical partition)

       

      I noticed on occasions keys in guest were stuck. I type something in terminal and the key goes autorepeat.

      To stop it: switch to host, open terminal (the key will be still pressed and autorepeating itself) and press something.

      The autorepeat still accepts modifiers (I can press Shift and get G out of repeating g).

      It looks like the key release event is lost.

       

      I have found reliable way to reproduce. When focus is in host, press Ctrl-G, the stuck key will be "g".

      If I select the VM->Grab Input it does not happen.

       

      Since my ubuntu and vmware have a "history" i have nucked the ~/.vmware /etc/vmare and reinstalled workstation

      The original ~/.vmware/config had the workaround for the Ctrl-Alt-Shift problem, but not anymore.

      I also tried to put xkeymap.noKeycodeMap = "TRUE" in the config, but it did not change anything.

      I used to remap "Caps Lock" to "Ctrl" but took it out and rebooted since.

       

      The following comes up in vmware.log when it happens:

      Apr 26 20:14:25.173: mks| MKS could not find key event for 0x25 up

      Apr 26 20:14:25.179: mks| MKS set modifier mapping failed: MappingBusy, giving up

      Apr 26 20:14:25.179: mks| MKS could not find key event for 0x25 down

      Apr 26 20:14:28.654: mks| MKS lost grab

      Apr 26 20:14:28.670: mks| MKS set modifier mapping failed: MappingBusy, giving up

      Apr 26 20:14:28.692: mks| MKS set modifier mapping failed: MappingBusy, giving up

       

      0x25 is left control. The left control works in guest and host.

       

      I am slowly running out of options, any suggestions are welcome.

       

      --Pawel

        • 1. Re: keyboard problem - key gets stuck (autorepeat) in guest
          Novice

           

          I am running pretty much the same config, with 64Bit Jaunty.

           

           

           

           

           

          Not a permanent fix, but it works for me.....

           

          1. Open Workstation, but do not start your VM yet.

          2. Press <CTRL>P to openup preferences.

          3. Go to the "Input" Tab.

          4. Ensure that "Grab keyboard and mouse input on mouse click" is selected, and that "Grab keyboard and mouse input on key press" is cleared/deselected (explanation below).

          5. Ensure that "Grab when cursor enters window", Ungrab when cursor leaves window" & "Hide cursor on ungrab" are selected and that "Never optimize mouse for games(...)" is cleared/deselected. (Not sure how hard & fast these are just what I have &  "It Works©".

          6. Close Preferences.

          7. Minimize Workstation for now.

          8. On one of your Panels, right click and choose "Add toPanel".

          9. Choose "Custom Application Launcher".

          10. Name it something like "Keyboard Fix".

          11. In the command field enter "setxkbmap" (no quotes).

          12. Optionally, give it a relevant icon, I used /usr/share/icons/gnome/scalable/apps/preferences-desktop-keyboard.svg.

          13. Place the Launcher wherever you want it on your panel.

          14. Bring Workstation back up and start your VM.

          15. When it comes up, click in the Window.  Everything works fine, right? You should be able to mouse in and out of the VM, type, etc. with no problems.....

          16. Now<CTRL<>ALT> out of the VM.

          17. If you mouse click back in to the VM, everythingshould still work fine.  It does for me anyhow.

          18. If you <CTRL>G back in, then the fun begins...

          19. At this point, mouse out of the VM and press the <ESC> key.  this should stop the keyboard stickiness, but you will also find that it breaks the keyboard for the host OS.  it should still be working in the VM.

          20. Now we come to that launcher you created.  Go ahead & click it now.  This should fix the keyboard for the host OS.

          21. You should now be able to resume "normal" operation.

           

          The reason for disabling grab input on key press is that whatever key you press will end up being the stuck key.  My habit was to use the left or right arrow key, which caused significant dificulty in getting the mouse out of the VM long enough to press the <ESC> key.

           

           

          The key thing here is that for now the only way you should re-grab input for the VM is via Mouse Click.  Any other method sends the keyboard down the rabbit hole again.

           

           

          Yes it's duct-tape, but it gets the job done for now.....

           

           

          • 2. Re: keyboard problem - key gets stuck (autorepeat) in guest
            pj1001 Novice

            short update.

             

            I have confirmed the problem follows host, exactly the same problem can be triggered with linux as guest.

            It is not my laptop specific, it can be reproduced on different workstation.

            I have try to get official support from vmware, but as you can suspect they are trying to reproduce the problem on last supported ubuntu version (8.04)

             

            --pawel

            • 3. Re: keyboard problem - key gets stuck (autorepeat) in guest
              tonz Lurker

               

              I experienced the same problem with from workstation 6.5.0 to the last version in hosts running ubuntu 8.04 , 8.10 e 9.04 , in xp vmachines.

               

               

              For me is a constant but rare event, and I only escape the situation with this workaround: I open in the linux host a text editor, and when this has the focus I press some random keys and the the phenomen come to an end.

               

               

              This is not a solution, but i want to report me too the problem.

               

               

              Greetings.

               

               

               

               

               

              • 4. Re: keyboard problem - key gets stuck (autorepeat) in guest
                muff10n Lurker

                I have the same problem. Quite annoying!

                 

                I've tested some of the proposed solutions I've found (keymap) but it does not help.

                On grab (CTRL+G or grab on key press) key up is lost and I get the same key-repeat-problem as well.

                 

                 

                 

                Host: OpenSUSE 11.1

                VM: XP Pro SP3

                 

                 

                 

                I've learned not to press CTRL-G (that was hard, keyboard shortcuts is way better than using the mouse all the time) but

                sometimes I forget and press CTRL-G out of old habit... sigh

                 

                 

                 

                Hope this bug will be patched real soon, my patience is wearing thin...

                 

                 

                 

                 

                 

                 

                //Henrik

                 

                 

                Forgot to post kernel version (2.6.27.21-0.1-pae) and  Workstation version (6.5.2 build-156735).

                 

                 

                But if I recall correctly I had the problem with 6.5.0 as wellggggggggggGGGGGGggggGGGggggggggggggggggggg (sorry, couldn't help myself...)

                • 5. Re: keyboard problem - key gets stuck (autorepeat) in guest
                  oznet Enthusiast

                  Same problem here.  This problem appeared with my upgrade to Ubuntu Jaunty 9.04 on the host so I suspect something is different there.

                   

                  This is the worst I have seen it in a long time.  Often the repeating carries over to the host and I can't get the keyboard back.  Even unplugging/resetting the keyboard (USB keyboard) doesn't fix it.

                   

                  On a side note, I really hate these keyboard issues.  It seems to reappear every once in a while and after years of dealing with it I'm getting really annoyed.  Why is it so hard to fix permanently?  I mean the keyboard one of the most basic things on the machine.  Obviously there is some sort of complicated issues involved but man is it annoying.   I have even lost data because of it when the keyboard starts repeating, running commands, causing the GUI to select things, and such.  So very frustrating.

                  • 6. Re: keyboard problem - key gets stuck (autorepeat) in guest
                    pj1001 Novice

                    For the reference, my support request number for this issue is: 1204529071

                    I made a link from the support request to this thread.

                     

                    Some time ago I decided to use VMWare instead of other poducts because we believe situation like this are not likely to happen and if it happens we will get support.

                    I guess it is time to revisit the decision and take a look at alternatives.

                     

                    --pawel

                    • 7. Re: keyboard problem - key gets stuck (autorepeat) in guest
                      muff10n Lurker

                       

                      Is it somehow possible for us to add some extra weight to your support request?

                      We're all paying customers after all...

                       

                       

                      And I agree, it feels like there is a lack of focus on Workstation on Linux. I've given some thought about leaving

                      Workstation and go for some other solution (virtualbox, KVM, whatever). But we're running ESX as well which has

                      kept me from leaving. So far. The benefit of using the same hypervisor on desktop and cluster is not worth having

                      ggGgggggGGGGggG ruining my day...

                       

                       

                      Our ESX3.5-based cluster is running just fine, but I've had tons of problems with Workstation on Linux.

                      All solved one way or the other, except for this annoying keyrepeat.

                       

                       

                      Now, the strangest thing is that my co-worker have the same setup as I have, except for the hardware.

                      I have a HP dc7700p and his HP is a dc7900. Could this be hardware-related?

                       

                       

                       

                       

                       

                      //Henrik

                       

                       

                      • 8. Re: keyboard problem - key gets stuck (autorepeat) in guest
                        pj1001 Novice

                        Is it somehow possible for us to add some extra weight to your support request?

                        We're all paying customers after all...

                        I guess the sales channel is the best bet. Make sure to mention the service request number

                         

                        Could this be hardware-related?

                        I have confirmed it on Thinkpad X60s and X61s.

                         

                         

                        except for this annoying keyrepeat.

                        Is VMware server an option? The performance is in the "ok" zone. However you are loosing all the workstation stuff. Multiple snapshots and shared folders are what holds me back.

                         

                        --pawel

                        • 9. Re: keyboard problem - key gets stuck (autorepeat) in guest
                          zip000 Lurker

                           

                          I'm getting the same problem in VMware server 2 in 64bit Ubuntu 9.04.

                           

                           

                           

                           

                           

                          When I was installing XP in the VM, I was getting autorepeated letter "g." Also, and it may be related, when I was in the early parts of the install - pre mouse availability in the VM - I couldn't get out of the VM, i.e. the Crtl-Alt was not working. I think this was due to the "g" getting in the way.

                           

                           

                           

                           

                           

                          When I got the mouse back, I clicked in a search field in my browser outside the VM and had an auto "g" there too. When I typed something else, it stopped Then I could work inside the vm again.

                           

                           

                           

                           

                           

                          This caused me to have the computer name "ggggggggggggggg" in the XP vm...which obviously isn't ideal.

                           

                           

                          • 10. Re: keyboard problem - key gets stuck (autorepeat) in guest
                            pj1001 Novice

                            Out of curiosity I checked out the vmware server 2.0.1 and  .... the gggggggggggggggggggggggggggggggggggggg were there

                            I have seen workstation with similar config and no g problem. I will give it a closer look.

                            --pawel

                            • 11. Re: keyboard problem - key gets stuck (autorepeat) in guest
                              pj1001 Novice

                              my request to fix it via official channel got rejected. Reason: can not reproduce on ubuntu 8.04 (8.10)

                              I guess no fix until next release of workstation.

                               

                              It would help If somebody with good account (support, etc) communicate it via marketing channel.

                              Message: "We need support for 9.04, there is a bug in vmware workstation".

                               

                              --pawel

                              • 12. Re: keyboard problem - key gets stuck (autorepeat) in guest
                                Master

                                Thanks to you all for reporting this. Ah, the perils of running on distros newer than our software release.

                                 

                                VMware engineering is aware of this bug and we have confirmed the behavior on Ubuntu 9.04. Note that it's our policy to not give dates or make promises for unannounced future versions of our software, so I can't tell you when this will be fixed.

                                 

                                In the meantime, when running WS 6.5.2 on Ubuntu 9.04, I would recommend the workaround you've already suggested in this thread

                                - turn off grab-on-keypress if you use that

                                - don't press ctrl-g to grab

                                - always grab by clicking the VM console with the mouse

                                • 14. Re: keyboard problem - key gets stuck (autorepeat) in guest
                                  tenstrum Lurker

                                  I just  "upgraded" to Ubuntu 9.04 and I have the same problem with VMWare Server 2.  I'm logging into VMware Infrastructure Web Access and do not see anywhere that I can go and edit the preferences so that I can get around this.

                                   

                                  Any ideas?  This is very frustrating!

                                   

                                   

                                   

                                   

                                   

                                  I cannot log into my WinXP virtual machine at all.  Anytime I hit CTRLALTDEL I get the Log In Help message on the Virtuall XP machine telling me to press  CTRLALTDEL....

                                  1 2 Previous Next