1 2 Previous Next 29 Replies Latest reply on Sep 14, 2009 5:16 PM by obspsr

    vmware server 1 and kernel 2.6.29.

    abieleck Lurker

       

      Hi.

       

       

      Have anybody know of the patch to vmware server 1.0.9 to have it successfuly compiled on kernel 2.6.29. I have just recently upgraded from kernel 2.6.27 and vmware server modules stop compiling.

       

      Extracting the sources of the vmmon module.

       

      Building the vmmon module.

       

      Using 2.6.x kernel build system.

      make: Entering directory `/root/tmp/vmware-config2/vmmon-only'

      make -C /lib/modules/2.6.29.1-desktop-3mnb/build/include/.. SUBDIRS=$PWD SRCROOT=$PWD/. modules

      make[1]: Entering directory `/usr/src/linux-2.6.29.1-desktop-3mnb'

        CC   /root/tmp/vmware-config2/vmmon-only/linux/driver.o

      In file included from /root/tmp/vmware-config2/vmmon-only/./include/x86.h:20,

                       from /root/tmp/vmware-config2/vmmon-only/./include/machine.h:24,

                       from /root/tmp/vmware-config2/vmmon-only/linux/driver.h:15,

                       from /root/tmp/vmware-config2/vmmon-only/linux/driver.c:49:

      /root/tmp/vmware-config2/vmmon-only/./include/x86apic.h:79:1: warning: "APIC_BASE_MSR" redefined

      In file included from /usr/src/linux-2.6.29.1-desktop-3mnb/arch/x86/include/asm/fixmap_32.h:29,

                       from /usr/src/linux-2.6.29.1-desktop-3mnb/arch/x86/include/asm/fixmap.h:5,

                       from /usr/src/linux-2.6.29.1-desktop-3mnb/arch/x86/include/asm/apic.h:8,

                       from /usr/src/linux-2.6.29.1-desktop-3mnb/arch/x86/include/asm/smp.h:13,

                       from include/linux/smp.h:36,

                       from include/linux/topology.h:33,

                       from include/linux/mmzone.h:767,

                       from include/linux/gfp.h:4,

                       from include/linux/kmod.h:22,

                       from include/linux/module.h:13,

                       from /root/tmp/vmware-config2/vmmon-only/linux/driver.c:12:

      /usr/src/linux-2.6.29.1-desktop-3mnb/arch/x86/include/asm/apicdef.h:132:1: warning: this is the location of the previous definition

      In file included from /root/tmp/vmware-config2/vmmon-only/./include/machine.h:24,

                       from /root/tmp/vmware-config2/vmmon-only/linux/driver.h:15,

                       from /root/tmp/vmware-config2/vmmon-only/linux/driver.c:49:

      /root/tmp/vmware-config2/vmmon-only/./include/x86.h:830:1: warning: "PTE_PFN_MASK" redefined

      In file included from /usr/src/linux-2.6.29.1-desktop-3mnb/arch/x86/include/asm/paravirt.h:7,

                       from /usr/src/linux-2.6.29.1-desktop-3mnb/arch/x86/include/asm/irqflags.h:55,

                       from include/linux/irqflags.h:57,

                       from /usr/src/linux-2.6.29.1-desktop-3mnb/arch/x86/include/asm/system.h:11,

                       from /usr/src/linux-2.6.29.1-desktop-3mnb/arch/x86/include/asm/processor.h:17,

                       from include/linux/prefetch.h:14,

                       from include/linux/list.h:6,

                       from include/linux/module.h:9,

                       from /root/tmp/vmware-config2/vmmon-only/linux/driver.c:12:

      /usr/src/linux-2.6.29.1-desktop-3mnb/arch/x86/include/asm/page.h:22:1: warning: this is the location of the previous definition

      In file included from /root/tmp/vmware-config2/vmmon-only/linux/driver.h:20,

                       from /root/tmp/vmware-config2/vmmon-only/linux/driver.c:49:

      /root/tmp/vmware-config2/vmmon-only/./include/compat_wait.h:37:5: warning: "VMW_HAVE_EPOLL" is not defined

      /root/tmp/vmware-config2/vmmon-only/./include/compat_wait.h:43:5: warning: "VMW_HAVE_EPOLL" is not defined

      In file included from /root/tmp/vmware-config2/vmmon-only/linux/driver.h:20,

                       from /root/tmp/vmware-config2/vmmon-only/linux/driver.c:49:

      /root/tmp/vmware-config2/vmmon-only/./include/compat_wait.h:60: error: conflicting types for ‘poll_initwait’

      include/linux/poll.h:67: error: previous declaration of ‘poll_initwait’ was here

      In file included from /root/tmp/vmware-config2/vmmon-only/linux/vmhost.h:13,

                       from /root/tmp/vmware-config2/vmmon-only/linux/driver.c:71:

      /root/tmp/vmware-config2/vmmon-only/./include/compat_semaphore.h:5:27: error: asm/semaphore.h: No such file or directory

      /root/tmp/vmware-config2/vmmon-only/linux/driver.c:146: error: unknown field ‘nopage’ specified in initializer

      /root/tmp/vmware-config2/vmmon-only/linux/driver.c:147: warning: initialization from incompatible pointer type

      /root/tmp/vmware-config2/vmmon-only/linux/driver.c:150: error: unknown field ‘nopage’ specified in initializer

      /root/tmp/vmware-config2/vmmon-only/linux/driver.c:151: warning: initialization from incompatible pointer type

      /root/tmp/vmware-config2/vmmon-only/linux/driver.c: In function ‘LinuxDriver_Ioctl’:

      /root/tmp/vmware-config2/vmmon-only/linux/driver.c:1650: error: ‘struct task_struct’ has no member named ‘euid’

      /root/tmp/vmware-config2/vmmon-only/linux/driver.c:1650: error: ‘struct task_struct’ has no member named ‘uid’

      /root/tmp/vmware-config2/vmmon-only/linux/driver.c:1651: error: ‘struct task_struct’ has no member named ‘fsuid’

      /root/tmp/vmware-config2/vmmon-only/linux/driver.c:1651: error: ‘struct task_struct’ has no member named ‘uid’

      /root/tmp/vmware-config2/vmmon-only/linux/driver.c:1652: error: ‘struct task_struct’ has no member named ‘egid’

      /root/tmp/vmware-config2/vmmon-only/linux/driver.c:1652: error: ‘struct task_struct’ has no member named ‘gid’

      /root/tmp/vmware-config2/vmmon-only/linux/driver.c:1653: error: ‘struct task_struct’ has no member named ‘fsgid’

      /root/tmp/vmware-config2/vmmon-only/linux/driver.c:1653: error: ‘struct task_struct’ has no member named ‘gid’

      /root/tmp/vmware-config2/vmmon-only/linux/driver.c:1670: error: too many arguments to function ‘smp_call_function’

      make[2]: *** /root/tmp/vmware-config2/vmmon-only/linux/driver.o Error 1

      make[1]: *** Error 2

      make[1]: Leaving directory `/usr/src/linux-2.6.29.1-desktop-3mnb'

      make: *** http://vmmon.ko Error 2

      make: Leaving directory `/root/tmp/vmware-config2/vmmon-only'

      Unable to build the vmmon module.

       

      For more information on how to troubleshoot module-related problems, please

      visit our Web site at "http://www.vmware.com/download/modules/modules.html" and

      "http://www.vmware.com/support/reference/linux/prebuilt_modules_linux.html".

       

      Execution aborted.

        • 1. Re: vmware server 1 and kernel 2.6.29.
          chguernsey Enthusiast

          I've been working on it, not done yet.  I have vmnet compiling cleanly (patch and patched-tar attached), running in to issues with vmmon.

          • 2. Re: vmware server 1 and kernel 2.6.29.
            jprobichaud Lurker

             

            Hi,

             

             

            I fall in the "me too" group for this issue and I was wondering if there was any patch/fix/workaround for this issue.  I stuck in a position where I need the 2.6.29 kernel (intel GEM issues) and vmware is a quite important tooll for my day-to-day work.

             

             

             

             

             

            Thanks,

             

             

             

             

             

            Jp

             

             

            • 3. Re: vmware server 1 and kernel 2.6.29.
              rfelsburg Lurker

               

              You can try the patch from IT Psycho located here: http://www.it-psycho.de/please-do-not-deeplink-file/vmware-server-modules-2.6.29.it-psycho.tar.bz2

               

               

              Essentially the process is as such, install the 1.0.9 RPM, then untar the patch, and ./runme.pl

               

               

               

               

               

              I hacked it around so I could install the tarred source instead of the 1.0.9 RPM by replacing the vmmon.tar/vmnet.tar files in the 1.0.9 tarred source code with the ones in the patch.  IE.

               

               

               

               

               

              mv $PATCH_1.0.9/vmmon.tar $SOURCE_1.0.9/lib/modules/source/

               

               

              mv $PATCH_1.0.9/vmnet.tar $SOURCE_1.0.9/lib/modules/source/

               

               

               

               

               

              There is also another patch you can try using the same process located at http://www.insecure.ws/warehouse/vmware-update-2.6.27-5.5.7-2.tar.gz

               

               

               

               

               

              Good luck.

               

               

               

               

               

              -Rob

               

               

               

               

               

              • 4. Re: vmware server 1 and kernel 2.6.29.
                obspsr Novice

                 

                Hi chguernsey !

                 

                 

                Do you know if somebody else as worked on  this problem of GCC and Mandriva-2009.1 kernel-2.6.29xx.

                 

                 

                I get the same problem and I'm stuck with vmmon compilation ... (on your VMWare Workstation section of this site, they

                 

                 

                have solved the problem) ... no known patches are working for the moment for Server. 

                 

                 

                May be Vmware Server 1.0.9 problem is very close ?

                 

                 

                Best regards,

                 

                 

                Serge.

                 

                 

                • 5. Re: vmware server 1 and kernel 2.6.29.
                  jprobichaud Lurker

                  Thanks Rob for your pointer, unfortunately, it doesn't work for me.  I'm using a 64bits SMP kernel, maybe that's why? 

                   

                   

                  Trying to compile your patches gives:

                   

                   

                  root@localhost%  make

                   

                   

                  Using 2.6.x kernel build system.        

                  make -C /lib/modules/2.6.29-tuxonice-take-9-vmware/build/include/.. SUBDIRS=$PWD SRCROOT=$PWD/. modules

                  make[1]: Entering directory `/usr/src/linux-2.6.29-tuxonice'                                          

                  CC   /tmp/vmware-server-distrib/lib/modules/source/vmmon-only/linux/driver.o                     

                  In file included from /tmp/vmware-server-distrib/lib/modules/source/vmmon-only/./include/machine.h:24,

                  from /tmp/vmware-server-distrib/lib/modules/source/vmmon-only/linux/driver.h:15,     

                  from /tmp/vmware-server-distrib/lib/modules/source/vmmon-only/linux/driver.c:49:     

                  /tmp/vmware-server-distrib/lib/modules/source/vmmon-only/./include/x86.h:830:1: warning: "PTE_PFN_MASK" redefined

                  In file included from /usr/src/linux-2.6.29-tuxonice/arch/x86/include/asm/pda.h:8,                              

                  from /usr/src/linux-2.6.29-tuxonice/arch/x86/include/asm/current.h:19,                         

                  from /usr/src/linux-2.6.29-tuxonice/arch/x86/include/asm/processor.h:15,                       

                  from include/linux/prefetch.h:14,                                                              

                  from include/linux/list.h:6,                                                                   

                  from include/linux/module.h:9,                                                                 

                  from /tmp/vmware-server-distrib/lib/modules/source/vmmon-only/linux/driver.c:12:               

                  /usr/src/linux-2.6.29-tuxonice/arch/x86/include/asm/page.h:22:1: warning: this is the location of the previous definition

                  In file included from /tmp/vmware-server-distrib/lib/modules/source/vmmon-only/linux/driver.h:20,                       

                  from /tmp/vmware-server-distrib/lib/modules/source/vmmon-only/linux/driver.c:49:                       

                  /tmp/vmware-server-distrib/lib/modules/source/vmmon-only/./include/compat_wait.h:11:1: warning: "VMW_HAVE_EPOLL" redefined

                  <command-line>: warning: this is the location of the previous definition                                                 

                  /tmp/vmware-server-distrib/lib/modules/source/vmmon-only/linux/driver.c: In function ‘LinuxDriver_Ioctl’:                

                  /tmp/vmware-server-distrib/lib/modules/source/vmmon-only/linux/driver.c:1736: error: too many arguments to function ‘smp_call_function’

                  make[3]: *** /tmp/vmware-server-distrib/lib/modules/source/vmmon-only/linux/driver.o Error 1                                        

                  make[2]: *** Error 2         

                   

                   

                  Any other clue?  The other process didn't help either (everything 'looks' ok, but I'm unable to start the vmware machine)

                   

                  I'm starting to loose hope...

                   

                  Jp

                  • 6. Re: vmware server 1 and kernel 2.6.29.
                    obspsr Novice

                     

                    I have the same problem with Mandriva-2009.1 (gcc and kernel-2.6.29xx)

                     

                     

                    Even if  I apply the different patches ... the vmware-config.pl is happy ... But

                     

                     

                    you end with "unamble to use this VM due to different version 138 iso 208 vmmon.o module ....

                     

                     

                    I tried to change the version in modules/include .... it  crashes completely.

                     

                     

                    Version 2.0 is 500Mb and does not work more ...

                     

                     

                    Vmware-Workstation is not usable to work with VM's installed on other host in the lan ....

                     

                     

                    So, I think that we are wasting our time with these packages ... I'am unable to use my SolidWorks distant drawings,

                     

                     

                    for a week ... not very serious ... not enough people involved in maintenance and the only possibility is to revert

                     

                     

                    to older kernel-2.6.23 with vmware-server 1.0.7 or 1.0.9 ....        I am really lessing hope !!!

                     

                     

                    • 7. Re: vmware server 1 and kernel 2.6.29.
                      tetstuser Novice

                      Hello,

                       

                       

                       

                       

                       

                       

                       

                      I got this problem fixed a fes days ago. I am running a host lenny 5.01 kernel 2.6.29.4 and guest WinXPSP3. My VMware Server version is 1.09

                       

                       

                      These are the steps that worked for me:

                       

                       

                       

                       

                       

                       

                       

                       

                       

                      0) Downlaod this file: http://www.insecure.ws/warehouse/vmware-update-2.6.29-5.5.9-3.tar.bz2

                      1) copy the patch 2.6.29-export-init_mm.patch to your kernel sources folder

                      2) cd into your kernel sources folder. i.e: cd /usr/src/linux-2.6.29.4/

                      3) then run: sudo patch -p1 < 2.6.29-export-init_mm.patch

                      4) Recompile your kernel

                      5) then run: sudo vmware-install.pl but DO NOT RUN the config script (vmware-config.pl)

                      6) then run the fix script: sudo ./runme.pl

                      7) sudo touch /etc/vmware/ssl/rui.key

                      8) sudo touch /etc/vmware/ssl/rui.crt

                      9) sudo apt-get install ia32-libs

                      10) sudo apt-get install libc6-i386

                      11) Lastly run the config script: sudo /usr/bin/vmware-config.pl

                       

                       

                       

                       

                       

                       

                       

                       

                       

                      Hope it helps!

                      • 8. Re: [SOLVED]vmware server 1 and kernel 2.6.29.3-1 Mandriva 2009 Spring
                        obspsr Novice

                         

                        Many thanks for coop, but I just found  this fix which contains only the 4 .tar files necessary.

                         

                         

                        You untar them straight in your /usr/lib/vmware/modules/source and run vmware-config 

                         

                         

                        Easy so far, and thanks to the Author !

                         

                         

                        vmware-server-modules-2629

                         

                         

                        • 9. Re: [PARTIALLY SOLVED]vmware server 1 and kernel 2.6.29.3-1 Mandriva 2009 Spring
                          obspsr Novice

                           

                          the problem is now that vmware server compiled and launched from a machine kernel 2.6.29-3

                           

                           

                          use successfully the VM's installed on the distant machine kernel 2.6.23.

                           

                           

                          BUT it still does not work on localhost identical VM's .... with debug message :

                           

                           

                          ==============================

                           

                           

                            Unable to change virtual machine power state: The process exited with an error:

                          vmxvmdb: Index name being generated from config file

                          POST(no connection): Version mismatch with vmmon module: expecting 138.0, got 208.0.

                          You have an incorrect version of the `vmmon' kernel module.

                          Try reinstalling VMware Server.

                           

                          POST(no connection): Failed to initialize monitor device.

                           

                          Failed to initialize VM.

                          End of error message.

                           

                           

                          ==============================

                           

                           

                          • 10. Re: [PARTIALLY SOLVED]vmware server 1 and kernel 2.6.29.3-1 Mandriva 2009 Spring
                            tetstuser Novice

                             

                            Hi,

                             

                             

                             

                             

                             

                            I already tried the patch you are using now, and it is not working. It compiles another vmmon module version that is not valid with the kernel 2.6.29.

                             

                             

                            Follow the steps I posted.

                             

                             

                            Bye

                             

                             

                            • 11. Re: [PARTIALLY SOLVED]vmware server 1 and kernel 2.6.29.3-1 Mandriva 2009 Spring
                              obspsr Novice

                               

                              Hi,

                               

                               

                              The fact is that, for using such a patch, we have to look at it a bit. And the fact that we do not know who are

                               

                               

                              people working the problem due to today's new internet methods is not easing the process  .....

                               

                               

                              1)The corrections are implying such a lot of files in the kernel that we are nearly sure to kill somnething else.

                               

                               

                              2) More ... we are not using a debian distribution BUT Mandriva last one and no apt-get all but rpm and urpmi.

                               

                               

                              3) Most people are using the reduced "devel" source set for compiling 3rd sources API et modules and not the

                               

                               

                              plain kernel sources ... because we have no time to spend hours, configuring every steps of the plain kernel, say ... on Dell

                               

                               

                              powerfull laptop working perfectly with distribution kernels.

                               

                               

                              4) To follow...  the .c,  init_mm , and other files are not in these packages and needs full kernel install reconfiguration and which is not a

                               

                               

                              viable solution for normal people ( I am a +20 years Linux admin and I find it too heavy !! so ...

                               

                               

                              5) I don't understand why VMware staff is not following such problems, as admins will not follow such unstable products for production.

                               

                               

                              and it is not a problem isolated as I tried most all VMware products and they are not working on actual 2.6.29 releases.

                               

                               

                              6) End of story, the fact that VMware Server 2 is 300/500 MB footprint is not  good for the tool when it is only used to use one or two M$ API's

                               

                               

                              ...as the M$ install is faster than fixing a Version Number of vmware... I am not kidding at all ... 1.0.9 is perfectly functionnal !

                               

                               

                              Excuse me for all of these words but devellopers are unreachable today, as you know,  so, ... pass the message if you can, because VMware is interesting for us

                               

                               

                              for all processors, but we will have to move to XEN on DualCores supporting virtualization.( It is well understood that we can regress to older kernels

                               

                               

                              and compilers for a while ... :-((  )

                               

                               

                              Best regards.

                               

                               

                              Serge Montagnac.

                               

                               

                              • 12. Re: [PARTIALLY SOLVED]vmware server 1 and kernel 2.6.29.3-1 Mandriva 2009 Spring
                                obspsr Novice

                                 

                                I reply my own doubts, as I think that the problems with compilation of VMware Server 1.0.9 under

                                 

                                 

                                kernel and recent compilers 2.6.29xx (particularly under Mandriva 2009 Spring) does not interest anybody

                                 

                                 

                                at VMware ... no answers about this bloody Version number conflict ...

                                 

                                 

                                It's after a month of patience not possible to use seriously this solution ... :-((( ......Too difficult to understand

                                 

                                 

                                why such a number of different products ... for the same goal ... virtualisation.( Thousands of guys are claiming

                                 

                                 

                                bugs and problems with no answers)

                                 

                                 

                                It should be better to have ONE not free product WORKING.

                                 

                                 

                                End of story.

                                 

                                 

                                Serge.

                                 

                                 

                                • 13. vmware server 1 on kernel 2.6.29.xxxx is NOT WORKING
                                  obspsr Novice

                                   

                                  Does somebody read technical messages concerning VMware - Server ???

                                   

                                   

                                  Thanks ... Please

                                   

                                   

                                  Serge.

                                   

                                   

                                  ( text is only useful if somebody cares ! )

                                   

                                   

                                  • 14. Re: vmware server 1 on kernel 2.6.29.xxxx is NOT WORKING
                                    obspsr Novice

                                    Unable to change virtual machine power state: The process exited with an error:

                                    vmxvmdb: Index name being generated from config file

                                    POST(no connection): Version mismatch with vmmon module: expecting 138.0, got 208.0.

                                    You have an incorrect version of the `vmmon' kernel module.

                                    Try reinstalling VMware Server.

                                     

                                    POST(no connection): Failed to initialize monitor device.

                                     

                                    Failed to initialize VM.

                                    End of error message.

                                    1 2 Previous Next