2 Replies Latest reply on Mar 6, 2009 6:28 PM by ragnar222

    Game Crashes with DirectDraw Error and Multiple Resolution Changes After Previously Working

    ragnar222 Lurker

      Background Info:

      VMware Fusion Version 2.0 (116369)

      Computer: Mac Pro 8 Core 2.8GHz (OS X 10.5.6) NVIDIA GeForce 8800 GT

      Guest OS: Windows XP Pro SP3 (Bootcamp Partition)

      Relevant VM Settings:  2 CPUs, 3072 MB RAM

                           Display: 3D enabled

      VMware Tools: Version e.x.p, build-116369

       

      Behavior:

      I'm attempting to run the classic windows game "Heroes of Might and Magic II Gold" in the virtual machine in full screen mode (1920x1200).  Initially after installing the game, it ran flawlessly in full screen mode.  However, one day, immediately after launching the game and while the vm was in the middle of a set of resolution changes, the McAfee virus scan nag dialog popped up.  After dismissing the dialog, the game did not successfully launch anymore.  Now, launching the game sets in motion 10 to 20 very rapid resolution and color bit depth changes until the game ultimately crashes with a DirectDraw Error:

       

      DDERR_WRONGMODE

      File: 'F:\h2xsrc\source\wingraph.cpp'

       

      In the course of troubleshooting, I noted that the game will run fine if the vm is in windowed mode, and that the vm window is automatically resized to 800x600 resolution in this case. (Attempting to play in a 800x600 window on a 1920x1200 monitor is not very fun.)

       

      I have attempted to reinstall the game, and have reinstalled DirectX 9.0c and passed all dxdiag checks as well with no luck.  Obviously, the game works flawlessly when I boot into windows directly using bootcamp.

       

      Since this was previously working, I gather that I should only have to reinitialize things.  Should I try reinstalling VMware Tools, and does reinstalling VMware Tools require Windows to be reactivated? Are there other settings that I can fiddle with?

        • 1. Re: Game Crashes with DirectDraw Error and Multiple Resolution Changes After Previously Working
          TheLoneVM Enthusiast
          VMware Employees

          Weird, never had a problem like that before.  What happens if you start the game, so it's in 800x600 windowed mode, and then switch to fullscreen mode?   Do you have any other games that don't work now or is it just HoMM II?

           

          It sounds like the game failed when the virusscan pop up appeared, and maybe set some internal flag that Fusion doesn't like.  Probably some kind of safe mode.  Does the game have any sort of external setting/option program that can be ran (some games add an extra shortcut in the start menu).  Maybe try looking in the game directory and see if there is some sort of .cfg type file to modify or rename so it creates a new one (be sure to back up original first).  Last thing would be reinstalling the game. (save your save games!)

           

          Reinstalling tools will not trigger Windows activation, but it doesn't sound like that would make a lot of difference (won't hurt to try).

          • 2. Re: Game Crashes with DirectDraw Error and Multiple Resolution Changes After Previously Working
            ragnar222 Lurker

            It's a definitely bizarre problem.  I've been scratching my head for a while now.

             

            1. Start in 800x600 mode, then switch to full screen.

            - I hadn't tried this yet, so I was hopeful. Unfortunately, this still doesn't work.  Upon switching to full screen, the vm goes even crazier with resolution changes. It's seemingly stuck in a loop of resolution changes (easily over 50) for over 30 seconds before it crashes again with the same error.  I see flashing glimpses of the game in a centered 800x600 screen with black borders, 800x600 screen anchored in the upper left corner, correctly scaled 1600x1200 full screen (I'm briefly hopeful for 200ms at a time!), and strange artifact-y portions of my desktop in 256 colors.

             

            2. Other game behavior?

            - WOW. This might be useful.  I hadn't tried to play any other games since this behavior started.  Now, the quake 3 arena demo is NOT working correctly in full screen mode either.  This was definitely working correctly before my HoMM II problem occurred.  Running the quake3 demo with the vm in full screen mode results in an unresponsive grey screen.  Running the q3 demo in windowed mode works perfectly.  I have no idea what's going on, but this seems diagnostically useful.

             

            3. HoMM II config files?

            - I've already tried a completely clean reinstall of HoMM II with no change in behavior.  I'll look to see if there are things that I can fiddle with in the meantime, but I'm not hopeful.

             

            4. Reinstalling VMware tools?

            - Is there a recommended procedure to go about doing this?  I'm nervous about screwing things up further if I mess up the tools installation.