1 Reply Latest reply: Jan 25, 2009 1:07 PM by wintensive RSS

    Parent virtual disk has been modified since the child was created

    wintensive Enthusiast


      I recently attempted to make a new VM from another

      image I had already created.  The goal was to clone it and have it be

      an independent image.  What I did not know is that when you use the

      CREATE NEW feature in Fusions and you select the option to build one

      off of another one, you are essentially stealing the "parent copy" from

      the original one. If you make any changes to it, the original VM WILL

      NOT WORK and you get the error above.


      I thought it was making a clone!!


      Computer is MacBook.  OS 10.5.6

      Guest OS: Windows XP Pro SP2



      Fusion 2.01




      any case, I cannot start the original VM.  I am happy to rebuild it

      eventually, but what I must do is get the data off of it (My

      Documents). I have NO BACKUP.


      Is there a way to just mount or "read" the VM to copy the data from it? Then we can try to save the VM itself.



      now the VM is stuck in suspend mode. The shut down command is gray and

      I cannot select it.  So I made a complete copy of the original VM and then deleted any .vmss files and .vmem files, one for each snapshot...I did this, except that I had no .vmss files.  I also updated the vmx file.  Now the VM is at least NOT stuck in suspend mode. But I still cannot mount it with VMDK mounter.


      Goal #1 - recover My Documents and Outlook Data any way possible



        • 1. Re: Parent virtual disk has been modified since the child was created
          wintensive Enthusiast





          I found a backup copy of the VM that is damaged from 01/06/2009, so I at least have a copy from there. It runs fine, but the data is of course from 1/6/09



          So the new question is can I restore the damaged CURRENT vm with the needed files from the working copy from 1/6. 



          I tried moving the base .vmdk file(the one that was modified when I tried to "clone")  back to the original damaged VM and now it starts fine.  BUT - it has reverted to the most recent snapshot which is 11/4/2008, so that turns up actually OLDER than the copy from 1/6/09.



          Can I somehow rebuild the damaged VM with the files from the copy on 1/6/2009 and have it start up into the most recent state, not te most recent snapshot?