5 Replies Latest reply on Mar 26, 2009 1:32 PM by 753713

    sharepoint designer problem

    rou2a Lurker

       

      Hi there,

       

       

      I'm having a problem trying to virtualize microsoft sharepoint designer. when I run the application it give me a message "cannot load fpsrvutl.dll"

       

       

      the file is located in C:\Program Files\Common Files\microsoft shared\Web Server Extensions\12\BIN I tried to set different isoluation modes writecopy & full

       

       

      same goes for the registry key that point to the file. but all failed.

       

       

      it only work when the file is located on the test machine otherwise it fail.

       

       

       

       

       

      can anyone help me

       

       

       

       

       

      thanks in advance

       

       

        • 1. Re: sharepoint designer problem
          rice4lunch Novice

          just a huntch, trying copy and putting the file in original location, %systemsystem%, and also the exe folder.

          • 2. Re: sharepoint designer problem
            rou2a Lurker

             

            I copied them but no luck,

             

             

            same problem only the message changed instead of c:\program files\common files.... c:\program files\microsoft office\

             

             

             

             

             

             

             

             

            • 3. Re: sharepoint designer problem
              MTalaga Lurker

              Any luck with this?

              • 4. Re: sharepoint designer problem
                Theike Hot Shot

                Hi,

                 

                We had a similar issue (file localy = ok, in capture fails) with some other program, and the following solution worked for us:

                 

                 

                0) Make sure you use 4.0.1-2866 (the vbs script won't work correctly with 4.0.0-2200)

                1) After capturing the app, obtain MFC42.DLL (any Windows XP system should have it in C:\Windows\System32\MFC42.dll) and copy it to the %SystemSystem% directory

                2) Save the attached "external.vbs" script in the same directory as Package.ini and patch the files to be used locally

                3) Add the following line to Package.ini in the \[BuildOptions\] section:

                ExternalDLLs=file1.dll;file2.dll;file3.dll

                 

                 

                And rebuild the package.

                 

                 

                What it basically does is the following:

                The script 'moves' the files (dll's) from the bubble to the sandbox by 'changing' them (open for rewrite). The dll's are specified to be loaded from the local system (point 3: ExternalDLLs-list), so ThinApp doesn't load them from within the bubble. Next the path is updated so the sandbox is searched as well.

                 

                 

                Check the script and patch it so it matches your situation (like replacing the 'PATH\TO\YOUR\APP' (2x) and the list of files.)

                 

                 

                Please let us know if this works.

                 

                 

                Kind regards and good luck,

                 

                 

                Michael Baars

                (ps: note to mark as solved/assign points)

                • 5. Re: sharepoint designer problem
                  753713 Enthusiast

                   

                  Hi,

                   

                   

                  in this script, I have this error:

                   

                   

                  Description:Erlaubnis verweigert.

                   

                   

                  File:(null)

                   

                   

                  Line 10 Character2 at:

                   

                   

                   

                   

                   

                  Any Ideas for this error?