1 2 Previous Next 15 Replies Latest reply on Dec 29, 2008 11:21 AM by wlwalsh

    SVGA II - This device cannot start. (Code 10)

    wlwalsh Novice

      I just upgraded from Vmware Fusion 1.1.3 to version 2.01. The device manager now shows a yellow exclamation point and the device status shows "This device cannot start. (Code 10)". The virtual machine does run but the guest window does not seem to size correctly as the desktop will no longer fill the window which it used to do in version 1.1.3. Does anyone have any suggestions as to how to correct the driver status and/or the window behaviour?

       

      Host machine is Mac Pro Core Duo (yes, a measly 4 cores ).

      Host OS is Mac OS X version 10.5.5 build 9F33

      Host machine memory: 10 GB

       

      Guest OS is Windows XP Pro Service Pack 3, 32- bit

      Configuration: 2 Virtual Processors, 3 GB RAM, Unity Disabled, 3D Enabled.

       

      A further note for the Vmware staff.

       

      My first step, in the finest Windows tradition, was to attempt to run Repair to see if the installer could correct the problem. This led to frustration followed by disaster.  Or at least it would have been disaster if I had not zipped an image of the virtual machine before upgrading it.  It was an illuminating experience.

       

      Item: You can't just run Repair from the Add/Remove programs control panel because the VMWare installer (contrary to Microsoft requirements) does not leave a copy of its database on the Guest.

       

      Item: I did activate the Repair option by initiating another upgrade using the VMWare. It presented the usual Modify/Repair/Uninstall menu so I selected repair. It started out OK and seemed to be removing the tools installation but when the reinstall phase started, the install hung at the SVGA install.  I gave it 10 or 15 minutes (although it should not need anything like that amount of time) and it remained hung. I attempted to Cancel ( the button was lit) but it ignored this entirely.  I was eventually forced to use Task Manager to terminate the repair. I rebooted and tried again; several times but never successfully. Interestingly, while it always hung, it wasn't always at the SVGA driver.  Sometimes it was the network driver (Vmxnet), sometimes the VMCI (whatever that may be). All had to be forcibly aborted. Always, it refused to Cancel (the Cancel button is supposed to work, Gentlemen).

       

      Item: I powered off the Guest, and disabled 3D as an experiment. When I powered up the Guest, it booted until it became time to display the desktop.  At that point, it announced that it could not find the desktop and declared a System Exception. It counted down and then rebooted. At that point, chkdisk ran, reported and corrected a number of file system errors, and booted. Still no desktop. At this point the virtual machine was completely corrupt so I deleted it completely.

       

      Using a new copy of my original virtual machine, I did the upgrade again. It took a couple of tries but I finally got the tools installed.  The SVGA problem mentioned earlier, remained. Also, the USB controller reported the following device status: "The drivers for this device are not installed. (Code 28)" and a big yellow question mark. I pressed "Reinstall Driver" and the system found and installed the standard USB driver.  Isn't this supposed to be a Vmware specific driver?.

       

      Observation: If you run install Vmware tools from the Vmware Fusion application and then Cancel it at the first opportunity (before installation starts) it leaves a copy of msiexec.exe running.  It is not supposed to do this.

       

      Observation: While performing the attempts described earlier, I saw as many as 6 copies of msiexec.exe running and three copies of runonce.exe.  I don't know what you are doing, but this is not normal.

       

      Observation: Out of curiosity, I brought up Orca and ran the ICE validation checks on your installer.  The result was an incredible number (too many for me to count, life is short) of errors and warnings.  In my limited experience, I have never seen so many validation errors in a shipping product. I realize it is difficult to completely avoid validation warnings but this is ridiculous.  Taken with the flakey way that your installer behaved, I would suspect that these errors need some attention. It may be that some of the weird and wonderful problems that have been reported on this forum could be accounted for.

       

      Thank You for your time.

       

      WLWalsh

        • 1. Re: SVGA II - This device cannot start. (Code 10)
          TheLoneVM Enthusiast
          VMware Employees

          Very strange, sorry to hear about your problems.  This is not something I have seen or heard of before.  The only time I have seen the svga driver fail to install was in one

          case where another application removed the

          "HKLM-Software\microsoft\windows\currentversion\runonce" registry key.

          Not likely, but could you check to make sure that this key exists?  There should be a log file in Documents and Settings/<username>/Local Settings/Temp  file  please post the vminst.log_xxxxxx_failed.log file here.

           

           

          As for troubleshooting, two basic things first, have you upgraded your virtual machine (Virtual Machine -> Upgrade Virtual Machine while VM is powered off?), and second are you logged into the guest as administrator?  Other then that, I have seen that sometimes the installshield  program itself gets confused when it tries to use a temporary directory that already exists.  I would try uninstalling the current tools, reboot, clear out the Documents and Settings/<username>/Local Settings/Temp directory and then try installing tools again.   Note, after removing tools it will find new devices and ask to reboot.  Click on "No" for the driver install, and don't reboot until after you have reinstalled tools.

           

           

           

           

           

           

           

           

           

          As a last resort, you can try manually deleting the old svga driver files, start again by uninstalling tools, reboot into safe mode,  and delete the following files:

           

           

           

          Windows\system32\vmx_fb.dll

           

           

           

          Windows\system32\vmx_mode.dll

           

           

           

          Windows\system32\drivers\vmx_svga.sys

           

           

           

          Then reboot and try installing tools again.

          • 2. Re: SVGA II - This device cannot start. (Code 10)
            Guru

            In case OLDTheLoneVM's suggestions don't help, some thoughts:

             

            What video card do you have?

            Try disabling 3D. I recall one report where this helped: 2beta2 vmware svga II xp device cannot start.

            At the least, we need vmware.log (and possibly the virtual machine - if you're willing to do that, let me know and I'll contact you privately if the display devs decide they need it).

            • 3. Re: SVGA II - This device cannot start. (Code 10)
              wlwalsh Novice

              I have not yet had a chance to try the fixes you suggested but I did want to reply promptly with some of the information you requested.

               

              The RunOnce and RunOnceEx keys exist.  Both are set to: (default) (value not set).  I am not really sure whether this is correct or not.

               

              I no longer have any Windows specific logs for the Virtual Machine that was corrupted but I am sending you all the logs I have for the current Virtual Machine which has the driver problems I discussed earlier.  This includes MSI installer logs which may help. I have also included some other logs from the host system, in case they may prove helpful.

               

              I have made a copy of the machine in its current state, prior to trying your fixes, which I will retain in case there is more information you would find helpful.

               

              I have a conference call with a client shortly.  After I have dealt with whatever that may bring, I will try your suggestions.

               

              My display card is an ATI X1900, the Apple version as shipped by Apple so there should not be any compatibility problems of that kind.

               

              Thank you for your prompt response, I will get you further reports as soon as I can.

               

              wlwalsh

              • 4. Re: SVGA II - This device cannot start. (Code 10)
                wlwalsh Novice

                I tried your suggestion about cleaning the Local Settings Temp folder.  I removed all files except for three (not yours) that were currently locked by the system.  Two of them were from Performance Monitor.  I didn't recognize the third.

                 

                It went like this:

                 

                Started Virtual Machine.

                Ran Update Vmware tools from the menu.

                Selected Uninstall from the Modify/Repair/Uninstall dialog box.  The Uninstall ran to completion without visual error indication.

                Restarted virtual machine to complete uninstall.

                The machine rebooted successfully.

                Restarted virtual machine again, partly on general principles and partly because of other reports on this forum.

                This time, the hardware wizard appeared.  It wanted to install a VGA driver. I allowed it to try, it failed, I cancelled it.

                The hardware wizard appeared again.  It wanted to install the base device (whatever that is). I just cancelled it.

                Ran Update Vmware tools from the menu.

                The installer ran until it tried to install the mouse driver.

                The installer hung while trying to install the mouse driver. I gave it over 5 minutes to complete. It did not complete in that time.

                Observation: I looked at this with Task Manager while it was hung.  There were four copies of msiexec.exe in the process list and one copy of runonce.exe. None of them were registering any CPU time.

                Since the Cancel button was enabled, I pressed it several times. It beeped, and did nothing.

                I aborted the install using Task Manager.  Task Manager reported that the task was not responding so I told it to end the task.

                I attempted to copy the logs from the temp area.  The system said they were in use.

                Three copies of msiexec.exe were still in the process list. I attempted to abort them to free the log files.

                Observation: When I terminated one of the msiexec.exe processes, another copy of msiexec.exe and a copy of runonce.exe promptly were spawned.

                I finally got all copies of msiexec.exe and runonce.exe to terminate and copied the logs.

                I have attached the logs generated from the uninstall and the subsequent reinstall.

                 

                Just based on the way the installer behaved, and the abort process, this looks rather like a "deadly embrace" situation.  I am running two virtual CPUs.  Could this be a factor?

                 

                Note to etung.  I did see that forum post.  It did, however, say that this was a problem with legacy operating systems so I did not think it applied.  Windows XP Pro SP3 is not normally considered a legacy operating system.  At the rate things are going, it may last longer than the (soon to be replaced) Vista.   Did I misinterpret the forum post in this regard?  In any case, I will try your suggestion about disabling 3D next; perhaps I can reproduce the corrupted virtual machine failure.

                 

                When I installed vmware fusion 2.01, I removed vmware fusion 1.1.3 using the uninstaller that came with 1.1.3.  I then installed fusion 2.0.1 and upgraded the virtual machine.  All virtual machines were shut down at that time.

                Yes, my account is an administrator account.

                 

                I will generate further reports as this proceeds.  If you need any more information or have further suggestions, just let me know.

                 

                Thanks,

                 

                wlwalsh

                • 5. Re: SVGA II - This device cannot start. (Code 10)
                  wlwalsh Novice

                  Please excuse multiple posts.  The forum seems to be rejecting my attachment.  I will try again.

                   

                  In fact, the forum is saying that I am unauthorized although it seems to post my message, it will not post the attachment. Since I am doing this last paragraph in edit mode, I will give it one more try.  If this doesn't work, please let me know what is necessary to post the attachment that should go with this (these) replies.

                   

                  This time, it says the file is too large.  The file (zipped) is only 2.2Mbytes.  What gives?

                   

                  Oops, sorry. I looked at the wrong one.  The file I need to upload is 6.6 Mbytes.  Please advise.

                   

                  Thanks

                   

                  wlwalsh

                   

                  Message was edited by: wlwalsh

                   

                  Message was edited by: wlwalsh

                  • 6. Re: SVGA II - This device cannot start. (Code 10)
                    wlwalsh Novice

                    Hi etung,

                     

                    I am sure you will be happy to know that I have reproduced the problem where the virtual machine was corrupted during installation of Vmware Fusion 2.01. On the bright side, while the machine seems to be pretty much destroyed, the device manager does say that the SVGA driver installed correctly.

                     

                    The following describes what happened more or less:

                     

                    Uninstalled VMWare tools which seemed to succeed although the previous install was somewhat doubtful. Still, the installer didn't complain during the removal process.

                    Rebooted, to complete uninstall.

                    Shut down virtual machine.

                    Disabled 3D graphics.

                    Powered on virtual machine.

                    Cancelled hardware wizard which wanted to install video driver.

                    Cancelled hardware wizard which wanted to install base component.

                    Initiated Install of Vmware tools from the Fusion menu.  Interestingly, the install completed without error.

                    Restarted machine when prompted to do so.

                    Machine came up. Desktop had shrunk to 640 by 480.

                    Got an error. "VMWare tools failed to start"

                    Restarted machine again.

                    Machine reached point where desktop was being painted.  Then the following error occurred:

                        SYSTEM SHUTDOWN. Ordered by NT AUTHORITY\SYSTEM

                        C:\Windows\system32\lsass.exe terminated unexpectedly.

                        Error code was -1073741818

                    This dialog runs through a one minute countdown to give you a chance to save files, then restarts.

                    The restart again reached the point where it was painting the desktop.  Then the following error occurred:

                      APDPROXY.EXE - Unable to locate component.

                       APDBOOT.DLL not found.

                    Using the device manager, I did check the SVGA and it indicated that it was operating normally. Obviously, nothing else was.

                    Just for fun, I resized the screen to 1280x800 and restarted.

                    Machine came up. Desktop had shrunk to 640 by 480.

                    Got the following errors:

                        VMWARETRAY.EXE - Unable to locate component.

                        VMCONTROLPANEL.CPL was not found.

                    Restarted again.

                        Got the errors shown in the attached tiff file.

                     

                    Somehow I doubt that rebooting will cure anything at this point.

                     

                    Why don't you tell me what information you want and I will try to obtain it.  I believe I remember that there is a way that I can open the virtual hard drive with the virtual machine shut down.  If so, I can give you the collection of logs that are probably still there.  I have not seen any complaints from chkdisk so the file system may still be intact or, at least, mostly so. I am not going to proceed until I hear from you since it would seem to be impossible to upload the information anyway, given my earlier experience.

                     

                    wlwalsh

                    • 7. Re: SVGA II - This device cannot start. (Code 10)
                      Guru
                      wlwalsh wrote:

                      Machine reached point where desktop was being painted.  Then the following error occurred:

                          SYSTEM SHUTDOWN. Ordered by NT AUTHORITY\SYSTEM

                          C:\Windows\system32\lsass.exe terminated unexpectedly.

                          Error code was -1073741818

                       

                      I haven't looked at anything else in your posts, but this jumped out. It suggests the guest may have been infected with the Sasser worm.

                      • 8. Re: SVGA II - This device cannot start. (Code 10)
                        wlwalsh Novice

                        To be honest, etung, I find it a little strange that reconfiguring vmware to disable 3D would suddenly cause this worm to manifest.  I will, however, check it out.  I am in the process of compressing the corrupt VM.  Once that is done, I will reinstall vmware from scratch without 3d and see what happens. I will also install that copy of Macafee that came with VMware and run a check.  I had not wanted to install the virus software until I was sure that the basic installation was stable but ...

                        • 9. Re: SVGA II - This device cannot start. (Code 10)
                          Guru

                          I don't think it's cause/effect so much as coincidental timing (or maybe a red herring). Regardless, I would suggest keeping the virtual machine off the network to minimize variables while you set up the fresh test.

                          • 10. Re: SVGA II - This device cannot start. (Code 10)
                            wlwalsh Novice

                            By the way, I discovered an aggravating undocumented feature of 2.0.1.  I had deleted the old virtual machine (both on the disk and in vmware) so I opened the new virtual machine in vmware.  It immediately asked me if I wanted to upgrade (fine) but I didn't press the button right away.  I checked the settings to make sure that 3d was disabled.  I then pressed the upgrade button.  By the time the machine had finished booting (up to the login prompt), the setting had been changed to 3D enabled.  I wondered how the initial machine had wound up with 3D enabled but at the time I thought it was my error.  I am sure 3D is a wonderful feature but I did not want it on this machine; that isn't what I use this one for.

                             

                            Oh, and what is this "Base Device" that Windows is determined to install (but can't), anyway?

                            • 11. Re: SVGA II - This device cannot start. (Code 10)
                              wlwalsh Novice

                              The virtual machine was checked with Intego (external) and McAfee (internal). Neither program found any virus or worm.

                               

                              I did another complete upgrade on a clean copy of the virtual machine. Install finished without any error indication but Device Manager reports the following problems.

                               

                                The SVGA II driver could not be started. Status is "This device cannot start. (Code 10)"

                                An "Other Devices" entry which contains "Universal Serial Bus (USB) Controller".  Status is "The drivers for this device are not installed. (Code 28)"

                               

                              The machine, other than the display problems caused by the driver, seemed to work normally.

                               

                              I shut down the machine, set 3D to disabled, and powered on the machine. The system booted to the login prompt and I signed in.

                               

                              The system failed as shown in the first picture and automatically restarted after a delay. Went through the chkdisk process and came up.

                               

                              The system failed again as shown in the second picture.  Note that the symptoms seem to be different after each reboot. Perhaps some kind of timing issue during startup?

                               

                              Forced the machine to the power off state using the vmware menu. Re-enabled 3D

                               

                              The system went through the chkdisk process and rebooted to the login prompt. I signed on and the system came up working more or less normally. The two device problems were present though.

                               

                              The event log showed a number of system and application errors that occurred when 3D was diisabled. Some of them are in the third picture.

                               

                               

                              It would appear that vmware has not been installed properly.  For some reason, it mostly works when 3D is enabled but breaks the system when 3D is disabled.  The SVGA II driver has been seen to start successfully when 3D is disabled; perhaps that improperly installed driver is what is breaking the system. Of course, if the driver were properly designed and coded that wouldn't happen but it is painfully obvious that somebody, probably Marketing, rushed this product to a premature release.  You have my sympathy; I have been there myself.

                               

                              It would also appear that the destruction of the machine is a secondary effect of the failure caused by the abnormal terminations of Windows when these failures occur.  NTFS can usually, but not always, recover from an abnormal termination.  If it fails to recover, as it has on a couple of occasions, the virtual machine is destroyed.

                               

                              At this point, I have collected a lot of data which the forum software won't let me up load.  The MSI logs, for example, can be an invaluable troubleshooting aid for installer problems, if you have anyone who knows how to read them. I have them available because I have recently developed an installer for a client so I still have all of the logging options turned on.

                               

                              Let me know if you are interested in pursuing this problem and what data you wish to have. I will try to provide it.

                              • 12. Re: SVGA II - This device cannot start. (Code 10)
                                Guru

                                What sort of installation media are you using - is it custom in any way, OEM, etc.?

                                 

                                You can email the files to fusion-feedback or my username at the obvious domain. As I mentioned before, in addition to anything you think is useful, vmware.log (and possibly the virtual machine itself) would be helpful.

                                • 13. Re: SVGA II - This device cannot start. (Code 10)
                                  wlwalsh Novice

                                  The installation is from a general purpose Windows XP Pro disk.  It is not a machine specific install.  The original software is a 2002 edition but it has been upgraded to SP3 and has all the latest updates. Among other tool sets, it includes Visual Studio 2008 SP1, .NET 2.0, .NET 3.0, .NET 3.5, MSDN Library, and Windows SDKs.

                                   

                                  I have attached logs and screen shots from an attempted install of Vmware tools with 3D disabled which, as usual, failed utterly, and in this case, destroyed the virtual machine while doing so.

                                   

                                  To do this, I upgraded the virtual machine, allowed it to boot to the sign in prompt, shut down, changed 3D to disabled in the virtual machine settings, and powered on. The boot proceeded normally to the sign in prompt.  After signing in, a long string of failures occurred.

                                   

                                  You should have received via e-mail the logs, and screen shots, of an install with 3D enabled followed by a switch to 3D disabled after the installation was complete.

                                   

                                  Hope you find these useful.

                                   

                                  wlwalsh

                                  • 14. Re: SVGA II - This device cannot start. (Code 10)
                                    Guru

                                    Heard back from the SVGA experts. They think your virtual machine is messed up (possibly before Tools entered the picture) and recommend you back up data and create a fresh virtual machine. They also note that you should make sure you have the latest version of Windows Installer. The error message in MSI37c2a.LOG about being unable to open 1033.MST is covered by http://support.microsoft.com/kb/888310

                                     

                                    The installation is from a general purpose Windows XP Pro disk. It is not a machine specific install. The original software is a 2002 edition but it has been upgraded to SP3 and has all the latest updates. Among other tool sets, it includes Visual Studio 2008 SP1, .NET 2.0, .NET 3.0, .NET 3.5, MSDN Library, and Windows SDKs.

                                     

                                    Are you talking about a slipstreamed CD or what you've done to the virtual machine since installation? XP didn't come with all that, and their presence may interfere with the intent of a clean test.

                                    1 2 Previous Next