1 2 Previous Next 17 Replies Latest reply on Jan 1, 2009 10:35 AM by MusicMartha

    Unity has stopped working upon upgrading to vmware tools in 2.01

    Pbryanw Enthusiast

      Hi,

       

      I have updated to Fusion 2.01 and updated my vmware tools to the new version. Upon updating my Unity menu became empty and Unity no longer worked.

       

      So, I deleted the Applications folder in my vmwarevm bundle to see if that would fix it, but it has not been re-created upon shutdown and restart of the vm, and the unity menu is still empty.

       

      I have tried uninstalling then re-installing the vmware tools twice but that han't helped.

       

      I think the problem is due to the advice I followed in this thread to remove applications from my OS X open with menu. Taken from thread (mudaltsov):

       

      "There was a bug in the original script that didn't properly remove an </array> entry from the Info.plist file, making it corrupted. Eric updated the script, and it should work correctly now. It also makes the applications read-only, which prevents Fusion from adding the file/URL handling information back into them (unless it publishes a new app). You can even keep the "Allow your Mac to open applications in the virtual machine" option turned on, so you can launch the applications from the Dock.

      After running the script, relaunching Finder seems to be enough to eliminate the apps from the Open With list. You can Relaunch Finder if you log out and back in, or hold down Option and right-click on the Finder in the Dock and choose Relaunch."

       

      I have also made sure the vmtools service is started and set to automatic. Also in the vm sharing settings "allow your mac to open applications in the virtual machine" is enabled.

       

      Any help appreciated, Paul

        1 2 Previous Next