4 Replies Latest reply on Nov 3, 2008 4:09 AM by Karunakar

    "Unable to access the specified host. It either does not exist, the server software is not responding, or ther is a network problem"

    Karunakar Hot Shot

       

      Hi All,

       

       

      Have been trying to resolve this since very long.

       

       

      I have a production server with ESX 3.0.1 . When trying to add this machine to the VC server  and then I get the above given error.

       

       

      Below are the resolutions I tried to resolve, but remained with no results.

       

       

      1> remove the vpxa rpm from the machine, restarted mgmt-vmware service, and tried to readd the machine from VC. --> Error is the same.

       

       

      2> When tried to make the entry of the vc server in the hosts file, tried to restart vpxa, and mgmt-vmware service, and tried to readd the machine from vc, --> Still error is the same.

       

       

      3> All the default gateways of the management agent and vmkernel network are the proper, and can ping from vc to esx and esx to vc perfectly.

       

       

      While trying to check the /var/log/messages file when trying to add the machine in vc, I get below errors.

       

       

      Oct 29 10:41:13 ukcdcph0012-sc vmware-authd(pam_unix)[3746]: authentication failure; logname= uid=0 euid=0 tty= ruser= rhost=  user=root

      Oct 29 10:41:16 ukcdcph0012-sc vmware-hostd[3746]: Rejected password for user root from 127.0.0.1

       

       

      I thought that this is some thing to do with the pam authentication, and made few changes in the "/etc/pam.d/vmware-authd" file as below.

       

       

      #auth       required     pam_stack.so service=system-auth

      #account    required     pam_stack.so service=system-auth

      auth   required        pam_permit.so   service=system-auth

      account    required    pam_permit.so   service=system-auth

       

       

      After doing this the machine allowes connection from the root @ 127.0.0.1, but still when try to add the machine on vc, i get the error.

       

       

      Checking the log file , /usr/sbin/vpxa stops very frequently.... like with in every 20 seconds. So machine is not able to connect to the VC server.

       

       

      Let me know if there are any other alternate solution to get this machine on vc, so that i can migrate the VM and rebuild this machine perfectly.

       

       

      Thanks,

       

       

      Karunakar