2 Replies Latest reply on Oct 21, 2008 7:08 AM by IamTHEvilONE

    Dedicate NICs

    gl3n Novice

      I have dell poweredge server with 3 NICs. 2 are onboard integrated with the 3rd being a PCIe Intel. I want 1 physical server to a single dedicated NIC and 2 VMs to other dedicated NICs. I want a static address assigned to the VM every time it's started. If I assign a static address in the VM using network connection the IP is assigned, however, if I run ipconfig on the host it displays a different ip on the adapter that was obtained via DHCP.

       

      Thanks for responses.

        • 1. Re: Dedicate NICs
          vmroyale Guru

          Hello.

           

          Try this: Remove the VMware Bridge Protocol from the network adapter that you want dedicated to the physical host.  Then remove all protocols, except the VMware Bridge Protocol, on the reamining two NICs.  This will give your host one dedicated NIC to use, and the other two NICs can be used for the VMs. 

           

          Good Luck!

          • 2. Re: Dedicate NICs
            IamTHEvilONE Champion

            Okay, I have generated some interest in this topic.  But we would like to know if this could be tested.

             

            Are you willing to test keeping the protocol bound to each adapter, but run the network editor manually (C:\Program Files\VMware\VMware Server\vmnetcfg.exe), disable automatic bridging, and specifically bridge to a single NIC that would let us know.

             

            As far as I know, disabling automatic bridging in the GUI (vmnetcfg.exe) has the same affect as de-selecting the protocol from the NICs that you do not want to bridge to.  (Although actually de-selecting the protocol at the NIC level will have a greater impact in that you won't be able to use custom bridging that that NIC any more.)

             

            What we want to know is if this resolves your problem without manually undoing the vmware bridged protocol.  If there is a functional difference, please explain how one method differs from the others.  (i.e. GUI does not prevent duplicate ACK messages)

             

            Please also see: http://communities.vmware.com/message/1080066/