2 Replies Latest reply on Feb 13, 2009 10:18 AM by haihong

    VMWare Fusion - PicoTech PS2203 USB Device not working

    jimmy_ott Lurker

      Hello,

       

      I'm using VMWare Fusion Version 2.0 (116369) on Mac OSX 10.5.5. Trying to connect my PicoTech PS2203 (USB) fails. I've read a discussion about a similiar problem with PicoScope 2202 which VMware and PicoTech solved together. So I try to ask here for support solving this.

       

       

       

      When I connect the PicoScope to the USB Port of my MacBook, my Windows XP (SP3) VMWare recognize the PS2203 and starts the Hardware Installation wizard. The driver installation never stops (the animation moving files from the left to right side). Manually disconnecting the device forces the HW wizard to go further, it says that the Hardware installation is now complete and the device is ready to use (in the device manager the scope is correctly listed without any exclamation mark)

      . Starting up the Software PicoScope R6.1.0/R6.0.13/R5.19.1/R5.20.1 (tested this versions) the application hangs while initialize the hardware device. Only disconnecting the device brings me back to a working VMware.

       

       

       

      The driver listed in devicemanager has the following version number: 1.13.2.0

       

       

       

      I've also enabled the usb analyzer in the .vmx file as suggested in the forum post previously mentioned and traced two logfiles which are attached to this post. One logfile is during hw install, the other one while starting up PicoScope 6.

       

       

       

      Thank you for any help! Jimmy

        • 1. Re: VMWare Fusion - PicoTech PS2203 USB Device not working
          haihong Novice
          VMware Employees

          Hi, Jimmy,

           

          Sorry about the delay in getting back to you. We have purchased a PicoScope PS2203 from UK to debug the problem.

           

          We found that the device has violated USB spec by setting the maximum packet size of bulk endpoint 1 out to 64 bytes. It should be set to 512 bytes for HighSpeed device. The device endpoint FIFO buffer is overflowed when host send packet bigger than 64 bytes to it and cause the device to hang. If you

          run the device natively on Windows host, the problem will not be exposed because Windows host breaks down packet to 64 bytes for bulk ep1 out. However, Mac host will just pass packet bigger than 64 bytes through virtual driver to the device which expose the problem.

           

          We have reported the issue to PicoTech and hopefully they fix the device to be compliant to USB spec. Meanwhile if you want to use the device inside VM on a Mac host, you can attach the PicoScope to Mac host through a full speed (USB1.1) hub. A full speed hub can force the host to send only packet limit to 64 bytes to endpoint 1 and workaround the problem. Please note that forcing the PicoScope to function through a full speed hub might impact its performance negatively and limit signal bandwidth it can sample.

           

          Please let us know if you have any question or run into problem.

           

          Thanks a lot.

           

          -Haihong

          • 2. Re: VMWare Fusion - PicoTech PS2203 USB Device not working
            haihong Novice
            VMware Employees

             

            Hi Jimmy,

             

             

            We have contacted PicoTech support. They have fixed the problem in driver PS2000.dll. We have tried out the driver and it resolved the hanging problem for PicoScope2203. You will find the ps2000.dll located in C:\Program Files\Pico Technology\Pico Full\ folder. Replace it with the updated one in your VM.

             

             

            Because they haven't officially release the update, I attached a copy here. Please contact them if you need driver update for other product. Following is the support ticket information we filed at PicoTech.

             

             

            Thanks a lot and best regards,

             

             

            Haihong

             

             

            -


             

             

             

            This is in reference with your Request Ticket Number: TS00021681.

             

            Haihong

             

            The updated driver will be included in the next release of PicoScope 6. In the meantime, the customer can email me (support@picotech.com - FAO Robin) or you can forward them the DLL.

             

            Regards

             

            Robin

            Pico Technical Support Team

            Visit our forum - http://www.picotech.com/support/