3 Replies Latest reply: Feb 17, 2009 1:02 PM by holycow RSS

    VMWare modules do not compile on latest debian 2.6.26-1 kernel

    arnaud.pn Lurker

       

      Debian OS up to date:

       

       

       

      1. cat /etc/issue.net

      Debian GNU/Linux lenny/sid

       

      1. uname -a

      Linux apn.it 2.6.26-1-686 #1 SMP Wed Aug 20 12:56:41 UTC 2008 i686 GNU/Linux

       

       

      Vmware version:

       

       

      VMware-server-1.0.6-91891.tar.gz

       

       

      Problem:

       

       

      Latest vmware-config.pl not compatible with those kernel headers:

       

       

      Using 2.6.x kernel build system.

      make: Entering directory `/tmp/vmware-config1/vmmon-only'

      make -C /lib/modules/2.6.26-1-686/build/include/.. SUBDIRS=$PWD SRCROOT=$PWD/. modules

      make[1]: Entering directory `/usr/src/linux-headers-2.6.26-1-686'

        CC   /tmp/vmware-config1/vmmon-only/linux/driver.o

      /tmp/vmware-config1/vmmon-only/linux/driver.c:146: error: unknown field 'nopage' specified in initializer

      /tmp/vmware-config1/vmmon-only/linux/driver.c:147: warning: initialization from incompatible pointer type

      /tmp/vmware-config1/vmmon-only/linux/driver.c:150: error: unknown field 'nopage' specified in initializer

      /tmp/vmware-config1/vmmon-only/linux/driver.c:151: warning: initialization from incompatible pointer type

      make[2]: *** /tmp/vmware-config1/vmmon-only/linux/driver.o Error 1

      make[1]: *** Error 2

      make[1]: Leaving directory `/usr/src/linux-headers-2.6.26-1-686'

      make: *** http://vmmon.ko Error 2

      make: Leaving directory `/tmp/vmware-config1/vmmon-only'

      Unable to build the vmmon module.

       

       

       

       

      => Is there an available patch solving this issue ?