1 Reply Latest reply on Aug 21, 2008 12:41 PM by rrdharan

    "Unable to resolve host name" when opening VMWare console -- SOLVED (??)

    ccochran Lurker

      On my Windows Server 2008 Enterprise x64 box, I just upgraded VMWare Server from 2.0 RC1 to 2.0 RC2 and everything seemed to work except for the following:

       

      1. My Datastore for ISOs (mapped to a network share) was not working. To resolve this:

        1. I disconnected all of the client CD rom drives that were using the store

        2. Deleted the store

        3. Re-created the store

        4. Re-connected the client server's CD-ROM drives to the ISOs datastore images

      2. I could not open a console session to a virtual server from the host OS's console. When I tried, I got the "Hostname could not be resolved for <vmwarehost>.<mydomain>. I could use another network PC to access the VMWare Server Home Page and open it successfully.

        1. In troubleshooting, I pinged a network host and it responded with the IPv4 address. Of course, Windows Server 2008 (like Vista) will use the IPv6 address when referring to itself.

        2. I opened C:\Windows\system32\drivers\etc\hosts and added an explicit entry to the IPv4 address for the server host to "trump" the default behavior of the OS.

        3. The console now opens correctly.

       

      Is there a better solution to the IPv6 thing on Windows Server 2008? I hate to leave this dropping on the server if there's a more elegant solution. I tried removing the IPv6 binding for the NIC but the system still resolves to the v6 address.