3 Replies Latest reply on Aug 21, 2008 4:48 PM by rrdharan

    RC2 issues on Vista x64

    EnzoMatrix Novice

       

      Hi,

       

      I'm running VMware Server on a laptop with Vista x64 SP1 Ultimate with wireless connection. Couple issues I found.

       

      1. There are some orphan files on the C drive left after installing the software, this happens with RC1 and RC2:

          C:\.rnd

          C:\msdia80.dll

          C:\Virtual Machines (I had changed the location of the VM to be "C:\Program Files (x86)\VMware\Virtual Machines" during installation)

       

      2. I installed RC1, I had the issue with the machine's name not working, the workaround was to use localhost and that worked fine. I was able to install Vista x32 Ultimate as a guest OS. I uninstalled RC1 and installed RC2, I added the VM for Vista back. I try to connect and it says "Error opening the remote virtual machine localhost:8333\48: A connection to the host could not be established". I uninstalled RC2 and re-installed RC1 and I have the same problem now.

       

      3. In RC1 when the guest Vista x32 was running,

         a. If I choose Bridged network, I can see my desktop computer, the router on the network but not my laptop (host OS)

         b. If I choose NAT network, I can see my laptop (host OS) but not my desktop computer and the router.

         How can I see everything on the network?

       

      4. The sound device is not detected by the guest OS, this happened with RC1 when I was able to run the guest OS. I also had installed Ubuntu x64 in RC1 and I had the same issue. The setting was "Auto Detect".

       

      Thanks,

       

      Pascal...

       

       

        • 1. Re: RC2 issues on Vista x64
          ccochran Lurker

          On my Windows Server 2008 Enterprise x64 box, I just upgraded VMWare Server from 2.0 RC1 to 2.0 RC2 and everything seemed to work except for the following:

           

          1. My Datastore for ISOs (mapped to a network share) was not working. To resolve this:

            1. I disconnected all of the client CD rom drives that were using the store

            2. Deleted the store

            3. Re-created the store

            4. Re-connected the client server's CD-ROM drives to the ISOs datastore images

          2. I could not open a console session to a virtual server from the host OS's console. When I tried, I got the "Hostname could not be resolved for <vmwarehost>.<mydomain>. I could use another network PC to access the VMWare Server Home Page and open it successfully.

            1. In troubleshooting, I pinged a network host and it responded with the IPv4 address. Of course, Windows Server 2008 (like Vista) will use the IPv6 address when referring to itself.

            2. I opened C:\Windows\system32\drivers\etc\hosts and added an explicit entry to the IPv4 address for the server host to "trump" the default behavior of the OS.

            3. The console now opens correctly.

           

          Is there a better solution to the IPv6 thing on Windows Server 2008? I hate to leave this dropping on the server if there's a more elegant solution. I tried removing the IPv6 binding for the NIC but the system still resolves to the v6 address.

          • 2. Re: RC2 issues on Vista x64
            EnzoMatrix Novice

             

            I found out how to have the VM starting in RC1 (after I uninstalled RC2 and re-installed RC1), instead of using localhost or the computer's name, I use the IP address in the shortcut that launches the VM.

             

            I won't try RC2 and I'll wait for GA since it's working just fine for now.

             

            Pascal...

             

             

            • 3. Re: RC2 issues on Vista x64
              Expert

              FYI, the remaining "hostname could not be resolved" issues in RC2 are due to an incompatibility with IPv6 networking. The issue has been fixed and the fix will be in the next build. In the meantime, workarounds include using either the literal IP address or adding the host->IP address mapping to system32\etc\hosts.

               

              Note that Server 2.0 GA will not truly support IPv6, in the sense that the management stack (hostd/web server) will only service incoming connections via IPv4 addresses.