1 2 3 Previous Next 704 Replies Latest reply on Aug 25, 2008 11:18 PM by dipaksharma

    BIG bug in ESX 3.5 Update 2 - If you're using 3.5u2 read this now! - A general system error occurred: Internal Error

    mattjk Enthusiast

      The express patches have been posted. This thread is long.

      Please post technical experiences here  and non-technical feedback  here. --JohnTroyer


      Hi all,


      We've just encountered a serious bug with our ESX cluster - serious enough that I thought I should post about it here as a prior warning for others running ESX 3.5 Update 2.


      The VMWare tech support person we spoke to wouldn't 100% confirm whether this was / would be affecting all ESX3.5u2 installs, but he strongly alluded that it was widespread. For others sake I hope I'm wrong and it's limited.






      The bug:







      Starting this morning, we could not power on nor VMotion any of our Virtual Machines. The VI Client threw the error "A general system error occurred: Internal Error".


      Further digging lead us to messages like this one in /var/log/vmware/hostd.log, and the log file for any virtual machine we tried to power on or VMotion:


      Aug 12 10:40:10.792: vmx| http://msg.License.product.expired This product has expired.

      Aug 12 10:40:10.792: vmx| Be sure that your host machine's date and time are set correctly.

      Aug 12 10:40:10.792: vmx| There is a more recent version available at the VMware Web site: "http://www.vmware.com/info?id=4".


      A call to tech support confirmed this as a known problem with a temporary workaround.











      The work-around:


      Turn off NTP (if you're using it), and then manually set the date of all ESX 3.5u2 hosts back to 10th of August. This can be done either through the VI Client (Host -> Configuration -> Time Configuration) or by typing date -s "08/10/2008" at the Service Console command line on the ESX hosts.


      As soon as the date was reset to the 10th - problem solved.


      Note that running VMs were operating fine, this only seems to affect initial VM power-on (including from suspended state) and VMotion.










      So, it sounds like a serious licensing bug has crept into 3.5u2. Further testing shows that the problem begins as soon as the date hits 12th August - 10th is fine, 11th is fine, 12th and the problem appears.


      There wasn't any real reference to similar problems in the forums as far as I could see, but it's quite possible we're seeing this before most of the rest of the world as we're in Australia, and therefore the date here ticked over to the 12th "before" those in Europe, America, etc.


      Hope this helps others... took us a couple of hours to get this far - at least we can power on VMs again though!

















      Matt Kilham

      Stratton Car Finance


      Message was edited by: JohnTroyer to add new thread links.

        1 2 3 Previous Next