0 Replies Latest reply on Aug 3, 2008 1:37 AM by necron73

    vmware not configured after reboot

    necron73 Novice

      Hello Community,

       

      after solving my problem with corrupted virtual disks the next problem appeart. I did a fresh installation of vmware 2rc1 on a new host and did a /usr/bin/vmware-config.pl. Except one warning the process succeded and vmware is running well but after a reboot the startup of vmware failed with the notice that vmware is not configured and I had to rerun "/usr/bin/vmware-config.pl" before I can use my virtual machines.

       

      OS Host:

      baal:~ # cat /etc/SuSE-release

      openSUSE 11.0 (X86-64)

      VERSION = 11.0

       

      The mentioned warning during configure process is the following warning:

       

      Your kernel was built with "gcc" version "4.3.1", while you are trying to use

      "/usr/bin/gcc" version "4.3". This configuration is not recommended and VMware

      Server may crash if you'll continue. Please try to use exactly same compiler as

      one used for building your kernel. Do you want to go with compiler

      "/usr/bin/gcc" version "4.3" anyway? yes

       

      I think this should not be the problem, because "gcc -v" gave me this:

       

      baal:~ # gcc -v

      Using built-in specs.

      Target: x86_64-suse-linux

      Configured with: ../configure --prefix=/usr --with-local-prefix=/usr/local --infodir=/usr/share/info --mandir=/usr/share/man --libdir=/usr/lib64 --libexecdir=/usr/lib64 --enable-languages=c,c+,objc,fortran,obj-c,java,ada --enable-checking=release --with-gxx-include-dir=/usr/include/c+/4.3 --enable-ssp --disable-libssp --with-bugurl=http://bugs.opensuse.org/ --with-pkgversion='SUSE Linux' --disable-libgcj --with-slibdir=/lib64 --with-system-zlib --enable-__cxa_atexit --enable-libstdcxx-allocator=new --disable-libstdcxx-pch --program-suffix=-4.3 --enable-version-specific-runtime-libs --enable-linux-futex --without-system-libunwind --with-cpu=generic --build=x86_64-suse-linux

      Thread model: posix

      gcc version 4.3.1 20080507 (prerelease) (SUSE Linux)

       

      vmware-config.pl uses "gcc -dumpversion" and this gives "4.3" .

       

      So I ignored this warning and configuration succeded:

       

      Starting VMware services:

         Virtual machine monitor                                             done

         Virtual machine communication interface                             done

         VM communication interface socket family:                           done

         Virtual ethernet                                                    done

         Bridged networking on /dev/vmnet0                                   done

         Host-only networking on /dev/vmnet1 (background)                    done

         DHCP server on /dev/vmnet1                                          done

         Host-only networking on /dev/vmnet8 (background)                    done

         DHCP server on /dev/vmnet8                                          done

         NAT service on /dev/vmnet8                                          done

         VMware Server Authentication Daemon (background)                    done

      Starting VMware management services:

         VMware Server Host Agent (background)                               done

         VMware Virtual Infrastructure Web Access

      Starting VMware autostart virtual machines:

         Virtual machines                                                    done

       

      The configuration of VMware Server 2.0.0 build-101586 for Linux for this

      running kernel completed successfully.

       

       

      But after a reboot I recognized no vm was started and under /etc/vmware I found the file "not_configured".

       

      What is going wrong? I can't find the problem.

       

      Any ideas?