1 2 Previous Next 28 Replies Latest reply on Sep 27, 2016 8:52 PM by jeetendraparekh1 Go to original post
      • 15. Re: Error 1406. could not write value folder type to key
        continuum Guru
        Community WarriorsvExpertUser Moderators

        Try to create it yourself BEFORE you try an install







        description of vmx-parameters: http://sanbarrow.com/vmx.html

        VMware-liveCD: http://sanbarrow.com/moa.html

        • 16. Re: Error 1406. could not write value folder type to key
          Marakai Lurker



          Have you ever been able to resolve this issue?



          I am trying to get Workstation 6.5 installed on a fresh install of 64-bit Vista Ultimate and am encountering the same error(s).





          I've tried every single solution in permutations - using local admin user, running the registrly fix, manually adding the registry keys, but to absolutely no avail.





          This is starting to have business impact (maybe I should just open an official ticket?) as I need Vista64 to address all my RAM (otherwise I would certainly just stick with XP - I don't think XP-x64 is officially supported is it?)














          PS: On a whim I deleted all keys referring to VMware from my registry - I had the VMware server browser plugin installed to get to the console of some remote VMs.




          Interestingly enough the installation proceeded far further and was able to successfully create all registry keys.




          Unfortunately it then stops with the cryptic:




          Warning 25033: Failed to remove Windows logon customization (INSTALLED=). Please contact your administrator.




          Not amount of googling has returned anything useful on this message anywhere - while labelled a "warning" it results in an automatic rollback of the installation.






          Not for the faint of heart: to try and get to the bottom of this, I took drastic measures and when above warning showed up I yanked the power (merely killing the installl process still creates a rollback, as it should). Brutal but it left almost everything in place and I'm able to bring up Workstation, enter a license key, add VMs, configure etc.



          When trying to start the machine up, though, I get "authorization service is not running". And when I check, none of the VMware services are available under Windows, so apparently it's trying to install those where the install goes awry. Is there a manual way to register all necessary services? Or is this enough information for someone to check what's going on here?


          Message was edited by: Marakai

          Added further troubleshooting information.

          • 17. Re: Error 1406. could not write value folder type to key
            matt336 Lurker


            When it asks for a path where to install it (on Vista x64) install it somewhere other than C:\Program Files (x86) .... I chose C:\VMware and it installed successfully.



            • 18. Re: Error 1406. could not write value folder type to key
              jvs Lurker

              I had a similar error with a different registry key. After I rebooted and tried to install workstation the problem was gone.


              Best regards,


              • 19. Re: Error 1406. could not write value folder type to key
                lightningbit Novice


                I had a similar issue/error



                I was installing VMware infrasturcture client 2.5.0 on a Windows vista Ultimate (32bit) , as an administrative user



                after reading this discussion, the consensus seems to be towards a registry access/write issue.



                So I did some troubleshooting/testing there :



                - I didn't stop the installation, while I was doing the below, I kept the install on the error where it complained about not being able to write the regkey, with the options CANCEL/IGNORE/RETRY



                - setting/resetting/changing the permissions on the key /SOFTWARE/VMware, Inc. through regedit did not work, adding a subkey didn't work either (permission denied), however, renaming the key DID work



                - now because the only other vmware tool I had installed on this machine was the vmware remote console



                - I RENAMED the /VMware, Inc. key to VMware, Inc. old



                - and then clicked "RETRY" on the installation error message ............... the install continued without issues, and I saw immediately a new /VMware, Inc. regkey appearing in the registgry, with all subkeys






                I hope this helps some of you, having similar issues









                • 20. Re: Error 1406. could not write value folder type to key
                  rguyler Novice

                  Not to dig up an old thread but maybe this will help others who may still run into this problem.


                  I ran into this issue today and not a lot out there that helped.  I finally just deleted the HKEY_LOCAL_MACHINE\SOFTWARE\VMware, Inc.\VMware Workstation key and then clicked "Retry" and everything installed just fine.



                  • 21. Re: Error 1406. could not write value folder type to key
                    BTirado Lurker

                    Just had this issue on a 2003 Server, was able to get around it by removing the VMware Key in the registry (The only VMware thing on this server is the vSphere client).  I had to restart the install after removing it as the retry option did not work.

                    • 22. Re: Error 1406. could not write value folder type to key
                      ewanat Novice

                      Thank you. renaming the regsitry key worked for me.

                      In my case I just migrated the Virtual Center from Windows 2003 32bit version 2.5U6 to Windows 2008 64bit version 4.1U1.
                      When I tried to install vCenter Update Manger I got the same issue that it could no create the key in the registry but in SOFTWARE\Wow6432Node\VMware, Inc. (since UpdateManger is 32bit).

                      • 23. Re: Error 1406. could not write value folder type to key
                        RossVerr Lurker

                        Hi All,


                        I received the same error when trying to install the vSphere Client immediately after installing vCenter Server.  I rebooted the server and was then able to install vSphere Client without making any changes....



                        • 24. Re: Error 1406. could not write value folder type to key
                          daveportland Lurker

                          Worked for me!


                          I was installing vcenter converter on xp and getting error 1406

                          Install was conflicting in regards to the registry with vmware remote console which was already installed

                          I tried changing the install path and got the same results


                          Then I  did start, run, regedit, found the file HKEY_LOCAL_MACHINE \ SOFTWARE \ VMware, Inc.

                          I changed the name on the file to VMware, Inc. remote console

                          Then I retried the install and it went through without a hitch


                          I went back and tried the remote console and it still worked fine with the change I made in the registry name.

                          Seems to me VMware has a problem with their install process with conflicting registry entries when more than one product are installed.

                          Comes up on multiple products and multiple operating systems

                          Hope this helps anyone having this problem and I hope VMware gets it corrected.

                          • 25. Re: Error 1406. could not write value folder type to key
                            CallumCarmicheal Lurker

                            Help Im Getting Same error but i did what u said


                            cd %ProgramFiles%\Windows Resource Kits\Tools

                            subinacl /subkeyreg HKEY_LOCAL_MACHINE /grant=administrators=f

                            subinacl /subkeyreg HKEY_CURRENT_USER /grant=administrators=f

                            subinacl /subkeyreg HKEY_CLASSES_ROOT /grant=administrators=f

                            subinacl /subdirectories %SystemDrive% /grant=administrators=f

                            subinacl /subkeyreg HKEY_LOCAL_MACHINE /grant=system=f

                            subinacl /subkeyreg HKEY_CURRENT_USER /grant=system=f

                            subinacl /subkeyreg HKEY_CLASSES_ROOT /grant=system=f

                            subinacl /subdirectories %SystemDrive% /grant=system=f


                            i get  1312311 (NUMBERS) MODIFED and i get 123123131321 (well not egsacly that mutch) but i get errors is that right ?


                            its not done yet but im wondering is it doing it right ?

                            • 26. Re: Error 1406. could not write value folder type to key
                              americhanac Novice

                              Just my two cents in this discussion.


                              a) Do NOT play with subacl tool as you WILL probably break something if you use your pc for more than facebook. If b) doesn't work for you immediatelly reinstall your machine ASAP as something has gone terribly wrong and you are most likely contributing to organized DDos attacs without your knowledge.


                              b) Delete all VMWare entries from Registry (there is a search function > use it)


                              After cleanup on three major places, installation works.


                              In my case, I wanted to make a shortcut and ran vmplayer from another PC (and it was Vista, 32 bit) without install. Apparently, VMWare, Inc registry entries target like HCLM so Local User settings and few others. b) worked like a charm


                              And, as always, good never-trust-wikipedia-totally-rule: Don't fiddle with stuff others know less than you about

                              • 27. Re: Error 1406. could not write value folder type to key
                                GSEXTON Lurker

                                Hi, I read Oliver's response and his method solved my installation problem for installing VMware Player on win8.1.

                                I opened the c:\windows\syswow64\regedit.exe and deleted the key mentioned in the message, HKLM\Software\VMware Inc. and the installation completed successfully.

                                • 28. Re: Error 1406. could not write value folder type to key
                                  jeetendraparekh1 Lurker

                                  I had same issue with VMware Horizon View Agent 7.x and I wasted entire day looking for some solution.

                                  Finally my findings are "sometimes we look at the bigger things and forget the smaller things and mess up everything".


                                  Let me ask you, have you tried to disable the Anti-Virus protection from your machine?

                                  AntiVirus tries to stop everything and everybody to make sure the system is protected and sometimes its pain.


                                  I had McAfee and I had to go to VirusScan Console and had to Disable below things:

                                       Access Protection

                                       On-Delivery Email Scanner (which I don't think is required, for 1-2 minutes there is no harm in disabling this)

                                       On-Access Scanner


                                  And the problem got resolved.

                                  1 2 Previous Next