2 Replies Latest reply on Jul 16, 2008 1:54 AM by The-GUINNESS

    VMware Tools won't mount or install

    Ross Walter Novice

       

      hi!

       

       

      I'm having a problem that's been bugging me for a while - I've P2V'ed a server (using VMware Converter) and need to run through the post-P2V tasks and cutover to the new VM. I select to install the VMware Tools for this Win2000 VM and the initial message appears, then.... nothing.

       

       

      The VMware Tools CD .ISO image doesn't mount, doesn't display any errors and doesn't install...

       

       

      The details of this are:

       

       

      - VC 2.5

       

       

      - ESX 3.5.0 (build 84374)

       

       

      - host is an IBM x3550

       

       

       

       

       

      I've even tried mounting the VMware Tools .ISO image (ie "windows.iso") via the "Datastore ISO file" option in the VM's CD settings, but again, this doesn't mount.

       

       

      Any advice will be greatly apprciated!

       

       

      thanks,

       

       

      Ross.

       

       

       

       

       

        • 1. Re: VMware Tools won't mount or install
          Ross Walter Novice

           

          Here's some entries in the vmware.log file for this affected VM:

           

           

           

           

           

          Jul 08 10:59:49.520: vcpu-0| CDROM: switching CDROM state from 2 to 3 using error sense key.

          Jul 08 10:59:53.520: vcpu-0| CDROM: switching CDROM state from 3 to 4 using error sense key.

          Jul 08 10:59:57.520: vcpu-0| CDROM: switching CDROM state from 4 to 0 using error sense key.

          Jul 08 11:00:06.147: vmx| TOOLS INSTALL entering BEGINNING state.

          Jul 08 11:00:06.156: vmx| TOOLS INSTALL Attempting image mount.

          Jul 08 11:00:06.156: vmx| TOOLS INSTALL using device 'ide0:0'.

          Jul 08 11:00:09.521: vcpu-0| CDROM: switching CDROM state from 1 to 3 using error sense key.

          Jul 08 11:00:09.904: vmx| TOOLS INSTALL entering INSERTED state.

          Jul 08 11:00:13.520: vcpu-0| CDROM: switching CDROM state from 3 to 4 using error sense key.

          Jul 08 11:00:17.520: vcpu-0| CDROM: switching CDROM state from 4 to 0 using error sense key.

          Jul 08 11:21:44.016: vmx| TOOLS INSTALL cancelling tools installation.

          Jul 08 11:21:44.017: vmx| TOOLS INSTALL entering ENDING state.

          Jul 08 11:21:45.530: vcpu-0| CDROM: switching CDROM state from 1 to 2 using error sense key.

          Jul 08 11:21:47.083: vmx| CDROM-LIN:  Implementing mediaChange workaround.

          Jul 08 11:21:47.107: vmx| TOOLS INSTALL entering IDLE state.

          Jul 08 11:21:53.528: vcpu-0| CDROM: switching CDROM state from 2 to 3 using error sense key.

          Jul 08 11:21:57.528: vcpu-0| CDROM: switching CDROM state from 3 to 4 using error sense key.

          Jul 08 11:22:01.529: vcpu-0| CDROM: switching CDROM state from 4 to 0 using error sense key.

          Jul 08 21:03:11.975: mks| SOCKET 7 recv error 5: Input/output error

          Jul 08 21:03:11.975: mks| SOCKET 7 destroying VNC backend on socket error: 5

           

           

          • 2. Re: VMware Tools won't mount or install
            The-GUINNESS Novice

             

            Hummm, Hard

             

             

            have you try, to remove CDROM drive in control panel of your guest W2K, and rebbot it, and try to mount again if the CDROM drive is come up on startup.

             

             

            By security, take a snapshop before operation

             

             

            Last solution, if the guest network work correctly, you can tranfert the ISO or the EXE in the Guest to install it.