4 Replies Latest reply on Jul 17, 2008 12:14 AM by saschab

    Suspend or Shutdown on Host Reboot

    captmiddy Enthusiast


      I have noticed that my virtual machines are not suspending or shutting down on host reboot.  I noticed that this seems to be a problem with the space in the directory path.  On Linux (Ubuntu Hardy 8.04 fully patched) I see an error on reboot about the directory not being found because it stops at "/var/lib/vmware/Virtual" when my paths are more like "/var/lib/vmware/Virtual Machines/testbuntu1/testbuntu1.vmx".  This seems to be a flaw in the design of the script to do shutdowns/suspends on system reboot or shutdown. 






      Does anyone know of a way to correct this problem ourselves as I have a machine that has to be rebooted fairly frequently and would like the virtual machines to do the right thing rather than just acting like their power cable was pulled out from under them. 






        • 1. Re: Suspend or Shutdown on Host Reboot
          Paul Thomas Master


          It sounds like you've found a bug - spaces in the directory name.  Is it worth renaming the directory, recreating the datastores and then adding the vms back into the inventory to see if that resolves the problem?



          I use vista as a host, and rc1 does seem better at the shutdown, however there is an issue where it seems the last machine to be suspended does not get enough time to complete its suspend before the host shuts down. I'm not sure if the same issue occurs with other hosts.



          • 2. Re: Suspend or Shutdown on Host Reboot

            I believe this bug has been caught and fixed internally.

            • 3. Re: Suspend or Shutdown on Host Reboot
              Peter_vm Guru
              rrdharan wrote:

              I believe this bug has been caught and fixed internally .

              So eventually fixed version will be available publicly ?

              • 4. Re: Suspend or Shutdown on Host Reboot
                saschab Lurker


                I've got a similar problem, but no errors about the directory not being found... machines simply don't suspend!!!



                I've eventually tracked it down to a problem in the /etc/init.d/vmware script, see the following output when I try to run the 'K' version to simulate a shutdown:






                root@vmserver:/etc/init.d# /etc/rc0.d/K08vmware stop

                Stopping VMware autostart virtual machines:

                   Virtual machines                                                    done

                Stopping VMware management services:

                   VMware Virtual Infrastructure Web Access

                   VMware Server Host Agent                                            done

                Stopping VMware services:

                   VMware Authentication Daemon                                        done

                Error: Malformed hostname parameter.  For the given service provider, the hostname must be a URL, in the form https://:/sdk



                At least one instance of VMware Server is still running.

                Please stop all running instances of VMware Server first.



                   VMware Authentication Daemon                                        done







                Any suggestions? Is this a bug?