3 Replies Latest reply on Jun 26, 2008 7:22 PM by Peter_vm

    Typical Memory Usage

    pjb3589 Lurker

       

      Hi all,

       

       

      I've been experimenting with virtualization on a Core 2 Quad box with 8GB of RAM. I have three VMs, one has a max of 2GB RAM, another is 3GB, and the third is 1.5GB. When I check the amount of memory being used, Windows Server 2008 always reports at least 88%. However, when I check the memory being used by each individual VM, its usually less than or around 1GB. Is this normal? I would assume yes if VMWare reserves the amount of physical RAM for each machine which the host sees as being used even if each VM isn't using its full amount, but I just want to confirm.

       

       

       

       

       

      Thanks

       

       

        • 1. Re: Typical Memory Usage
          Peter_vm Guru

          Many things can come to play, major ones are:

          1. Windows does not report memory usage for kernel processes directly. Some of memory used for VMs is allocated at kernel level.

          2. VMware does more sophisticated memory mamagement by default. But you can disable those optimizations for better overall performance.

          • 2. Re: Typical Memory Usage
            pjb3589 Lurker

            My host performance is under where I would like it to be as I am running VMWare on a primary domain controller (which I realize isn't recommended but this is in a lab environment). How can I disable some of the memory management optimizations?

            • 3. Re: Typical Memory Usage
              Peter_vm Guru

              For VMware Server 1.x they were:

               

              C:\Documents and Settings\All Users\Application Data\VMware\VMware Server\config.ini

              prefvmx.useRecommendedLockedMemSize = "TRUE"

              prefvmx.minVmMemPct = "100"

               

              guest ".vmx" file:

               

              sched.mem.pshare.enable = "FALSE"

              mainMem.useNamedFile = "FALSE"

              MemTrimRate = "0"

              MemAllowAutoScaleDown = "FALSE"