1 2 Previous Next 24 Replies Latest reply on Aug 8, 2008 12:56 PM by jj2mtn Go to original post
      • 15. Re: Problems with virtual networking
        ggonzalez45 Novice

         

        As you can see from the image when I dropdown VMNet4 or any orther unusued, I don't have "bridge" option, do I have to something before?

         

         

         

         

         

        • 16. Re: Problems with virtual networking
          John Brook Novice

           

          Hiya

           

           

          Sorry  wasn't clear. In that drop down, just select your network card (if you had more than 1 NIC, they would all appear, and you could choose which one to use).

           

           

          This is slightly different from the default VMNet0, where you are allowed to let VMWare decide which NIC to use. You can't do that with eg VMNet4. (If you click on the dropdown for VMNet0, you will see the network card in there, too).

           

           

           

           

           

          So that looks fine - just pick the network card and OK it.

           

           

          Cheers, John

           

           

          • 17. Re: Problems with virtual networking
            ID10T Novice

             

            Been tearing my hair out with the exact same problem for over a week now.

            setup as follows: -

            Hardware: Dell PowerEdge R200 with 2 Broadcom NetExtreme G/Bit NIC's

            Host: Windows 2003 R2 SP2 running VMWare Server 1.0.5 (was running 1.0.6)

                Role: 2 x NIC RRAS server

            Guest: Windows 2003 R2 SP2

                Role: 1 x NIC intranet web server

            The guest VM would have full network connectivity 1 day, then randomly loose connectivity with all other nodes on the LAN, restarting the guest didn't sort the problem, resarched the issue on VMWare communities and came up with a problem with the NIC's installed on the server in that the Broadcom NetExtreme NIC's must have the following options disabled in the driver advanced properties tab: -

            CheckSum Offload,

            Large Send Offload

            This appeared to initially corrected the problem, for a couple of days atleast, VMWare Server 1.0.6 update released upgraded fine, all still working, then random lost of guest network connectivity again, downgraded back to VMWare Server v1.0.5 everything worked again, went away happy, attempted to access the server and it's lost connectivity again. came accross a post on the web relating to the same problem though it was relating to NAT on the VMNet8 interface, it got me thinking... so disabled the option "Automatically choose an available physicall network adapter to bridge to VMNet0" from the Host - Virtual Network Settings - Automatic Bridging tab, and suddenly everything starts working again... Jobs-a-good-n!!!

             

             

            Hope that this helps someone else out.

             

             

            • 18. Re: Problems with virtual networking
              John Brook Novice

               

              Hiya

               

               

              That's interesting. Your solution has the same effect as my use of VMNet4, in that by using a custom switch I HAVE to select an actual NIC rather than allow VMWare to choose which card to use (as it does by default with VMNet0).

               

               

              I like your solution better though - fewer clicks! (By the way, my NICs and those of the OP are HPs rather than Broadcomms)

               

               

              Cheers, John

               

               

              • 19. Re: Problems with virtual networking
                ggonzalez45 Novice

                No luck, here you have images, maybe this can help. By the way, I put the IP address of the guest manually in the same rank of the host.

                • 20. Re: Problems with virtual networking
                  Peter_vm Guru

                  Disable Automatic Bridging in VMware Virtual Network Settings... and assign VMnets to physical NICs manually.

                  Then, in your guest hardware configuration editor, for Ethernet Adapter, use appropriate VMnet number.

                  Try to assign VMnet0 to active physical NIC.

                   

                  If VMware Bridge Protocol is not enabled in host OS NIC properties, enable it and use 0 for that bridge Vmnet.

                  • 21. Re: Problems with virtual networking
                    John Brook Novice

                     

                    Hiya

                     

                     

                    No dobt best to follow Peter's advice, he is the expert.

                     

                     

                    But looking at your screenshots, I have 2 questions:-

                     

                     

                    1) have you changed the VM guest settings so that it is using your new VMnet3?

                     

                     

                    2) the IP subnet for your VMNet3 looks more like a subnet mask - ave you got that right?

                     

                     

                    Cheers, John

                     

                     

                    • 22. Re: Problems with virtual networking
                      jj2mtn Novice

                       

                      I've been having problems with loosing network connectivity on VMNET0 for all VMs as soon as I try to add a printer in Vista Business Edition. I already set the:

                       

                       

                      CheckSum Offload - None

                      Large Send Offload - Disabled

                       

                       

                      And have already disabled the option in manage virtual networks to Automatically choose an available physical network adapter. I also explicitly assigned the physical adapter to the Host Virtual Network Adapter Tab for VMNet0.

                       

                       

                      My NIC is HP NC105i PCIe Gigabit Server Adapter

                       

                       

                      I can ping everything after reboot of the VMWARE Server and powering on the Vista VM. Then when I try to add a printer, the OS goes out to discover Printers, gets about 5 or 6 and then network connectivity drops. After this happens, all VM sessions no longer can connect to the network. All of my VMs use VMnet0 the rest of the VMnets are disabled. I can't seem to get past this problem.

                       

                       

                      Anybody got any ideas for me to try?

                       

                       

                      • 23. Re: Problems with virtual networking
                        John Brook Novice

                         

                        Hello there...

                         

                         

                        I would try setting up eg VMNet3 as a bridged network and use that instaed of VMNet0, and see if you still get the same problem.

                         

                         

                        Cheers, John

                         

                         

                        • 24. Re: Problems with virtual networking
                          jj2mtn Novice

                           

                          John,

                           

                           

                          Thanks for the reply. I'll try that next. I've noticed some other wierdness. When I get the dropout in Vista, my Network Connections on the server change to show the ethernet adapter as being disabled, but I can still ping from the server and can use WTS, etc just fine.

                           

                           

                          Also, the network adapter disappears from being selectable under Manage Virtual Networks wizard. I can't enable the network adapter and I have to reboot the server to recover from this state.

                           

                           

                          1 2 Previous Next