1 51 52 53 54 55 Previous Next 850 Replies Latest reply on Oct 1, 2019 12:48 PM by JasonHess Go to original post
      • 780. Re: ESX deployment appliance v1.05
        DennisBray Hot Shot
        vExpert

        I reimported the appliance. I updated the virtual hardware to VMware workstation 8. I reinstalled the VMware tools including the --clobber-kernel-modules=vmxnet and the error went away.

        I still couldn't ping and got a "network is unreachable" error. The ifconfig output looked odd, so I shutdown the VM, removed the nic, restarted the VM and removed all the entries in /etc/udev/rules.d/70-persistent-net.rules, then I shutdown the VM again, added a nic and all appears to be good.

        I changed a lot of things, so I don't have the pinpoint solution for remedying the issue. I could be as simple as updating the vmware tools and cleaning up the /etc/udev entries to remove "old" mac addresses...

         

        Dennis

        • 781. Re: ESX deployment appliance v1.05
          JCV Novice

          That did get the network connectivity up! Hope to test deployment soon

          Thanks again,

          Jon

          • 782. Re: ESX deployment appliance v1.05
            brugh Expert
            vExpert

            the appliance is packaged with the dev/rules.d cleared. if you deploy it, the first time it boots, it will regenerate these 70-* files in that directory.

            also, the installed VMware tools are compatible with the running kernel so you shouldn't need to reinstall them.

             

            removing the nic from the appliance however makes sense although it's the most annoying solution too because that means that workstation 9 creates incompatible OVF files. there were problems with the cdrom in earlier release for exactly this issue. seems the network adapter has the same issue.

            i posted a message on the WS9 community but it doesn't seem to have priority with somebody overthere. i need to do some further testing but as i said, i have limited facilities to check different environments. any help like DennisBray's tests are appreciated. at least there's a valid workaround although a lot of ppl don't go through the trouble. which is a shame ofcourse since deploying hosts with EDA only takes the typing of one name and a few minute wait

             

            on a sidenote; if you add a new network adapter you need to remove the files from udev/rules.d. if you don't, it will make the new adapter eth1 and the configuration scripts will fail.

            • 783. Re: ESX deployment appliance v1.05
              JCV Novice

              Having a new issue.

              I have been trying to deploy esxi hosts using a custom image (iso) I put together using the Powercli Image builder but kept getting the following error:

               

              Error loading /cd/esx/s.v00

              Fatal error: 10 (Out of resources)

               

              So I tried just using the base image from VMWare and I get the same failure error..... I have done some digging and I see people having this issue with bad images or iso's but I have tried 3 -4 different ones....they also were getting error code 6 or 8, not 10.

               

              I have tried adding more memory to the eda (6GB is were it is currently at) thinking it was having the issue, but that did not help. Hope some one might be able to give me a better clue as were to look.

              Hardware:

              HP BL-465c G7

              dual 10gb (CNA) nics

              196Gb mem

               

              By the way the custom images and VMWare iso installs just fine when using ilo's virtual drive.

               

              thanks for any clues!

              JV

               

              2012-10-10_1156.png

              • 784. Re: ESX deployment appliance v1.05
                wuytens201110141 Lurker

                Dear,

                 

                I am out the office until 12 Ocotber.

                 

                Your mail is not beeing forwarded.

                 

                For urgent matters you can try to reach me on my mobile phone.

                 

                kind regards

                • 785. Re: ESX deployment appliance v1.05
                  JCV Novice

                  I am trying to enable verbose logging for the tftp-hpa server to help me troubleshoot my issue and and not having very good luck. I have added the -vvvv option to the /etc/default/tftpd-hpa file, but still nothing. Maybe I am looking in the wrong place or there may be some other file I need to edit.

                  there used to be a daemon log in previous versions of the EDA but I can not find it anymore. Any suggestions?

                  thanks,

                  JV

                  • 786. Re: ESX deployment appliance v1.05
                    brugh Expert
                    vExpert

                    i think you have to add the -v option(s) to the /etc/default/tftpd-hpa config file. it should log to /var/log/tftpd.log

                     

                    the out of resources error is a tricky one. i don't think adding memory to the eda will help. eda is built on a 32bit version of ubuntu so adding more than 4gb won't do any good anyway. the point where the error occurs is when the pxe environment is loaded and the installer runs in this second pxe stage. for some reason it seems the installer runs out of memory. weird thing is, i run vmware and hp iso's all the time and don't have this issue. the s.v00 is by far the biggest file that needs transferring but it's just a file copy at this point. i would need to dive into this to see if tftpd or the installer can be told to use smaller chunks or something or perhaps bios settings or removing memory from the host at install may work for you. perhaps a different pxe (syslinux) version would help but again, i install in simular environments without issues.

                     

                    sorry i haven't gotten back to you earlier. i missed the vmware reminder that somebody replied to this topic. probably vmworld or vacation's fault

                    • 787. Re: ESX deployment appliance v1.05
                      buckmaster Hot Shot

                      Vacation today, back Tuesday

                      This message and attachment(s), if any, is intended for the sole use of the individual and/or entity for which it is addressed, and may contain information that is privileged, confidential and prohibited from disclosure under applicable law. If you are not the addressee, or authorized to receive this on behalf of the addressee, you are hereby notified that you may not use, copy, disclose or distribute to anyone this message or any part thereof. If you have received this in error, please immediately advise the sender by e-mail and delete this information and all attachments from your computer and network. Thank you.

                      • 788. Re: ESX deployment appliance v1.05
                        JCV Novice

                        No problem. Vacation ad VMWorld sound like more interesting. I did find the –v options for tftp-hpa and even have used wire shark to trace the packets to and from the eda…but have not found a reason for the installer error. I did build my own pxe server using the full blown ubuntu 64-bit server os and it makes it through the install without any issues. I’ll dig into the bios or using smaller chunks as well.

                        thanks for the hints.

                        • 789. Re: ESX deployment appliance v1.05
                          JasonHess Novice

                          Has anyone succesfully dual homed the EDA (management one 1 and the "build" network on another?  I managed to get a second nic configured, but after the inital blast of ESXi, it attempts to contact the "management" IP for the post install script(s).

                          I'm going to try and make the build network the primary one but still allow me to pull up the web interface on the managment one.  I doubt all features will work with what I ahve in mind though.

                           

                          thanks!

                          • 790. Re: ESX deployment appliance v1.05
                            brugh Expert
                            vExpert

                            the eda configures itself as the kickstart script home. you need to run the httpd on the deployment network as well as on the management network. easiest way to do that is to run the webserver on both interfaces and set deployment as first adapter. since it's built to do that anyway, i suspect if you add eth1 to /etc/network/interfaces on the management network, it should pretty much work the way you want.

                            • 791. Re: ESX deployment appliance v1.05
                              JasonHess Novice

                              I just ended up using 1 NIC instead.

                              My next issue though.. how can I set the esx vmk0 vlan id (from the EDA GUI.. I know how to do it manually of course).

                              I attempted to edit the code, but getting lost in the PHP.

                               

                              thanks,

                              Jason

                              • 792. Re: ESX deployment appliance v1.05
                                brugh Expert
                                vExpert

                                not sure why you'd want to change the php code (it's not very reader friendly ).

                                the vmk0 is connected to a portgroup and usually that portgroup gets the vlan tags. that command is in the script builder: esxcfg-vswitch -p "<portgroup name>" -v <VLAN_ID> <virtual switch name>

                                is your setup different? that usually works fine.

                                • 793. Re: ESX deployment appliance v1.05
                                  JasonHess Novice

                                  That would work I bet, but let me explain our situation and why I was hoping to change some things.

                                  We roll out 3-12 esxi hosts at a time several "builds" in a week (5-10.. each build is a 3-12 host build from scratch).

                                  The guy we had customizing the EDA left the company.  We have started a new line of product and having India tech support doing work over our (USA) night.  Instructing them to edit the text field on the right might be possible, but problematic at best.

                                   

                                  I was hoping to have a field on the left that had these additional fields (that change with each "build":

                                   

                                  1) management vlan#

                                  2) syslog server (if customer provided one)

                                  3) ntp server(s) (if customer provided one)

                                   

                                  Also, I tried to incorporate an NFS interface in the same section as the host ip and vmotion ip..

                                  I've pretty much just made a mess trying to ahck something together... wish our php guy had waited another month or 2 before leaving.

                                   

                                  thanks for any help you can offer.

                                  Jason

                                   

                                  p.s.  alternativly.. is there a way to change the color of the variables in the text area on the right?  Maybe I could just write up something that says "change the number in red to the customer's management vlan number", "change the number(s) in orange to the customer's NTP server(s)"

                                  ?

                                  • 794. Re: ESX deployment appliance v1.05
                                    brugh Expert
                                    vExpert

                                    i got the syslog and ntp settings question a couple of times before so i just did a quick test to see if something breaks if i (almost blindly) add them.

                                     

                                    5 minutes later the good news is that it works fine. i have an eda v1.06 now that has an ntp and syslog setting on the left.

                                    adding a management VLAN should be just as simple (if you know where to add it ). i'm not building that into the eda by default but here's a few hints:

                                     

                                    i have a few more things i wanted to add so you could wait for the next eda release that should be out soon. or you can add ntpserver and syslogserver the same way as described above.

                                     

                                    to add color to input boxes shouldn't be too hard to do. i use a 'row' function to display the various input lines. it takes 2 or 3 parameters where the 3rd optional will display a small hint if you hoover your mouse over the input box. if you change inc.php in /var/www/eda:

                                    • change line 34 and add '$color' as 4th argument
                                    • change line 36 after '<input' add ' style='background:$color'

                                    then in /var/www/eda/index.php at any line that has a 'row' function you could add a color 'lightblue', 'orange', whatever as 4th argument

                                    1 51 52 53 54 55 Previous Next